求救 :运行lumaqq时的问题,thx

为当前最终发行版之前的所有版本提供支持
回复
头像
kakaka
帖子: 82
注册时间: 2007-10-07 22:37
送出感谢: 0
接收感谢: 0

求救 :运行lumaqq时的问题,thx

#1

帖子 kakaka » 2007-11-04 14:22

Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/kakaka/test/LumaQQ/swt/libswt-pi-gtk-3218.so: /home/kakaka/test/LumaQQ/swt/libswt-pi-gtk-3218.so: wrong ELF class: ELFCLASS32
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1030)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:124)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:119)
请问,有什么方法解决吗?thx
回复

回到 “老旧版本支持”