当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu7.10环境编译2.6.23.1内核错误?
帖子发表于 : 2007-11-09 19:34 

注册: 2007-10-20 11:02
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我用make menuconfig错误提示如下 :
代码:
michael@michael:/usr/src/linux$ sudo make menuconfig
  HOSTCC  scripts/kconfig/lxdialog/checklist.o
在包含自 scripts/kconfig/lxdialog/checklist.c:24 的文件中:
scripts/kconfig/lxdialog/dialog.h:32:20: 错误: curses.h:No such file or directory
In file included from scripts/kconfig/lxdialog/checklist.c:24:
scripts/kconfig/lxdialog/dialog.h:97: 错误: expected specifier-qualifier-list before ‘chtype’
scripts/kconfig/lxdialog/dialog.h:187: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:194: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:196: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:197: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:198: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:199: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:201: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:31: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:59: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:95: 错误: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c: 在函数 ‘dialog_checklist’ 中:
scripts/kconfig/lxdialog/checklist.c:116: 错误: ‘WINDOW’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:116: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
scripts/kconfig/lxdialog/checklist.c:116: 错误: 所在的函数内只报告一次。)
scripts/kconfig/lxdialog/checklist.c:116: 错误: ‘dialog’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:116: 错误: ‘list’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:116: 警告: 逗号表达式的左操作数不起作用
scripts/kconfig/lxdialog/checklist.c:129: 警告: 隐式声明函数 ‘getmaxy’
scripts/kconfig/lxdialog/checklist.c:129: 错误: ‘stdscr’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:130: 错误: ‘KEY_MAX’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:131: 警告: 隐式声明函数 ‘getmaxx’
scripts/kconfig/lxdialog/checklist.c:137: 错误: ‘COLS’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:138: 错误: ‘LINES’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:140: 警告: 隐式声明函数 ‘draw_shadow’
scripts/kconfig/lxdialog/checklist.c:142: 警告: 隐式声明函数 ‘newwin’
scripts/kconfig/lxdialog/checklist.c:143: 警告: 隐式声明函数 ‘keypad’
scripts/kconfig/lxdialog/checklist.c:143: 错误: ‘TRUE’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:145: 警告: 隐式声明函数 ‘draw_box’
scripts/kconfig/lxdialog/checklist.c:146: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:146: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:147: 警告: 隐式声明函数 ‘wattrset’
scripts/kconfig/lxdialog/checklist.c:147: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:148: 警告: 隐式声明函数 ‘mvwaddch’
scripts/kconfig/lxdialog/checklist.c:150: 警告: 隐式声明函数 ‘waddch’
scripts/kconfig/lxdialog/checklist.c:151: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:154: 警告: 隐式声明函数 ‘print_title’
scripts/kconfig/lxdialog/checklist.c:156: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:157: 警告: 隐式声明函数 ‘print_autowrap’
scripts/kconfig/lxdialog/checklist.c:164: 警告: 隐式声明函数 ‘subwin’
scripts/kconfig/lxdialog/checklist.c:171: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:171: 错误: ‘struct dialog_color’ 没有名为 ‘atr’ 的成员
scripts/kconfig/lxdialog/checklist.c:189: 警告: 隐式声明函数 ‘print_item’
scripts/kconfig/lxdialog/checklist.c:192: 警告: 隐式声明函数 ‘print_arrows’
scripts/kconfig/lxdialog/checklist.c:195: 警告: 隐式声明函数 ‘print_buttons’
scripts/kconfig/lxdialog/checklist.c:197: 警告: 隐式声明函数 ‘wnoutrefresh’
scripts/kconfig/lxdialog/checklist.c:199: 警告: 隐式声明函数 ‘doupdate’
scripts/kconfig/lxdialog/checklist.c:202: 警告: 隐式声明函数 ‘wgetch’
scripts/kconfig/lxdialog/checklist.c:210: 错误: ‘KEY_UP’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:210: 错误: ‘KEY_DOWN’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:220: 错误: ‘FALSE’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:221: 警告: 隐式声明函数 ‘scrollok’
scripts/kconfig/lxdialog/checklist.c:222: 警告: 隐式声明函数 ‘wscrl’
scripts/kconfig/lxdialog/checklist.c:232: 警告: 隐式声明函数 ‘wrefresh’
scripts/kconfig/lxdialog/checklist.c:293: 警告: 隐式声明函数 ‘delwin’
scripts/kconfig/lxdialog/checklist.c:297: 错误: ‘KEY_LEFT’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:298: 错误: ‘KEY_RIGHT’ 未声明 (在此函数内第一次使用)
scripts/kconfig/lxdialog/checklist.c:310: 警告: 隐式声明函数 ‘on_key_esc’
scripts/kconfig/lxdialog/checklist.c:312: 错误: ‘KEY_RESIZE’ 未声明 (在此函数内第一次使用)
make[1]: *** [scripts/kconfig/lxdialog/checklist.o] 错误 1
make: *** [menuconfig] 错误 2

我问别人好像少lib包,可是有个叫什么包的怎么都装不上去?
好像什么依赖关系不满足。
求助......
我的QQ:422370121
[/code][/quote]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-09 20:30 

注册: 2007-10-31 13:09
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我用的make xconfig 没问题

只是现在 无线网卡还没装上 好像要把firmware放到什么地方 编译 模块 什么的 还在查。。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-09 23:29 
头像

注册: 2007-10-28 21:35
帖子: 1169
送出感谢: 0 次
接收感谢: 2
明显是没有curses库文件了。

用 sudo apt-cache search -n curses

有一个libcurses开头的,装了就ok了。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-10 9:17 

注册: 2007-10-20 11:02
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
yaska 写道:
明显是没有curses库文件了。

用 sudo apt-cache search -n curses

有一个libcurses开头的,装了就ok了。。

下列的软件包有不能满足的依赖关系:
libncurses5-dev: 依赖: libncurses5 (= 5.5-5ubuntu2) 但是 5.6+20070716-1ubuntu3 正要被安装
E: 无法安装的软件包
我无语,不知道这个什么东西??


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-10 9:19 

注册: 2007-10-20 11:02
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
代码:
michael@michael:~$  sudo apt-cache search -n curses
[sudo] password for michael:
evms-ncurses - Enterprise Volume Management System (ncurses UI)
lib64ncurses5 - Shared libraries for terminal handling (64-bit)
lib64ncurses5-dev - Developer's libraries for ncurses (64-bit)
libncurses5-dbg - Debugging/profiling libraries for ncurses
libncurses5-dev - Developer's libraries and docs for ncurses
libncursesw5-dbg - Debugging/profiling libraries for ncurses
libncursesw5-dev - Developer's libraries for ncursesw
libruby1.8 - Libraries necessary to run Ruby 1.8
ncurses-term - Additional terminal type definitions
irmp3-ncurses - irmp3 control frontend
libcurses-perl - Curses interface for Perl
libcurses-ruby - Curses interface for Ruby
libcurses-ui-perl - curses-based OO user interface framework for Perl
libcurses-widgets-perl - Curses widget interface for Perl
libncurses-ruby - ruby Extension for the ncurses C library
libncurses-ruby1.8 - ruby Extension for the ncurses C library
libncurses-ruby1.9 - ruby Extension for the ncurses C library
libncurses4 - Shared libraries for terminal handling
ncurses-hexedit - Edit files/disks in hex, ASCII and EBCDIC
pike7.6-pexts-curses - Pike (N)Curses module
pinentry-curses - curses-based PIN or pass-phrase entry dialog for GnuPG
weechat-curses - Fast, light and extensible IRC client
michael@michael:~$ sudo apt-get install libncursesw5 libncurses5 libncurses4 libncurses libncurses libncurses libcurses-widgets-perl libcurses-ui-perl libcurses-ruby libcurses-perl
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
libncursesw5 已经是最新的版本了。
libncurses5 已经是最新的版本了。widgets-perl libcurses-ui-perl libcurses-ruby libcurses-E: 无法找到软件包 libncurses
michael@michael:~$ sudo apt-get install libncurses5-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libncurses5-dev: 依赖: libncurses5 (= 5.5-5ubuntu2) 但是 5.6+20070716-1ubuntu3 正要被安装
E: 无法安装的软件包
michael@michael:~$


错误!!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-13 14:49 

注册: 2007-10-20 11:02
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
http://packages.ubuntu.com/
自己的问题自己解决,去这里可以下载


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译