当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 死机重启后就进不了系统了,请高手帮帮忙。
帖子发表于 : 2005-06-11 11:19 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我前几天已经升了linux-image-2.6.10-5-686 (2.6.10-34.1) to 2.6.10-34.2。幸运地,我可以安然无恙地进系统,并运行良好。

可今天,用着FF,突然FF自动退出,然后怎么启动FF都出不来,试启动终端也同样启动不了。于是注销。输入密码后,点击登陆后就没反应了,黑屏。按NumLock键没反应,应该是死机了。于是强行重启。

结果启动不了,提示错误:
引用:
Filesystem is not clean
Filesystem seems to have falal corruptions .Running with --rebuild-tree is requid.
fsck failde.Please repair manually and reboot .Please note that the root file system is currently mounted read-only.


应该用什么命令呢?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-06-11 12:00 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
还有,我记得我的386核心还在的,但在/boot/grub/menu.lst中注释了,现在在grub菜单中显示不出来,请问怎么在没进系统时编辑grub?或怎么能启动386核心?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-06-11 15:03 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
使用LiveCD盘进入,使用 fsck 检查并修复硬盘。


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-06-11 15:31 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
内核放在/boot里的吗?为何我升了只有一个内核?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-06-11 15:51 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
单纯的升级会自动删除旧的内核。


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-06-11 16:52 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
开什么玩笑!刚才ls一下,发现386的核心都没了。 :shock:
现在没法刻盘,没条件。SO,还有别的方法吗?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-06-11 17:02 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
使用安装盘启动,到分区时,切换到其他控制台,使用fsck 检查。


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-06-11 17:41 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
使用安装盘启动,到分区时,切换到其他控制台,使用fsck 检查。

愚笨了,还是不行。
到分区时,按alt+f2,输入fsck,说没这命令?
后面要加设备名不?比如分区:hda10


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-06-11 18:04 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
没有啊,你到/sbin 中找找看看有没有,实在没有的话,以只读挂载,也就是

#mount -ro /dev/hda1 /mnt
#cd /mnt
#chroot .
#fsck /dev/hda1


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-06-11 18:09 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
你的hda1是哪个盘?
是放了安装盘ISO的,还是装了Ubuntu的?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-06-11 18:20 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
你需要检查的Ubuntu的分区

你的原因是硬盘文件有损坏。需要检查和修复。


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-06-11 18:42 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
没有啊,你到/sbin 中找找看看有没有,实在没有的话,以只读挂载,也就是

#mount -ro /dev/hda1 /mnt
#cd /mnt
#chroot .
#fsck /dev/hda1


/sbin下有fsck.ext2,fsck.ext3,fsck.jfs。我的是reiserfs!

执行mount -ro /dev/hda10 /mnt提示:
cant find /mnt in /etc/fstab
于是执行mount -ro /dev/hda10 /dev
cd /dev
chroot
fsck /dev/hda10
提示仍是没这命令!

看来是分区格式的问题吧?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-06-11 18:48 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
不要挂载到/dev吧

没有/mnt 自己建立一个不就得了。

挂载上去chroot /mnt 后,再看看 /sbin/fsck.reiserfs 有没?如果还是没有,

必须要livecd了,如果有,运行修复之。

不过说实话,我不太喜欢 reiserfs ,我喜欢

/boot ext3 200M
/ jfs/xfs

这样来分区。这样坏的机会比较少一些。


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-06-11 18:55 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我没有单独/boot。如果这次不行,重装的话,考虑一下你的分区。呵呵。谢谢了。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-06-11 20:21 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
回复一下我刚才做的,并还没有搞定:
1。到分区时,按alt+f2
2。nano /etc/fstab  加上/mnt ,挂载/dev/hda10
3。mount -r /dev/hda10 /mnt (-ro不行)
4。cd /mount
5。chroot /mnt
6。fsck /dev/hda10 (按它提示加上 --rebuild-tree不行)

输入Yes后,检测开始
结束显示:
引用:
the problem in the internal node occured , whole sub tree is skipped finished

Comparing bitmaps.....Vpf-10640:the on-disk and the correct bitmaps differs

Bad nodes were found,Semantic pass skipped
6 found corruptions can be fixed only when running with --rebuild-tree


问题没解决。看来要用livecd了。我没有,所以打算重装吧。当然,如果哪位DX能有好方法也不妨不吝指教。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译