内核编译优化问题

为当前最终发行版之前的所有版本提供支持
回复
lf906415
帖子: 8
注册时间: 2007-10-18 17:43
送出感谢: 0
接收感谢: 0

内核编译优化问题

#1

帖子 lf906415 » 2007-11-14 11:46

各位大虾帮个忙(在线等)
我的CPU是t2450 2.0Ghz的,想优化内核,在终端输
sudo apt-get install linux-686-smp
但是提示找不到该软件,估计是源里没有,我用的cn99的源,哪位帮个忙贴个源给我(我的系统是ubuntu7.10,校园网,拜托给个大陆的源),另外我由于下不到,干脆自己编译内核,用的ubuntu方式,但是提示以下错误:

make[2]: *** 没有规则可以创建“arch/i386/kernel/asm-offsets.s”需要的目标“arch/i386/kernel/asm-offsets.c”。 停止。
make[1]: *** [prepare0] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14'
make: *** [debian/stamp-kernel-conf] 错误 2

我的编译步骤是:
#make clean
#make mrproper #我以前用其他方式编译过.
#cp /boot/config-`uname -r` ./.config
#make menuconfig
#make-kpkg clean
#fakeroot make-kpkg --initrd --append-to-version=-linux-2.6.22 kernel_image kernel_headers
lf906415
帖子: 8
注册时间: 2007-10-18 17:43
送出感谢: 0
接收感谢: 0

#2

帖子 lf906415 » 2007-11-14 11:54

没人顶,我自己先顶一下!
lf906415
帖子: 8
注册时间: 2007-10-18 17:43
送出感谢: 0
接收感谢: 0

#3

帖子 lf906415 » 2007-11-15 10:26

怎么光有人看,没人回复啊
shizhi1877
帖子: 8
注册时间: 2007-07-25 13:53
送出感谢: 0
接收感谢: 0
联系:

re:找不到linux-686-smp

#4

帖子 shizhi1877 » 2007-11-15 10:49

遇到同样问题,换了几个源都不行阿。
头像
wanzcong
帖子: 201
注册时间: 2007-08-23 3:52
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wanzcong » 2007-11-18 0:51

下载内核没有?可以先下载标准内核然后解压,编译的。
lf906415
帖子: 8
注册时间: 2007-10-18 17:43
送出感谢: 0
接收感谢: 0

#6

帖子 lf906415 » 2007-11-21 12:22

下了,就是这个结果
mech
帖子: 466
注册时间: 2007-09-06 16:07
送出感谢: 0
接收感谢: 0

#7

帖子 mech » 2007-11-21 13:49

sudo apt-get install kernel-package
make clean
make menuconfig
fakeroot make-kpkg --append-to-version=.123456 kernel_image --initrd binary
dpkg -i kernel-image-xxx.deb

这是我做的

p.s. kernel 2.6.23.8 从kernel.org下载的
wenda
帖子: 56
注册时间: 2007-03-27 12:29
送出感谢: 0
接收感谢: 0

#8

帖子 wenda » 2007-11-30 16:10

wanzcong
你的图片是哪里照的,是湖农的校友吗。
扫描仪microtek x9800不能驱动;
cad格式qcad不支持;
其余都在ubuntu下面搞定。
头像
seabee
帖子: 243
注册时间: 2006-11-08 13:02
送出感谢: 1 次
接收感谢: 0

#9

帖子 seabee » 2007-12-01 16:48

我也碰上了一样的问题,
make[1]: *** No rule to make target `arch/i386/kernel/asm-offsets.c', needed by `arch/i386/kernel/asm-offsets.s'. Stop.
make: *** [prepare0] Error 2

请问怎么办??? :oops:
简简单单的生活,自自然然的我~www.3gcomet.com
wenda
帖子: 56
注册时间: 2007-03-27 12:29
送出感谢: 0
接收感谢: 0

#10

帖子 wenda » 2007-12-02 20:56

我编译成功了,启动选项也有了,就是进不去,编译内核可真是一个苦力活,眼睛受罪了,为了那么一点点性能的提升不值得,系统跑的很顺畅,谁叫我是爱折腾的人,以后再也不编译了。
扫描仪microtek x9800不能驱动;
cad格式qcad不支持;
其余都在ubuntu下面搞定。
头像
seabee
帖子: 243
注册时间: 2006-11-08 13:02
送出感谢: 1 次
接收感谢: 0

#11

帖子 seabee » 2007-12-03 9:46

wenda 写了:我编译成功了,启动选项也有了,就是进不去,编译内核可真是一个苦力活,眼睛受罪了,为了那么一点点性能的提升不值得,系统跑的很顺畅,谁叫我是爱折腾的人,以后再也不编译了。


请问知道怎么解决 asm-offset.c 的问题吗?
简简单单的生活,自自然然的我~www.3gcomet.com
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

#12

帖子 hubert_star » 2007-12-03 10:20

2.6.22没有专门的smp内核,默认是开启了smp支持的。

还有就是搂住去官方wiki看一下怎么编译ubuntu的内核,首先需要装source,然后是附加驱动,还要有对应的配置文件和工具,有的你忙的。我编译的官方内核不认我的无线网卡,没有特殊需要尽量不要编译内核,现在不是kernel 2.2了,到你升级的时候麻烦。
oiniya
帖子: 256
注册时间: 2007-07-26 15:07
送出感谢: 0
接收感谢: 0

#13

帖子 oiniya » 2007-12-03 10:37

完全应该用gentoo
wenda
帖子: 56
注册时间: 2007-03-27 12:29
送出感谢: 0
接收感谢: 0

#14

帖子 wenda » 2007-12-03 11:05

seabee 写了:
wenda 写了:我编译成功了,启动选项也有了,就是进不去,编译内核可真是一个苦力活,眼睛受罪了,为了那么一点点性能的提升不值得,系统跑的很顺畅,谁叫我是爱折腾的人,以后再也不编译了。


请问知道怎么解决 asm-offset.c 的问题吗?


不好意思阿,我是个菜鸟,也是按照鸟哥的私房菜上讲的做的,你可以搜索一下鸟哥的私房菜。
扫描仪microtek x9800不能驱动;
cad格式qcad不支持;
其余都在ubuntu下面搞定。
fengson_xie
帖子: 12
注册时间: 2008-03-21 15:59
送出感谢: 0
接收感谢: 0

#15

帖子 fengson_xie » 2008-05-14 23:15

wenda 写了:
seabee 写了:
wenda 写了:我编译成功了,启动选项也有了,就是进不去,编译内核可真是一个苦力活,眼睛受罪了,为了那么一点点性能的提升不值得,系统跑的很顺畅,谁叫我是爱折腾的人,以后再也不编译了。


请问知道怎么解决 asm-offset.c 的问题吗?


不好意思阿,我是个菜鸟,也是按照上讲的做的,你可以搜索一下鸟哥的私房菜。



对,他的书比较适合入门,里面也有讲到这一章,你可以上GOUGOU搜一下,书名叫鸟哥的私房菜基础学习篇
回复

回到 “老旧版本支持”