[问题]在编译安装最新版本vim的时候遇到问题求救!哪个包里有terminal library?[已解决]

为当前最终发行版之前的所有版本提供支持
回复
cyberghost
帖子: 15
注册时间: 2007-02-02 17:19
送出感谢: 0
接收感谢: 0

[问题]在编译安装最新版本vim的时候遇到问题求救!哪个包里有terminal library?[已解决]

#1

帖子 cyberghost » 2007-11-18 11:36

如题,在编译vim的时候congfig过不了:

checking --with-tlib argument... empty: automatic terminal library selection
checking for tgetent in -lncurses... no
checking for tgetent in -ltermlib... no
checking for tgetent in -ltermcap... no
checking for tgetent in -lcurses... no
no terminal library found
checking for tgetent()... configure: error: NOT FOUND!
You need to install a terminal library; for example ncurses.
Or specify the name of the library with --with-tlib.

我该上哪里去找terminal library? 哪个包里面有?
上次由 cyberghost 在 2007-11-18 12:00,总共编辑 1 次。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-11-18 11:39

1. 删掉你下载的vim
2.
sudo apt-get update
sudo apt-get install vim-full
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
cyberghost
帖子: 15
注册时间: 2007-02-02 17:19
送出感谢: 0
接收感谢: 0

问题解决了!如大虾所言,非常感谢!

#3

帖子 cyberghost » 2007-11-18 11:59

如题目!万分感谢!
头像
hatoyu
帖子: 171
注册时间: 2006-03-16 10:20
来自: http://www.adelaidecartridge.com
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 hatoyu » 2008-06-27 14:52

上面2楼的 那样安装要安装gtk的
回复

回到 “老旧版本支持”