昨天更新了系统后,再更新不了拉,安装也不行了,有下面提示,高手们告诉我怎么解决?

为当前最终发行版之前的所有版本提供支持
tanyongliang
帖子: 91
注册时间: 2006-07-17 14:36
来自: 黑龙江
送出感谢: 0
接收感谢: 0
联系:

昨天更新了系统后,再更新不了拉,安装也不行了,有下面提示,高手们告诉我怎么解决?

#1

帖子 tanyongliang » 2007-11-20 18:33

tanyongliang@tanyongliang:~$ sudo apt-get install mplayer
[sudo] password for tanyongliang:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
mplayer 已经是最新的版本了。
mplayer 设定为手动安装.
已经不需要下列自动安装的软件包:
libstdc++5 libgmp3c2 gcc-3.3-base
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 tzdata (2007i-0ubuntu0.7.04) ...
Running 'tzconfig' to set this system's timezone.
/var/lib/dpkg/info/tzdata.postinst: line 27: /usr/sbin/tzconfig: No such file or directory
dpkg:处理 tzdata (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)
tanyongliang@tanyongliang:~$
amoooo
帖子: 22
注册时间: 2007-11-12 17:42
送出感谢: 0
接收感谢: 0

#2

帖子 amoooo » 2007-11-21 9:10

我也是这样,然后我安装alien的时候也有同样提示,不会以后都没法安装软件吧。提示如下:
amoo@amoo-laptop:~$ sudo apt-get install alien
[sudo] password for amoo:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
debhelper html2text intltool-debian libbeecrypt6 libneon25 librpm4
po-debconf rpm
建议安装的软件包:
lsb-rpm lintian dh-make
推荐安装的软件包:
libmail-sendmail-perl libcompress-zlib-perl
下列【新】软件包将被安装:
alien debhelper html2text intltool-debian libbeecrypt6 libneon25 librpm4
po-debconf rpm
共升级了 0 个软件包,新安装了 9 个软件包,要卸载 0 个软件包,有 9 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 2676kB 的软件包。
解压缩后会消耗掉 8520kB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://cn.archive.ubuntu.com gutsy/main html2text 1.3.2a-3build1 [90.6kB]
获取:2 http://cn.archive.ubuntu.com gutsy/main intltool-debian 0.35.0+20060710.1 [31.6kB]
获取:3 http://cn.archive.ubuntu.com gutsy/main po-debconf 1.0.9 [117kB]
获取:4 http://cn.archive.ubuntu.com gutsy/main debhelper 5.0.51ubuntu3 [526kB]
获取:5 http://cn.archive.ubuntu.com gutsy/main libbeecrypt6 4.1.2-6build1 [108kB]
获取:6 http://cn.archive.ubuntu.com gutsy/main libneon25 0.25.5.dfsg-6build1 [103kB]
获取:7 http://cn.archive.ubuntu.com gutsy/main librpm4 4.4.1-14.1ubuntu2 [991kB]
获取:8 http://cn.archive.ubuntu.com gutsy/main rpm 4.4.1-14.1ubuntu2 [603kB]
获取:9 http://cn.archive.ubuntu.com gutsy/main alien 8.68 [104kB]
下载 2676kB,耗时 23s (112kB/s)
正在设置 tzdata (2007i-0ubuntu0.7.04) ...
Running 'tzconfig' to set this system's timezone.
/var/lib/dpkg/info/tzdata.postinst: line 27: /usr/sbin/tzconfig: No such file or directory
dpkg:处理 tzdata (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)
amoo@amoo-laptop:~$
starboys
帖子: 132
注册时间: 2007-06-30 20:33
送出感谢: 0
接收感谢: 0

#3

帖子 starboys » 2007-11-21 9:33

试试
sudo apt-get install -f
amoooo
帖子: 22
注册时间: 2007-11-12 17:42
送出感谢: 0
接收感谢: 0

#4

帖子 amoooo » 2007-11-21 9:35

还是一样的错误

amoo@amoo-laptop:/usr/sbin$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 9 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 tzdata (2007i-0ubuntu0.7.04) ...
Running 'tzconfig' to set this system's timezone.
/var/lib/dpkg/info/tzdata.postinst: line 27: /usr/sbin/tzconfig: No such file or directory
dpkg:处理 tzdata (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)
tanyongliang
帖子: 91
注册时间: 2006-07-17 14:36
来自: 黑龙江
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 tanyongliang » 2007-11-21 10:40

想来想去还是核心代码可能出了问题了,
我想找到那个核心代码,手工改一下
amoooo
帖子: 22
注册时间: 2007-11-12 17:42
送出感谢: 0
接收感谢: 0

#6

帖子 amoooo » 2007-11-21 10:48

我觉得是那个tzconfig文件不存在造成的,我也看了我的sbin目录中也确实没有那个文件。不知怎么回事。是否可以从其他系统拷贝一个过来?
tanyongliang
帖子: 91
注册时间: 2006-07-17 14:36
来自: 黑龙江
送出感谢: 0
接收感谢: 0
联系:

问题已经解决

#7

帖子 tanyongliang » 2007-11-21 11:49

我在论坛上问了,高人指点终于好了,就是把
/var/lib/dpkg/info/tzdata.postinst 删了 重新 apt-get update
amoooo
帖子: 22
注册时间: 2007-11-12 17:42
送出感谢: 0
接收感谢: 0

#8

帖子 amoooo » 2007-11-21 11:55

果然好了,多谢ls !!
tanyongliang
帖子: 91
注册时间: 2006-07-17 14:36
来自: 黑龙江
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 tanyongliang » 2007-11-21 12:24

哈哈,好了就行,我还要谢谢那个高手
free-of-linux
帖子: 221
注册时间: 2007-11-08 18:19
送出感谢: 0
接收感谢: 1 次

#10

帖子 free-of-linux » 2007-11-21 19:24

用dpkg -i 试试
tmx_cn2
帖子: 2
注册时间: 2007-11-21 20:41
送出感谢: 0
接收感谢: 0

#11

帖子 tmx_cn2 » 2007-11-21 20:43

哈哈,问题解决了。高手就是高手,我都打算重装了。谢谢。 :wink:
kelvinyuliang
帖子: 25
注册时间: 2007-10-31 14:18
送出感谢: 0
接收感谢: 0

#12

帖子 kelvinyuliang » 2007-11-22 9:44

我也用这个方法搞定了。多谢!
duanyong
帖子: 73
注册时间: 2007-05-17 9:38
送出感谢: 0
接收感谢: 0

#13

帖子 duanyong » 2007-11-22 17:29

下载 2676kB,耗时 23s (112kB/s)

兄弟,你的速度也太快了吧.
amoooo
帖子: 22
注册时间: 2007-11-12 17:42
送出感谢: 0
接收感谢: 0

#14

帖子 amoooo » 2007-11-22 17:47

还不算最快,有时可以达到300k/s。嘿嘿
DrummerRAY
帖子: 1
注册时间: 2007-11-07 12:52
送出感谢: 0
接收感谢: 0

#15

帖子 DrummerRAY » 2007-11-24 1:50

我按照7楼的作法,问题解决了~
回复

回到 “老旧版本支持”