怎样删除旧版的glib

为当前最终发行版之前的所有版本提供支持
回复
fanggai
帖子: 3
注册时间: 2007-10-24 23:31
送出感谢: 0
接收感谢: 0

怎样删除旧版的glib

#1

帖子 fanggai » 2007-11-20 22:09

问题如题:./configure时出错
#./configure 的提示
checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.5.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
回复

回到 “老旧版本支持”