新手求助,无法更新软件包源

为当前最终发行版之前的所有版本提供支持
回复
tondo
帖子: 3
注册时间: 2006-01-22 1:07
送出感谢: 0
接收感谢: 0

新手求助,无法更新软件包源

#1

帖子 tondo » 2006-01-22 1:15

我是菜鸟,我按照一篇教程修改
sudo gedit /etc/apt/sources.list
删除原有文本中的软件源,再添加:
deb http://cn.archive.ubuntu.com/ubuntu breezy main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu breezy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu breezy-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu warty main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu warty-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu warty-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu breezy main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu breezy-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu breezy-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn ubuntu.org.cn main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted

可是一直出现这个错误,不知道怎么回事
tondo@ubuntu:~$ sudo apt-get update
E: Could not get lock /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the list directory

不管执行什么包括install,都出现这个,无法执行
上次由 tondo 在 2006-01-22 1:31,总共编辑 1 次。
tondo
帖子: 3
注册时间: 2006-01-22 1:07
送出感谢: 0
接收感谢: 0

#2

帖子 tondo » 2006-01-22 1:29

还有每次执行 gedit的时候都不出现这个提示


tondo@ubuntu:~$ sudo gedit /etc/X11/xorg.conf

(gedit:7706): Gdk-WARNING **: locale not supported by Xlib

(gedit:7706): Gdk-WARNING **: cannot set locale modifiers
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

Re: 新手求助,无法更新软件包源

#3

帖子 Tenyears » 2006-01-22 9:51

tondo 写了: E: Could not get lock /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the list directory
同时开了新立得?
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 dongmh » 2006-01-22 10:20

tondo 写了:还有每次执行 gedit的时候都不出现这个提示


tondo@ubuntu:~$ sudo gedit /etc/X11/xorg.conf

(gedit:7706): Gdk-WARNING **: locale not supported by Xlib

(gedit:7706): Gdk-WARNING **: cannot set locale modifiers
不出现是什么意思? 这个提示是说你的locale不受支持 可以不用关
你的源添加有误 只要添加breezy的源就可以了
不要同时开着两个apt或者开个apt又开个新立德
ubuntu 6.06
我是初学者 大家多多关照
tondo
帖子: 3
注册时间: 2006-01-22 1:07
送出感谢: 0
接收感谢: 0

#5

帖子 tondo » 2006-01-22 12:25

谢谢高手答复,我是按照那片教程改的,有这方面的资料吗??或者有没有完整的sources.list文件给我,我想可能改错了

PS:前面的字打错了
头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 dongmh » 2006-01-23 10:52

ubuntu 6.06
我是初学者 大家多多关照
回复

回到 “老旧版本支持”