[问题]安装apt、Grub和Lilo均出现错误

为当前最终发行版之前的所有版本提供支持
回复
笑行者
帖子: 26
注册时间: 2005-06-13 11:55
来自: 路上
送出感谢: 0
接收感谢: 0
联系:

[问题]安装apt、Grub和Lilo均出现错误

#1

帖子 笑行者 » 2005-06-13 12:00

安装apt、Grub和Lilo均出现错误,无法安装,第一阶段结束重启后显示的是Windows启动菜单,如何进入Ubuntu继续安装?
我是硬盘安装的,求救,谢谢!
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 firehare » 2005-06-13 12:32

请参见本站的文档,上面讲得很清楚呀!
根据文档一步步来做,一般不会出现你所说的情况!

另:
如果还是有问题
请详细描述你的现象!
我心无畏,源自于我心无知。
图片
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#3

帖子 lyreopera » 2005-06-13 12:37

我也有这问题,但是我是用cd装的,搞不懂!
……
笑行者
帖子: 26
注册时间: 2005-06-13 11:55
来自: 路上
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 笑行者 » 2005-06-13 12:42

严格按照文档中关于硬盘安装的介绍做的啊
头像
oneleaf
论坛管理员
帖子: 10207
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#5

帖子 oneleaf » 2005-06-13 13:43

使用liveCD 启动后使用 grub-install /dev/hda 手工安装

安装完毕后再使用 update-grub ,更新一下列表试试。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
笑行者
帖子: 26
注册时间: 2005-06-13 11:55
来自: 路上
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 笑行者 » 2005-06-13 13:44

但是为什么安装 apt 和 Lilo 都出错?
头像
oneleaf
论坛管理员
帖子: 10207
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#7

帖子 oneleaf » 2005-06-13 13:51

grub 不是支持所有的分区,例如/boot区在xfs或jfs上就不支持。

有时候如果你使用两个以上硬盘,而使用从第二个盘启动时,也会出现安装不上去的问题。

lilo 也是如此。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
笑行者
帖子: 26
注册时间: 2005-06-13 11:55
来自: 路上
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 笑行者 » 2005-06-13 15:52

问题解决了,出人意料。第一次安装时到创建用户的时候我嫌密码太麻烦就没有输入密码,它提示必须输入密码,我就中断回到那个安装进程列表跳过创建用户直接进行下一步安装,就出现错误。
后来我试着在创建用户时输入密码,一切似乎又正常了,匪夷所思。
感谢楼上的所有人!

另外有个问题,Ubuntu里多余的PPPoE连接如何删除?因为我执行了2次pppoeconf,所以现在有ppp0和ppp1两个连接了。
还有,pppoeconf里面那几个提示都是什么意思?我设置好后只能登陆Mozilla和新华网等网站,Google和Ubuntu.org.cn无法登陆,求解,谢谢!
笑行者
帖子: 26
注册时间: 2005-06-13 11:55
来自: 路上
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 笑行者 » 2005-06-13 22:13

一切都好了
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 yongyi » 2005-06-13 22:21

可以说说你的解决方法,方便后来的兄弟。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
笑行者
帖子: 26
注册时间: 2005-06-13 11:55
来自: 路上
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 笑行者 » 2005-06-13 22:30

重启了一次,一切都好了
对于pppoeconf,里面的一些提示是有用的,比如 pon dsl-provider 和 poff 就是两个很有用的命令
回复

回到 “老旧版本支持”