Xlib错误?xserver 授权?这个毛病是什么问题阿?

为当前最终发行版之前的所有版本提供支持
回复
头像
baoshaojing
帖子: 85
注册时间: 2007-05-30 9:23
送出感谢: 0
接收感谢: 0
联系:

Xlib错误?xserver 授权?这个毛病是什么问题阿?

#1

帖子 baoshaojing » 2007-12-04 11:39

修改源的时候,用gedit就会有这个错误提示,大虾告诉我什么意思阿?

root@bao-laptop:/etc/apt# gedit sources.list
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

cannot open display:
运行“gedit --help”可查看可用的命令行选项的全部列表。

有人说是xserver 授权问题,不知道对不对。
上次由 baoshaojing 在 2007-12-04 12:00,总共编辑 1 次。
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#2

帖子 windwiny » 2007-12-04 11:59

退出root,用登陆用户 sudo gedit
头像
baoshaojing
帖子: 85
注册时间: 2007-05-30 9:23
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 baoshaojing » 2007-12-04 12:03

windwiny 写了:退出root,用登陆用户 sudo gedit



呵呵,是的。看来应该是xserver授权的问题。root不能进入x,对吧。

怎么设置,让root能够进入x呢。
回复

回到 “老旧版本支持”