今天系统自动升级后,Firefox 等软件变得容易崩溃

为当前最终发行版之前的所有版本提供支持
回复
头像
patrickhe
帖子: 681
注册时间: 2005-07-21 19:13
来自: Peking, China
送出感谢: 0
接收感谢: 0
联系:

今天系统自动升级后,Firefox 等软件变得容易崩溃

#1

帖子 patrickhe » 2007-12-08 18:08

今天启动系统后,系统提升有新的 package 可以升级。升级项目中包括 Firefox 2.0.0.11。
升级完毕之后,重启 Firefox,已经更新到 2.0.0.11,很完美。:D
随便打开一个网页,Firefox 立即退出…… :o
尝试多次之后,发现打开英文网页的话,Firefox 能够正常浏览,打开百度首页等少数几个中文页面也可以正常浏览——但是进入百度搜索页面就不行,而 Google 搜索页面即使包含很多中文字符也可以正常浏览。于是怀疑升级的 2.0.0.11 是有问题的,使用 apt 降级回到 2.0.0.10,发现问题依旧…… :em18
又发现 Audacious 也不能启动了 :shock:
检查了一下 Thunderbird、Sunbird,都可以正常浏览中文邮件或者中文日程安排,可以排除是 Mozilla 的基础组件的问题。再检查了一下 OpenOffice、Acrobat Reader、gedit 等软件,也可以正常处理中文,于是排除系统的中文字体处理的问题。下面该怎么办呢?:em30
总不能这样就重装系统吧?!!!咱 Linux 系统不至于搞得像 Windows 那样,出了点问题就靠重装来解决吧???!!! :em72
我在升级之前,看来一下有哪些项目可以升级,还记得其中一个 package 是和二维矢量图形有关的 lib。但是因为升级的东西不少,现在也不记得升级的是哪些 package 了。Google 了一下,找到 yum 的 log 的位置,类似地推断出 apt 的 log 文件存放处,在 /var/log/apt 下。看了一下 term.log,发现内容有点多。于是用
apt-cache depends
命令查了一下 firefox 和 audacious 各自的依赖包,发现刚才升级的 libcairo2 是这两个软件所共同依赖的包之一,在 term.log 查到也是刚才升级的包之一。用
apt-cache show
看了一下 libcairo2 的描述,确实就是哪个和二维图形处理有关的包。于是尝试将 libcairo2 降级安装。再打开 firefox 和 audacious,恢复正常~~~ :em76
头像
magicsky
帖子: 225
注册时间: 2007-03-30 9:46
送出感谢: 1 次
接收感谢: 0

#2

帖子 magicsky » 2007-12-08 22:55

我也遇到过,我的解决办法是删除~/.mozila/firefox/**/prefs.js这个文件,就是删除了配置文件,所以慎用阿,呵呵,不过的确能解决自动跳出的问题
在国外,众多程序员为了理想而夜以继日;
而在国内,程序员在为填饱自己和家人的肚子而埋头苦干。
头像
patrickhe
帖子: 681
注册时间: 2005-07-21 19:13
来自: Peking, China
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 patrickhe » 2007-12-09 15:37

我尝试过删除 Firefox 的配置文件,连 .mozilla/firefox 目录都删除了,还是出现一样的问题。而且 audacious 也同样崩溃。可以知道咱们遇到的是有同样现象的不同问题,呵呵。希望这些方法对遇到同样问题的朋友有些帮助。
fengyione
帖子: 11
注册时间: 2007-12-09 12:24
送出感谢: 0
接收感谢: 0

#4

帖子 fengyione » 2007-12-09 16:24

libcairo2 降级安装
是初学者,安装的时候都是在网上找个命令照着干,能不能写个命令给我啊,怎么降级安装啊?
头像
patrickhe
帖子: 681
注册时间: 2005-07-21 19:13
来自: Peking, China
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 patrickhe » 2007-12-09 22:27

fengyione 写了:libcairo2 降级安装
是初学者,安装的时候都是在网上找个命令照着干,能不能写个命令给我啊,怎么降级安装啊?


代码: 全选

sudo apt-get install libcairo2=1.4.10-1ubuntu4
netspiderman
帖子: 2
注册时间: 2007-12-06 12:35
送出感谢: 0
接收感谢: 0

#6

帖子 netspiderman » 2007-12-10 12:31

4楼 5楼正确。
或用此包安装。
附件
libcairo2_1.4.10-1ubuntu4_i386.deb
(510.76 KiB) 下载 25 次
1987
帖子: 62
注册时间: 2007-12-09 0:14
送出感谢: 0
接收感谢: 0

#7

帖子 1987 » 2007-12-10 12:44

我装的firefox2.0.0.11
设置字体为wenquanyi字体后浏览器会自己关闭
没办法
卸载了那字体
hujy
帖子: 218
注册时间: 2006-05-25 10:13
来自: 明州
送出感谢: 0
接收感谢: 0

#8

帖子 hujy » 2007-12-10 13:04

兄弟总结的真及时,今日升级后确实很不稳定,连新立得和panel也常崩溃,试试你的方法。
sp_hawk
帖子: 38
注册时间: 2007-04-18 23:51
送出感谢: 0
接收感谢: 0

#9

帖子 sp_hawk » 2007-12-10 13:21

我的也是啊,用的是cn99的源,不仅仅firefox,连新立得也动不动就崩溃啊,晕死,不是说linux稳定吗?现在是一碰就倒
头像
ciel-bleu
帖子: 173
注册时间: 2007-12-03 16:02
送出感谢: 0
接收感谢: 0

#10

帖子 ciel-bleu » 2007-12-10 22:36

偶怎么没事?难道偶人品好? :shock:
头像
hnzksq
帖子: 473
注册时间: 2007-07-11 16:21
来自: 火星
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 hnzksq » 2007-12-10 23:56

这个什么意思啊?今天更新的时候出现的问题。
附件
Screenshot-11.png
------
“不要揣测神的心,我的孩子,”老头子的声音仿佛梦呓,“神的胸膛里没有心,那只是一块铁石。”
回复

回到 “老旧版本支持”