请教关于内核升级的问题

为当前最终发行版之前的所有版本提供支持
回复
头像
liupingjing
帖子: 451
注册时间: 2007-11-29 17:31
送出感谢: 0
接收感谢: 0
联系:

请教关于内核升级的问题

#1

帖子 liupingjing » 2007-12-11 20:17

安装ubuntu有两周多了,期间更新了几次,现在发现grub启动菜单里第一个是i386版本的,下面的才是generic版本(安装时的版本),为什么升级时会从generic升级到i386呢,我的电脑是amd64的,是不是generic的更好一些,
另外,还有点小问题,发现根目录下多了几个链接文件,有一个是vmlinuz,这些文件是怎么生成的呢,为什么直接生成在根目录下,有点想不通
有知道的麻烦给小弟解释一下,谢谢了
store88
帖子: 109
注册时间: 2005-10-15 0:30
来自: China
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 store88 » 2007-12-11 20:57

据我推测 你的应该是在新立得里面安装的
底层是deb管理包

不过如果不妨碍使用 就放着吧
对性能的影响无足轻重

如果你想搞明白 可以自己编译一下内核
www.kernel.org下载源代码 自己编译一下
不管你编译成功还是失败 在编译的过程中你自己会去寻找到答案
你会很清楚怎么生成的

第一次 我花了3天(不断的失败又失败)才编译好一个内核 很痛苦的过程
不过成功后的成就感^_^。。。。。。

不管怎么说 个人感觉性能上的提升没有多少价值
要想了解必须要有代价
头像
liupingjing
帖子: 451
注册时间: 2007-11-29 17:31
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 liupingjing » 2007-12-11 21:05

恩, 多谢回答,这周要考试了,下周编译,如果只求能用就不会从windows转到linux了
对了,再麻烦您一下,我编译的时候可不可以直接编译amd64版本的,i386和amd64到底有多大区别呢
回复

回到 “老旧版本支持”