7.10安装问题……

为当前最终发行版之前的所有版本提供支持
回复
neo9999
帖子: 3
注册时间: 2007-12-11 22:52
送出感谢: 0
接收感谢: 0

7.10安装问题……

#1

帖子 neo9999 » 2007-12-12 0:22

7.10跟xp组双系统,装好后发现grub报错 grub 1.5 error 18,参考了官方对这个错误的解释:
18 : "Invalid or unsupported executable format"
This error is returned if the kernel image boing loaded is not recognized as Multiboot or one of the supported native formats (Linux zImage or bzImage, FreeBSD, or NetBSD).
还是搞不懂,参考了网上的做法:(我安在(hd0,8))
root (hd0,8)
setup(hd0)
boot
界面已经说是suceed了,但重启还是不成……希望高手们支招。另:以前装过6.10,一次安装就成功了,可惜卸载了。
neo9999
帖子: 3
注册时间: 2007-12-11 22:52
送出感谢: 0
接收感谢: 0

#2

帖子 neo9999 » 2007-12-15 10:16

有没有人能帮我啊?
头像
TeliuTe
论坛版主
帖子: 7392
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 29 次
接收感谢: 95 次
联系:

#3

帖子 TeliuTe » 2007-12-16 1:35

一般先装XP,然后安装ubuntu会自动安装好grub

找到menu.lst文件里头的启动项,
在grub里头照着依次运行一下root、kernel、initrd看看错误提示是什么
头像
晶晶守护神
帖子: 705
注册时间: 2007-12-02 14:09
送出感谢: 0
接收感谢: 0

#4

帖子 晶晶守护神 » 2007-12-16 1:37

视乎是kernel不被 引导支持。。。楼主什么磁盘分区 编译进内核了吗
neo9999
帖子: 3
注册时间: 2007-12-11 22:52
送出感谢: 0
接收感谢: 0

#5

帖子 neo9999 » 2007-12-16 12:23

晶晶守护神 写了:视乎是kernel不被 引导支持。。。楼主什么磁盘分区 编译进内核了吗

是最后那个盘分出的10g,原来是自动分的…ext3…分了出了这个错误就手动分……内核应该编译进去了吧?
我用kubuntu,ubuntu两张盘都出现这样的问题……

ps:我的光驱有点老……读盘很吃力……不知道有关不?
回复

回到 “老旧版本支持”