[问题]grub loading, please wait....... error 17[已解决]

为当前最终发行版之前的所有版本提供支持
回复
ccbwx
帖子: 76
注册时间: 2007-12-02 20:52
送出感谢: 0
接收感谢: 0

[问题]grub loading, please wait....... error 17[已解决]

#1

帖子 ccbwx » 2007-12-16 17:04

之前安装和使用都正常, 双系统xp 和 ubuntu ,三块硬盘(40G 30G 40G)

后来我在xp下用pq8 把第三块硬盘多分了一个区,重启后就出现下面提示了


grub loading stage1.5

grub loading, please wait.......
error 17
然后就再也不动了

估计是pq8修改了分区表的什么信息,导致grub启动失败,可我不知道怎么修改回来,请问大侠怎么办?
上次由 ccbwx 在 2007-12-21 14:03,总共编辑 1 次。
free-of-linux
帖子: 221
注册时间: 2007-11-08 18:19
送出感谢: 0
接收感谢: 1 次

#2

帖子 free-of-linux » 2007-12-16 18:28

好像是grub引导问题,它不能引导1024柱面以后的系统,,重装grub,并且一定要在前面
ccbwx
帖子: 76
注册时间: 2007-12-02 20:52
送出感谢: 0
接收感谢: 0

#3

帖子 ccbwx » 2007-12-16 23:21

重装grub,并且一定要在前面?我是菜鸟,具体有操作步骤吗?

我用win98的启动盘,到dos里,用fdisk/mbr就可以启动winxp了,可是我的ubuntu怎么找回来,能说具体点吗?
ccbwx
帖子: 76
注册时间: 2007-12-02 20:52
送出感谢: 0
接收感谢: 0

#4

帖子 ccbwx » 2007-12-17 17:55

自己顶一下
ccbwx
帖子: 76
注册时间: 2007-12-02 20:52
送出感谢: 0
接收感谢: 0

#5

帖子 ccbwx » 2007-12-18 21:55

已经搞定!自己动手丰衣足食 :D
xlsp
帖子: 10
注册时间: 2006-09-28 13:03
送出感谢: 0
接收感谢: 0

#6

帖子 xlsp » 2007-12-19 13:41

lz怎么搞定的?我的也出现这种错了!谢谢
头像
tenfar
帖子: 336
注册时间: 2005-12-10 17:36
来自: 北京市海淀区上地十街辉煌国际
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 tenfar » 2007-12-19 13:55

ubuntu livecd 里启动,找找论坛。很多,grub相关的
Laptop:HP Compaq Presario V3210AU
OS:Gentoo openbox+stalonetray+rox-filer+gmrun+mplayer+firefox+ibus+sonata+tilda
Phone:Orange Dopod 838+ SPV C600
OS:Windows Mobile 6.1
xlsp
帖子: 10
注册时间: 2006-09-28 13:03
送出感谢: 0
接收感谢: 0

#8

帖子 xlsp » 2007-12-19 14:26

是不是grub必须装在第一主硬盘啊?
ccbwx
帖子: 76
注册时间: 2007-12-02 20:52
送出感谢: 0
接收感谢: 0

#9

帖子 ccbwx » 2007-12-21 14:02

grub
root (hd2,7)
setup (hd2)
quiet
就这样搞定的
lizart
帖子: 12
注册时间: 2006-11-18 19:27
送出感谢: 0
接收感谢: 0

#10

帖子 lizart » 2008-05-17 10:46

补充一下楼主的:
我的本来是正常的,在Windows里面误点了一下PQ,什么都没做,结果重启就出现error17错误了。
找了好多东西都不能修复……最后终于试成功了……记录下来……
完整的使用方法应该是:

首先进入Live CD,也就是用Live CD进入Ubuntu操作系统,在终端里输入

sudo grub


如果不知道你的操作系统安装在哪,可以用以下命令查找

grub> find /boot/grub/stage1

注意:gurb>后面有一个空格!否则提示命令不可用。

然后确定包含引导文件夹的分区,我的Ubuntu操作系统安装在E盘,我的就是

grub> root (hd0,2) (这里替换成上面find出来的结果)

最后就是安装了

grub> setup (hd0) (也是要替换成find出来的结果)

grub> quit

回到GUI选择重启,会有比较长的时间刷新一个列表……完了就OK了。
参考来源:http://hi.baidu.com/nfubuntu/blog/item/ ... 27251.html
gemini614
帖子: 1
注册时间: 2009-03-20 13:59
送出感谢: 0
接收感谢: 0

Re:

#11

帖子 gemini614 » 2009-03-20 14:07

弱弱的提下,好像对于两快硬盘的兄弟们那个
grub> setup (hdx)
不是替换成find出的结果,一般用hd0的
刚刚在网上各位大侠的帮助下解决了问题,感觉挺好
lizart 写了:补充一下楼主的:
我的本来是正常的,在Windows里面误点了一下PQ,什么都没做,结果重启就出现error17错误了。
找了好多东西都不能修复……最后终于试成功了……记录下来……
完整的使用方法应该是:

首先进入Live CD,也就是用Live CD进入Ubuntu操作系统,在终端里输入

sudo grub


如果不知道你的操作系统安装在哪,可以用以下命令查找

grub> find /boot/grub/stage1

注意:gurb>后面有一个空格!否则提示命令不可用。

然后确定包含引导文件夹的分区,我的Ubuntu操作系统安装在E盘,我的就是

grub> root (hd0,2) (这里替换成上面find出来的结果)

最后就是安装了

grub> setup (hd0) (也是要替换成find出来的结果)

grub> quit

回到GUI选择重启,会有比较长的时间刷新一个列表……完了就OK了。
参考来源:http://hi.baidu.com/nfubuntu/blog/item/ ... 27251.html
回复

回到 “老旧版本支持”