老是出现symol lookup error:/usr/lib/libgobject-2.0.so.0 ...[已解决]

为当前最终发行版之前的所有版本提供支持
回复
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

老是出现symol lookup error:/usr/lib/libgobject-2.0.so.0 ...[已解决]

#1

帖子 INUYASHA » 2007-12-17 21:09

进不了X了

错误提示:
symol lookup error:/usr/lib/libgobject-2.0.so.0 undefined symbol:g_regex_unref

重装多次 每次用一段时间就又出这个问题

似乎于glib有关
因为xdm能运行的说

请大家帮帮忙呀
上次由 INUYASHA 在 2008-03-16 17:07,总共编辑 2 次。
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#2

帖子 INUYASHA » 2007-12-18 19:57

自己顶一下
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#3

帖子 avauntage » 2007-12-19 9:17

你干了什么之后,就不能进去了?
试试这个办法:

代码: 全选

locate libgobject
/xx/xxx/libgobject-2.0.so.0
/usr/lib/libgobject-2.0.so.0
/usr/lib/libgobject-2.0.so.0.1400.1
如果有红色的那行,那么就把它删掉即可。不放心的话,就给它改个名字也成。

代码: 全选

sudo mv /xx/xxx/libgobject-2.0.so.0 /xx/xxx/libgobject-2.0.so.0.bk
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#4

帖子 INUYASHA » 2007-12-23 21:09

avauntage 写了:你干了什么之后,就不能进去了?
试试这个办法:

代码: 全选

locate libgobject
/xx/xxx/libgobject-2.0.so.0
/usr/lib/libgobject-2.0.so.0
/usr/lib/libgobject-2.0.so.0.1400.1
如果有红色的那行,那么就把它删掉即可。不放心的话,就给它改个名字也成。

代码: 全选

sudo mv /xx/xxx/libgobject-2.0.so.0 /xx/xxx/libgobjectject-2.0.so.0.bk
运行locate libgobject
结果只有
/usr/lib/libgobject-2.0.so.0
/usr/lib/libgobject-2.0.so.0.1400.1

运行apt-get --reinstall install libglib2.0-0
也没用
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#5

帖子 INUYASHA » 2008-03-10 21:36

再顶
回复

回到 “老旧版本支持”