[问题] 安装软件openbox出现的错误,无法修复吗

为当前最终发行版之前的所有版本提供支持
回复
zhaoguanfeng
帖子: 44
注册时间: 2006-06-22 9:42
送出感谢: 0
接收感谢: 0

[问题] 安装软件openbox出现的错误,无法修复吗

#1

帖子 zhaoguanfeng » 2007-12-21 15:52

peter@gutsy:~$ sudo apt-get install openbox
[sudo] password for peter:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
已经不需要下列自动安装的软件包:
tk8.4
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
libobparser16 libobrender16
建议安装的软件包:
obconf menu libxml2-dev
下列【新】软件包将被安装:
libobparser16 libobrender16 openbox
共升级了 0 个软件包,新安装了 3 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/327kB 的软件包。
解压缩后会消耗掉 1610kB 的额外空间。
您希望继续执行吗?[Y/n]y
dpkg: 解析错误,在“/var/lib/dpkg/available”文件的第“23969”行附近 软件包“openoffice.org-writer”:
“Recommends”字段,无效的软件包名“ij”:必须以字母开头
E: Sub-process /usr/bin/dpkg returned an error code (2)
peter@gutsy:~$

之后试着安装其它软件也是提示上述错误,之后再重启,还是不行。
请帮帮在下。感激~
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2007-12-21 16:13

先删了 openbox 这个包吧
关注我的blog: ε==3
zhaoguanfeng
帖子: 44
注册时间: 2006-06-22 9:42
送出感谢: 0
接收感谢: 0

#3

帖子 zhaoguanfeng » 2007-12-22 18:45

删除过了 也不行呀

根本删不了那包!

autoremove remove 还是新立得都不能将其删除
zhaoguanfeng
帖子: 44
注册时间: 2006-06-22 9:42
送出感谢: 0
接收感谢: 0

#4

帖子 zhaoguanfeng » 2007-12-25 15:22

暂未解决 继续求助
zhaoguanfeng
帖子: 44
注册时间: 2006-06-22 9:42
送出感谢: 0
接收感谢: 0

#5

帖子 zhaoguanfeng » 2007-12-26 19:44

请高人进来继续呀
free-of-linux
帖子: 221
注册时间: 2007-11-08 18:19
送出感谢: 0
接收感谢: 1 次

#6

帖子 free-of-linux » 2007-12-27 14:06

dpkg --force
shishi
回复

回到 “老旧版本支持”