当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]启动和退出时界面的分辨率
帖子发表于 : 2007-12-27 10:34 

注册: 2007-12-27 9:54
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
ubuntu启动和退出时好像是高分辨率的宽屏显示,我的显示器只支持到1024*768,在启动和退出时显示out of range之类的,怎么让启动和退出的界面固定在1024*768或更低的分辨率上呢?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-27 17:52 

注册: 2007-12-27 9:54
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
没有高手回答吗?顶一个上去


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-27 18:19 

注册: 2007-07-21 15:51
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
看看/etc/usplash.conf


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-27 18:29 

注册: 2007-12-27 9:54
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
改成了1024、768,依然如故


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-27 18:31 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
试试把etc/X11/xorg.conf里面高过1024*768的显示模式去掉


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-27 18:38 

注册: 2007-07-21 15:51
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
修改之后应该执行sudo dpkg-reconfigure usplash-theme-ubuntu ,使配置生效吧。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-28 13:00 
头像

注册: 2007-11-20 21:42
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
我启动是也是和你的一样~!但进到桌面后就正常 了!如何解决??


我的etc/X11/下没有xorg.conf这个文件的??


_________________
你不理Ubuntu ,Ubuntu不理你。
我的茶叶小店http://goodtea.taobao.com
我的小博客网http://www.pcser.net


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-28 14:06 

注册: 2007-12-27 9:54
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
试试把etc/X11/xorg.conf里面高过1024*768的显示模式去掉

这个里面没有大于1024*768的地方。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-28 14:07 

注册: 2007-12-27 9:54
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
zhatin 写道:
修改之后应该执行sudo dpkg-reconfigure usplash-theme-ubuntu ,使配置生效吧。

还需要这样吗?重新启动不行吗?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-12-28 18:30 
头像

注册: 2007-11-20 21:42
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "NoLogo" "True"
Option "AllowGLXWithComposite" "True"
EndSection

Section "Monitor"
Identifier "通用显示器"
Option "DPMS"
Horizsync 30-70
Vertrefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Monitor "通用显示器"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
EndSection



我的是这个样子的,开机时就会变成最大的那个分辩率,进到桌面就正常 1024*768 了,大家看下我的文件哪里改!


_________________
你不理Ubuntu ,Ubuntu不理你。
我的茶叶小店http://goodtea.taobao.com
我的小博客网http://www.pcser.net


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-29 16:37 
头像

注册: 2007-10-16 19:29
帖子: 296
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install startup-*


_________________
cpu:Intel(R) Core(TM)2 Quad CPU Q6600
mem:2GB DDR2 800 *4
disk:ide320GB+(640GB+640GB)raid
video:Nvidia GTX 260+
network: Atheros AR8121/AR8113
monitor: BENQ FP92W
OS: ubuntu


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-12-29 17:24 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
pxw816 写道:
sudo apt-get install startup-*

好像有门,呵呵,我的是1280x800,启动选项里好像没有这个模式哦,怎么弄呢


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-12-29 20:59 
头像

注册: 2007-10-16 9:56
帖子: 52
地址: 郑州
送出感谢: 0 次
接收感谢: 0 次
启动和退出时的分辨率是由内核控制的,grub加启动参数
具体方法可以参见这里
http://library.javaeye.com/blog/151266


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-12-30 10:06 
头像

注册: 2007-09-04 13:51
帖子: 296
地址: LC @ eastasia
送出感谢: 3
接收感谢: 1
我也有这个问题。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译