当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [原创]Ubuntu5.10上的MYSQL5 + Ahapche2 + PHP5 +Phpmyadmin安装手记
帖子发表于 : 2006-02-15 1:27 
头像

注册: 2006-02-07 23:40
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
从freeBSD换成了Ubuntu5.10
我是第一次使用Ubuntu这个系统 以前的linux经验还停留在遥远的redhat 6.2
折腾了半天终于搞定了基本的网络服务
这里分享一下安装手记
高手不要见笑 提点意见就好了
菜鸟看看还行~

第一步安装MYSQL
笔记本速度太慢,懒得编译源代码,apt-get没找到5的版本 直接apt-get install mysql-server事4.10 我用的台湾的sourcelist 因为这个网通速度稍微快一些
没办从官方法下载一个bin文件mysql-standard-5.0.18-linux-i686.tar.gz
开始安装:
代码:
cp mysql-standard-5.0.18-linux-i686.tar.gz /usr/local/
gunzip < mysql-standard-5.0.18-linux-i686.tar.gz | tar xvf -
mv mysql-standard-5.0.18-linux-i686.tar.gz mysql
groupadd mysql
useradd -g mysql mysql
cd mysql
scripts/mysql_install_db --user=mysql
chown -R root  .
chown -R mysql data
chgrp -R mysql .
bin/mysqld_safe --user=mysql &

偶不喜欢用ln -s的方法不知道为什么就是不喜欢
这样就好了 接下去
代码:
cp support-files/my-medium.cnf  /etc/my.cnf
cd /etc/init.d
cp /usr/local/mysql/support-files/mysql.server mysql

现在mysql还不能自己启动 每次重启都要手工启动
ubuntu下没有chkconfig只能(或者安装deb版的chkconfig)
代码:
update-rc.d mysql defaults 

到这里我们就完成了MYSQL的bin的安装
也可以通过/etc/rc.d/init.d/mysql start或者/etc/rc.d/init.d/mysql stop来启动停止MYSQL服务
剩下的事情就是你自己通过/usr/local/mysql/bin/mysqladmin -u root password "your password"来设置root用户的密码

MYSQL搞定 开始搞APACHE 和PHP
APACHE2懒得折腾直接apt-get
代码:
apt-get install apache2

接下来安装PHP5
代码:
apt-get install php5

然后是
代码:
apt-get install libapache2-mod-auth-mysql
apt-get install php5-mysql

这两个模块
接下来是
代码:
apt-get install php5-gd

对GD的支持还要改一下php.ini 顺便把mysql.so也挂上
代码:
nano /etc/php5/apache2/php.ini

找到
代码:
#extension=mysql.so
#extension=gd.so

去掉前面的注释 保存就好了 如果你要改什么上传文件大小 使用内存的大小 可以一并改了

最后安装phpmyadmin 还是apt-get
代码:
apt-get install phpmyadmin

好了看看能不能用
输入用户名密码
我靠
代码:
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

这个错误 怎么搞定呢?
修改/etc/phpmyadmin/config.inc.php
代码:
nano /etc/phpmyadmin/config.inc.php

找到/// $cfg['Servers'][$i]['socket'] = '';
改为
代码:
$cfg['Servers'][$i]['socket'] = '/tmp/mysql.sock';

就好了~
然后再试试 输入用户名密码
我靠有没有高错 还有错误
代码:
Client does not support authentication protocol requested by server; consider upgrading MySQL client

这个是怎么回事呢?
我们修改过MYSQL的root的密码,因为MYSQL的password的散列加密方法和以前有了变化,所以出了这个问题 这个改变在MYSQL4.1版以上才有
原先的方式变成了OLD_PASSWORD
我们重新更新一下密码就好了
代码:
/usr/local/mysql/bin/mysql -u root -p

输入密码进入mysql的管理程序
代码:
UPDATE mysql.user SET Password = OLD_PASSWORD('ur_pwd')
 WHERE Host = 'ur_host' AND User = 'root';

好了phpmyadmin能登陆了

这样最基本的php5 mysql5 apache2 还有phpmyadmin就安装好了~
剩下的事情就是大家按照自己的习惯去配置好了
最后说一下 我用的是root身份进行操作的
习惯了 省得sudo


最后由 freewolf 编辑于 2006-02-17 16:21,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-02-15 10:53 

注册: 2006-01-30 20:36
帖子: 131
送出感谢: 0 次
接收感谢: 0 次
还没有试过,支持原创和讨论!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-02-15 11:02 
头像

注册: 2006-02-07 23:40
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我是5.10 server clean的系统
直接安装的 之前系统上可能就 apt-get了一个ssh-server
遇到的问题我也都写了
ubuntu应该都可以


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-02-18 10:21 

注册: 2006-01-23 16:57
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
apache2的安装目录和html目录是什么?我是新手,发现和Red Hat的不一样


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-02-18 22:22 
头像

注册: 2006-02-07 23:40
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
xdjyjsc 写道:
apache2的安装目录和html目录是什么?我是新手,发现和Red Hat的不一样

你是按照我的办法???
我的这个安装过程过后
apache2在/etc/apache2
html 在/var/www


页首
 用户资料  
 
6 楼 
 文章标题 : 我在ubuntu6.04下安装了apache2+mysql+php5+openssh,但为什么php
帖子发表于 : 2006-02-22 22:42 

注册: 2006-02-22 18:20
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我在ubuntu6.04下安装了apache2+mysql+php5+openssh,但为什么php不能连接mysql
提示如下:
Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (13) in /var/www/phptest.php on line 2
php代码如下:
<?php
$conn=mysql_connect("localhost","userName","passwd")
or die;
mysql_close($conn);
phpinfo();
?>
我找了很久都没有成功,我试过的方法有:
1.
#extension=gd.so
#extension=mysql.so
--------->
extension=gd.so
extension=mysql.so
不行,
2.'/var/run/mysqld/mysqld.sock' 存在
我的mysql是可以正常登录的,
mysql -u root -p
输入密码后就可以登录到mysql
3.将mysql.so拷贝到/etc/apache2/bin目录下,
也不行,谁能帮我看看,谢了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-03-17 14:20 

注册: 2006-03-17 14:08
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
对于.tar.gz和rpm软件包的安装方法的思路是什么,各有什么命令,如gzip,tar,rpm,chmod等的口令怎么用,麻烦你们详细解说一下。
---------------------我是菜鸟我怕谁!!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-03-18 0:48 
头像

注册: 2006-03-16 23:22
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我先是按照网站的 如何安装 Web 支持 这篇文档安完了apache2 + php5 + mysql,然后又按照您安装PHPMYADMIN的设置方法安装,可是进入PHPMYADMIN后台后新创建数据库时出现这个错误:
MySQL 返回:文档
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

它说的是语法错误吧?是因为我安装的这个MYSQL版本和PHPMYADMIN不对?因为我看到安装的PHPMYADIN应该是MYSQL4的,对吧。
请问我改如何解决呢?
是不是要下个最新的PHPMYADIN来安装一下呢?
刚刚接触 LINUX,很多地方还在摸索中,请多多指教,谢谢 !


页首
 用户资料  
 
9 楼 
 文章标题 : 漏了一个配置 不然 phpmyadmin不能登录说 错误2002 socket 设置不正确
帖子发表于 : 2006-03-18 1:42 

注册: 2006-03-01 22:25
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
在php.ini 加上

mysql.default_socket =/tmp/mysql.sock


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-03-18 1:45 
头像

注册: 2006-03-16 23:22
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
求助:按照站内的文档安装apache2 + php5 + mysql后又安装phpmyadmin出现问题
我按照网站内的文档:http://www.ubuntu.org.cn/support/documentation/server/apache
安装设置完所有的内容后,又按照这篇帖子跳过前面的步骤直接安装phpmyadmin。
安装完虽然能进入后台界面,但是在新建数据库时出现问题:

MySQL 返回:文档
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

它说的是语法错误吧?是因为我安装的这个MYSQL版本和PHPMYADMIN不对?因为我看到安装的PHPMYADIN后台界面是显示版本是MYSQL4的。然后我看了安装时产生的代码,发现它用PHP4代替了PHP5:

将会安装下列的额外的软件包:
libapache2-mod-php4 libzzip-0-12 php4 php4-common php4-mysql
建议安装的软件包:
php-pear php4-gd
推荐安装的软件包:
php4-mcrypt php5-mcrypt
下列软件包将被【卸载】:
libapache2-mod-php5 php5-gd php5-mysql
下列【新】软件包将被安装:
libapache2-mod-php4 libzzip-0-12 php4 php4-common php4-mysql phpmyadmin

于是我又重新安装PHP5:

下列软件包将被【卸载】:
libapache2-mod-php4 php4 php4-mysql phpmyadmin
下列【新】软件包将被安装:
libapache2-mod-php5

这时候就出现问题了:

hp5-common 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
phpmyadmin: 依赖: php4 但是它将不会被安装 或
php4-cgi 但是它将不会被安装 或
php5 但是它将不会被安装 或
php5-cgi 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

结果Phpmyadmin也运行不起来了。然后我又重新安装Phpmyadmin,结果提示:

phpmyadmin 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
phpmyadmin: 依赖: php4 但是它将不会被安装 或
php4-cgi 但是它将不会被安装 或
php5 但是它将不会被安装 或
php5-cgi 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

请问我现在该怎么办啊?还有办法补救么?
请那位高人指点指点。小弟不胜感激!

下面是完整的安装时产生的代码信息:

ericsong@Ericsong:~$ sudo apt-get install phpmyadmin
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列的额外的软件包:
libapache2-mod-php4 libzzip-0-12 php4 php4-common php4-mysql
建议安装的软件包:
php-pear php4-gd
推荐安装的软件包:
php4-mcrypt php5-mcrypt
下列软件包将被【卸载】:
libapache2-mod-php5 php5-gd php5-mysql
下列【新】软件包将被安装:
libapache2-mod-php4 libzzip-0-12 php4 php4-common php4-mysql phpmyadmin
共升级了 0 个软件包,新安装了 6 个软件包,要卸载 3 个软件包,有 0 个软件未被升级。
需要下载 4683kB 的软件包。
解压缩后会消耗掉 10.6MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://archive.ubuntu.org.cn breezy/universe libzzip-0-12 0.12.83-5 [33.9kB]
获取:2 http://archive.ubuntu.org.cn breezy-security/universe php4-common 4:4.4.0-3ubuntu2 [172kB]
获取:3 http://archive.ubuntu.org.cn breezy-security/universe libapache2-mod-php4 4:4.4.0-3ubuntu2 [1552kB]
获取:4 http://archive.ubuntu.org.cn breezy-security/universe php4 4:4.4.0-3ubuntu2 [1166B]
获取:5 http://archive.ubuntu.org.cn breezy-security/universe php4-mysql 4:4.4.0-3ubuntu2 [20.8kB]
获取:6 http://archive.ubuntu.org.cn breezy-security/universe phpmyadmin 4:2.6.4-pl1-1ubuntu1.1 [2903kB]
下载 4683kB,耗时 1m5s (71.0kB/s)

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 66676 个文件和目录。)
正在删除 php5-mysql ...
正在删除 php5-gd ...
正在删除 libapache2-mod-php5 ...
Module php5 disabled; run /etc/init.d/apache2 force-reload to fully disable.
选中了曾被取消选择的软件包 libzzip-0-12。
(正在读取数据库 ... 系统当前总共安装有 66671 个文件和目录。)
正在解压缩 libzzip-0-12 (从 .../libzzip-0-12_0.12.83-5_i386.deb) ...
选中了曾被取消选择的软件包 php4-common。
正在解压缩 php4-common (从 .../php4-common_4%3a4.4.0-3ubuntu2_i386.deb) ...
选中了曾被取消选择的软件包 libapache2-mod-php4。
正在解压缩 libapache2-mod-php4 (从 .../libapache2-mod-php4_4%3a4.4.0-3ubuntu2_i386.deb) ...
选中了曾被取消选择的软件包 php4。
正在解压缩 php4 (从 .../php4_4%3a4.4.0-3ubuntu2_all.deb) ...
选中了曾被取消选择的软件包 php4-mysql。
正在解压缩 php4-mysql (从 .../php4-mysql_4%3a4.4.0-3ubuntu2_i386.deb) ...
选中了曾被取消选择的软件包 phpmyadmin。
正在解压缩 phpmyadmin (从 .../phpmyadmin_4%3a2.6.4-pl1-1ubuntu1.1_all.deb) ...
正在设置 libzzip-0-12 (0.12.83-5) ...

正在设置 php4-common (4.4.0-3ubuntu2) ...
正在设置 libapache2-mod-php4 (4.4.0-3ubuntu2) ...
* Forcing reload of web server (Apache2)... [ ok ]

正在设置 php4 (4.4.0-3ubuntu2) ...

正在设置 php4-mysql (4.4.0-3ubuntu2) ...

正在设置 phpmyadmin (2.6.4-pl1-1ubuntu1.1) ...

Creating config file /etc/phpmyadmin/apache.conf with new version

Creating config file /etc/phpmyadmin/config.footer.inc.php with new version

Creating config file /etc/phpmyadmin/config.header.inc.php with new version

Creating config file /etc/phpmyadmin/config.inc.php with new version

Creating config file /etc/phpmyadmin/htaccess with new version

ericsong@Ericsong:~$ mysql-query-browser ericsong@Ericsong:~$ mysql-query-phpmyadmin
bash: mysql-query-phpmyadmin: command not found
ericsong@Ericsong:~$ sudo apt-get install mysql-server
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
mysql-server 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
ericsong@Ericsong:~$ sudo apt-get install php5-common
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
php5-common 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
ericsong@Ericsong:~$ sudo apt-get install php5-gd
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列的额外的软件包:
php5-cli
建议安装的软件包:
php-pear
下列【新】软件包将被安装:
php5-cli php5-gd
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 1864kB/1896kB 的软件包。
解压缩后会消耗掉 4149kB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://archive.ubuntu.org.cn breezy-security/main php5-cli 5.0.5-2ubuntu1.2 [1864kB]
下载 1864kB,耗时 23s (81.0kB/s)

正在预设定软件包 ...
选中了曾被取消选择的软件包 php5-cli。
(正在读取数据库 ... 系统当前总共安装有 67334 个文件和目录。)
正在解压缩 php5-cli (从 .../php5-cli_5.0.5-2ubuntu1.2_i386.deb) ...
选中了曾被取消选择的软件包 php5-gd。
正在解压缩 php5-gd (从 .../php5-gd_5.0.5-2ubuntu1.2_i386.deb) ...
正在设置 php5-cli (5.0.5-2ubuntu1.2) ...

正在设置 php5-gd (5.0.5-2ubuntu1.2) ...

ericsong@Ericsong:~$ sudo apt-get install php5-mysql
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列【新】软件包将被安装:
php5-mysql
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/21.3kB 的软件包。
解压缩后会消耗掉 102kB 的额外空间。

正在预设定软件包 ...
选中了曾被取消选择的软件包 php5-mysql。
(正在读取数据库 ... 系统当前总共安装有 67341 个文件和目录。)
正在解压缩 php5-mysql (从 .../php5-mysql_5.0.5-2ubuntu1.2_i386.deb) ...
正在设置 php5-mysql (5.0.5-2ubuntu1.2) ...

ericsong@Ericsong:~$ sudo apt-get install libapache2-mod-php5
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
建议安装的软件包:
php-pear
下列软件包将被【卸载】:
libapache2-mod-php4 php4 php4-mysql phpmyadmin
下列【新】软件包将被安装:
libapache2-mod-php5
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 4 个软件包,有 0 个软件未被升级。
需要下载 0B/1869kB 的软件包。
解压缩后将会空出 10.3MB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。
ericsong@Ericsong:~$ sudo apt-get install libapache2-mod-php5
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
建议安装的软件包:
php-pear
下列软件包将被【卸载】:
libapache2-mod-php4 php4 php4-mysql phpmyadmin
下列【新】软件包将被安装:
libapache2-mod-php5
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 4 个软件包,有 0 个软件未被升级。
需要下载 0B/1869kB 的软件包。
解压缩后将会空出 10.3MB 的空间。
您希望继续执行吗?[Y/n]y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 67341 个文件和目录。)
正在删除 phpmyadmin ...
/var/lib/dpkg/info/phpmyadmin.prerm: line 12: db_get: command not found
dpkg:处理 phpmyadmin (--remove)时出错:
子进程·pre-removal script·返回了错误号·127
正在删除 php4-mysql ...
dpkg:php4:有依赖问题,但是如您所愿还是继续删除:
phpmyadmin 依赖于 php4 | php4-cgi | php5 | php5-cgi;然而:
软件包 php4 即将被删除。
软件包 php4-cgi还没有被安装。
软件包 php5还没有被安装。
软件包 php5-cgi还没有被安装。
正在删除 php4 ...
正在删除 libapache2-mod-php4 ...
Module php4 disabled; run /etc/init.d/apache2 force-reload to fully disable.
在处理时有错误发生:
phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)
ericsong@Ericsong:~$ sudo apt-get install php5-common
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
php5-common 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
phpmyadmin: 依赖: php4 但是它将不会被安装 或
php4-cgi 但是它将不会被安装 或
php5 但是它将不会被安装 或
php5-cgi 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
ericsong@Ericsong:~$ mysql-query-phpmyadmin
bash: mysql-query-phpmyadmin: command not found
ericsong@Ericsong:~$ sudo apt-get install phpmyadmin
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
phpmyadmin 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
phpmyadmin: 依赖: php4 但是它将不会被安装 或
php4-cgi 但是它将不会被安装 或
php5 但是它将不会被安装 或
php5-cgi 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
11 楼 
 文章标题 : [讨论]我用了上述的安装方法还是提示出错。
帖子发表于 : 2006-03-29 23:05 
头像

注册: 2005-10-02 8:22
帖子: 723
送出感谢: 0 次
接收感谢: 0 次
具体错误还是:Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/speme/workspace/new1/db.php on line 9
Client does not support authentication protocol requested by server; consider upgrading MySQL client
我按照说明上的把用户密码改了,还是不行。不过提示:我启动mysql是加了utf8的参数。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-05-01 21:43 

注册: 2006-04-12 15:26
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
我还是喜欢用源码安装,统一把文件都安装在/usr/local目录里


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-05-02 16:02 

注册: 2005-11-26 18:27
帖子: 193
送出感谢: 0 次
接收感谢: 0 次
有很多问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译