当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]configure: error: C compiler cannot create executables
帖子发表于 : 2008-01-01 22:36 

注册: 2008-01-01 22:30
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
执行./configure后的错误:
configure: error: C compiler cannot create executables
而且执行sudo apt-get install libc6-dev后的错误是

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.6.1-1ubuntu9 正要被安装
E: 无法安装的软件包

请求高手给予指导,谢谢了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-01 22:41 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
先 sudo apttitude update 一下,再 install xxx


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-01 23:00 

注册: 2008-01-01 22:30
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
sudo apttitude update
这命令不对阿,大哥,俺刚装上,命令不懂,出了错都不知道在哪儿,怀疑你的命令是错的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-01 23:19 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
:) , 我打错了 , sudo aptitude update ,,


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-02 0:02 

注册: 2008-01-01 22:30
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
执行# sudo apt-get install gcc libo6-dev
后是
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 libo6-dev
我是需要去下一个 libo6-dev么

谢谢2楼的大哥


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-02 0:13 

注册: 2008-01-01 22:30
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
./configure时又有了这样的错误。。。。
Error: Cannot find header either inttypes.h or bitypes.h. There is no chance for compilation to succeed.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-02 0:20 
头像

注册: 2006-10-27 18:15
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
我也是刚刚遇到这个问题。。。


_________________
Thinkpad X200 7457A78
Intel Core2 Duo(Penryn) P8600(2.4GHz)
3GB RAM


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-01-02 0:21 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
你也打错了, libc6-dev 吧? 目录下有 README/INSTALL 先看看,有什么要求


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-02 8:32 

注册: 2008-01-01 22:30
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
8楼,不好意思,你说的“目录下有 README/INSTALL” 是指哪个目录呢?我总觉得我没有libc6-dev 这个包


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-01-02 8:38 

注册: 2008-01-01 22:30
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
执行sudo apt-get install libc6-dev后
结果是
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.6.1-1ubuntu9 正要被安装
E: 无法安装的软件包


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-01-02 8:39 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
README/INSTALL 是帮助文件 txt格式


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-21 15:23 
头像

注册: 2007-11-19 9:10
帖子: 112
送出感谢: 0 次
接收感谢: 0 次
configure: error: C compiler cannot create executables
我也遇到了一样的问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译