slocate(broken package)

为当前最终发行版之前的所有版本提供支持
回复
nostoryboy
帖子: 27
注册时间: 2006-01-08 20:57
送出感谢: 0
接收感谢: 0

slocate(broken package)

#1

帖子 nostoryboy » 2006-02-17 12:31

将会安装下列的额外的软件包:
slocate
下列【新】软件包将被安装:
slocate
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 88 个软件包没有被完全安装或卸载。
需要下载 0B/27.0kB 的软件包。
解压缩后会消耗掉 147kB 的额外空间。
您希望继续执行吗?[Y/n]y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 60859 个文件和目录。)
正在解压缩 slocate (从 .../slocate_2.7-4_i386.deb) ...
Removing `diversion of /etc/cron.daily/find to /etc/cron.daily/find.notslocate by slocate'
dpkg-divert: rename involves overwriting `/etc/cron.daily/find' with
different file `/etc/cron.daily/find.notslocate', not allowed
dpkg:处理 /var/cache/apt/archives/slocate_2.7-4_i386.deb (--unpack)时出错:
子进程·pre-installation script·返回了错误号·2
在处理时有错误发生:
/var/cache/apt/archives/slocate_2.7-4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


???????
nostoryboy
帖子: 27
注册时间: 2006-01-08 20:57
送出感谢: 0
接收感谢: 0

#2

帖子 nostoryboy » 2006-02-17 12:46

刚才新装了班图,可是按照快速设置里升级的时候出现了以上情况,貌似这个slocate软件包损坏,是源上的包出问题了还是什么?望管理员帮个忙,告诉我怎么弄,thx
头像
daf3707
论坛版主
帖子: 12670
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#3

帖子 daf3707 » 2007-07-11 16:14

顶一下,我也有此问题
头像
daf3707
论坛版主
帖子: 12670
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#4

帖子 daf3707 » 2007-07-11 16:36

解决了,在托盘那个更新的图标上右键“选开始软件包管理”,再选“己损坏的软件包,重新勾选重装
回复

回到 “老旧版本支持”