Why Can't update my OS

为当前最终发行版之前的所有版本提供支持
回复
bigbang
帖子: 23
注册时间: 2005-09-21 13:30
送出感谢: 0
接收感谢: 0
联系:

Why Can't update my OS

#1

帖子 bigbang » 2006-02-17 15:54

I use ubuntu5.10
when I sudo apt-get update
then it was
获取:1 http://archive.ubuntu.org.cn breezy Release.gpg [189B]
获取:2 http://archive.ubuntu.org.cn breezy-security Release.gpg [189B]
获取:3 http://archive.ubuntu.org.cn breezy-updates Release.gpg [189B]
获取:4 http://archive.ubuntu.org.cn breezy-backports Release.gpg [189B]
忽略 http://archive.ubuntu.org.cn breezy Release.gpg
忽略 http://archive.ubuntu.org.cn breezy-extras Release.gpg
获取:5 http://archive.ubuntu.org.cn breezy Release [30.9kB]
获取:6 http://archive.ubuntu.org.cn breezy-security Release [23.3kB]
获取:7 http://archive.ubuntu.org.cn breezy-updates Release [30.9kB]
获取:8 http://archive.ubuntu.org.cn breezy-backports Release [19.6kB]
忽略 http://archive.ubuntu.org.cn breezy Release
忽略 http://archive.ubuntu.org.cn breezy-extras Release
获取:9 http://archive.ubuntu.org.cn breezy/main Packages [585kB]
获取:10 http://archive.ubuntu.org.cn breezy/restricted Packages [5061B]
获取:11 http://archive.ubuntu.org.cn breezy/universe Packages [2304kB]
获取:12 http://archive.ubuntu.org.cn breezy/multiverse Packages [91.6kB]
获取:13 http://archive.ubuntu.org.cn breezy-security/main Packages [35.0kB]
获取:14 http://archive.ubuntu.org.cn breezy-security/restricted Packages [4458B]
获取:15 http://archive.ubuntu.org.cn breezy-security/universe Packages [27.9kB]获取:16 http://archive.ubuntu.org.cn breezy-security/multiverse Packages [1560B]
获取:17 http://archive.ubuntu.org.cn breezy-updates/main Packages [31.3kB]
获取:18 http://archive.ubuntu.org.cn breezy-updates/restricted Packages [14B]
获取:19 http://archive.ubuntu.org.cn breezy-updates/universe Packages [8929B]
获取:20 http://archive.ubuntu.org.cn breezy-updates/multiverse Packages [708B]
忽略 http://archive.ubuntu.org.cn breezy/main Packages
忽略 http://archive.ubuntu.org.cn breezy/restricted Packages
忽略 http://archive.ubuntu.org.cn breezy/universe Packages
忽略 http://archive.ubuntu.org.cn breezy/multiverse Packages
忽略 http://archive.ubuntu.org.cn breezy-extras/main Packages
忽略 http://archive.ubuntu.org.cn breezy-extras/restricted Packages
忽略 http://archive.ubuntu.org.cn breezy-extras/universe Packages
忽略 http://archive.ubuntu.org.cn breezy-extras/multiverse Packages
获取:21 http://archive.ubuntu.org.cn breezy-backports/main Packages [14.0kB]
获取:22 http://archive.ubuntu.org.cn breezy-backports/restricted Packages [14B]获取:23 http://archive.ubuntu.org.cn breezy-backports/universe Packages [26.1kB]
获取:24 http://archive.ubuntu.org.cn breezy-backports/multiverse Packages [1353B]
获取:25 http://archive.ubuntu.org.cn breezy/main Packages [90.4kB]
获取:26 http://archive.ubuntu.org.cn breezy/restricted Packages [1900B]
获取:27 http://archive.ubuntu.org.cn breezy/universe Packages [20B]
获取:28 http://archive.ubuntu.org.cn breezy/multiverse Packages [10.2kB]
获取:29 http://archive.ubuntu.org.cn breezy-extras/main Packages [33B]
获取:30 http://archive.ubuntu.org.cn breezy-extras/restricted Packages [33B]
获取:31 http://archive.ubuntu.org.cn breezy-extras/universe Packages [33B]
获取:32 http://archive.ubuntu.org.cn breezy-extras/multiverse Packages [33B]
下载 3346kB,耗时 4m35s (12.2kB/s)
E: 无法获得锁 /var/lib/dpkg/lock - open (11 资源暂时不可用)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?


why it be this? thank you! by the way ! I haven't 安装中文语言支持,It is the same problem!
thank you again!
bigbang
帖子: 23
注册时间: 2005-09-21 13:30
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 bigbang » 2006-02-17 15:57

the file /var/lib/dpkg/lock was locked
then I sudo chmod 777 /var/lib/dpkg/lock
but it was useless
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#3

帖子 firehare » 2006-02-17 17:19

你有没有打开其它的源代码安装程序?
我心无畏,源自于我心无知。
图片
bigbang
帖子: 23
注册时间: 2005-09-21 13:30
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 bigbang » 2006-02-17 17:40

没有
现在中文是可以输入了
但是中文语言支持还是不行
其它的也不行
提示都是同一个问题
bigbang
帖子: 23
注册时间: 2005-09-21 13:30
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 bigbang » 2006-02-17 17:44

E: 无法获得锁 /var/lib/dpkg/lock - open (11 资源暂时不可用)
是什么意思呢?

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
我并没有开其它的程序

对了,再问一下在新立得中装了fcitx,有没有必要再装里面的那个scim-fcitxne呢
以前安装的时候没有注意这个问题。
bigbang
帖子: 23
注册时间: 2005-09-21 13:30
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 bigbang » 2006-02-17 20:04

我又换了其它源sudo apt-get update
又出现了其它的问题
然后我就又换回来到最初的源
这次就没有出现错误,很顺利
不知道这是为什么呢?
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#7

帖子 oneleaf » 2006-02-17 23:49

有可能系统当时正在后台下载升级包。
bigbang
帖子: 23
注册时间: 2005-09-21 13:30
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 bigbang » 2006-02-18 11:18

我今天早上弄了一下
终于知道了,正如firehare所说的那样
刚开始我还不知道就是这个原因,所以还以为firehare错了呢
呵呵,不过也说不定,说不定是oneleaf所说的原因呢
不过反正就像是教室里面一个位子已经被别人坐了,我无法再坐下去了一样
希望像我一样水的人可以看到而知道是这样的
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#9

帖子 firehare » 2006-02-18 11:57

:)
我心无畏,源自于我心无知。
图片
回复

回到 “老旧版本支持”