前车之鉴-在Debian下使用Ubuntu的源

为当前最终发行版之前的所有版本提供支持
回复
头像
杨珂
帖子: 92
注册时间: 2005-05-11 17:36
来自: 四川南充
送出感谢: 0
接收感谢: 0
联系:

前车之鉴-在Debian下使用Ubuntu的源

#1

帖子 杨珂 » 2005-06-18 9:32

前几天我试装了几个版本的Linux:FC4、Debian3.1······

FC4上有自带的yum 我又在FC4上装了Synaptic,但是源太少特别是中国的源,FC4上的apt我几乎没用过。
yum也只用了两次

yum install kernel-devel (for Vmware)
yum install libstdctt.so.5 (for realplayer)

在我装amule时(for FC3 5兆)FC4给我列出了缺少十几个关联的文件
(我这下明白为什么在Ubuntu下apt-get install amule 有十几兆了)

感觉最好就是Debian3.1,但是没有合适的源,所以网路上完全用的是Ubuntu的源安装中文支持时ubuntu就自动把debian上的KDE3.3卸载了,不过这没
什么反正我用KDE用得少。
后来我安GNOME 中文用户的网站上的方法GNOME 2.10 for Debian (from ubuntu linux)http://www.gnome-cn.org/download/2.10/install_gnome_2.10_on_debian
gnome-cn 写了:GNOME 2.10 for Debian (from ubuntu linux)
Document Actions

* Send this page to somebody
* Print this page

来自 "ubuntu linux" 的 Deb 包.

把以下 apt source 添加到 /etc/atp/sources.list 中:

# GNOME 2.10 for ubuntu linux
deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe
#deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe

deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
#deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted

然后执行:

apt-get update

然后执行:

apt-get dist-upgrade -u

OK, 你的 gnome 已经是 gnome 2.10 的了.:)


把gnome2.8升及到2.10但完成后无法进入Gnome。
不过这次安装是在Vmware里进行的-- 哈哈!我事先留了一手。
可是灾祸还是降临在我的debian上
我当时的源列表是:
deb http://debian.cn99.com/debian sarge main non-free contrib
deb http://debian.cn99.com/debian-non-US sarge/non-US main contrib non-free

deb http://debian.cn99.com/debian-security sarge/updates main contrib non-free
deb-src http://debian.cn99.com/debian sarge main non-free contrib
deb-src http://debian.cn99.com/debian-non-US sarge/non-US main contrib non-free

deb http://dl.linuxforum.net/debian unstable main non-free contrib
#deb http://dl.linuxforum.net/debian experimental main non-free contrib
deb-src http://dl.linuxforum.net/debian unstable main
deb ftp://sunsite.ust.hk/pub/debian /unstable main


安装firefox apt-get install firefox
显示没找到firefox

由于firefox不是什么大软件我放松了警惕用Ubuntu的源

deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn ubuntu.org.cn main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted
deb-src http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse


结果不仅firefox装上没法使用,还把我的GNOME改了,注销、重启后进不了GNOME

错误可能是Ubuntu自动为程序加如菜单那步,我在终端里看到了apt对gnome-panel的改动注销前debian的GNOME2.8的菜单被改成了Ubuntu里的2.10但GNOME版本任显示2.8


感觉运行最快最顺的是debian(3.1 sarge 我用的2.6内核后用Ubuntu的源升级到686)但debian的软件包较旧grup和登陆界面不好看
这一点上FC4是最酷的
Ubuntu的grup很一般但登陆界面做的很好
debian应该向Ubuntu和Fedora学习,不要软件旧界面也旧。

FC4还是Red Hat系列的老问题-软件关联。
Fedora的yum、apt比起Debian门派的还差很远。

FC4启动时在有一步要停很久好像是和网络有关的一步(什么什么IP什么的) Redhat门派的Mandrak也有这个现象好像是:burning up network interface 常常是失败但又对上网没什么影响
可恨的是用Ctrl+C跳不过这一步(FreeBSD中类似问题都是用Ctrl+C跳过的)
图片
图片
图片
上次由 杨珂 在 2005-06-21 20:29,总共编辑 6 次。
我和他人紧紧相连, 密不可分, 我们都在同一种生活之中.

[]Laptop: acer 5022 /AMD64/ati X600/1G/100G
OS: acer WinXp / Gentoo 2006.0 AMD64
[]Desktop:P4 2.4 NorthWood/SiS 651/521M/80G
OS: Xp.Pro.en / Ubuntu 6.06
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yongyi » 2005-06-18 9:51

看来ubuntu对debian(还没真正用过debian)改动比较大的哦。连装个firefox都会把gnome-panel修改了。

不过,debian的源不大可能没有firefox吧?也许sid中有?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
杨珂
帖子: 92
注册时间: 2005-05-11 17:36
来自: 四川南充
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 杨珂 » 2005-06-18 10:29

yongyi 写了:看来ubuntu对debian(还没真正用过debian)改动比较大的哦。连装个firefox都会把gnome-panel修改了。

不过,debian的源不大可能没有firefox吧?也许sid中有?


debian要用apt-get intall Mozilla Firefox
我和他人紧紧相连, 密不可分, 我们都在同一种生活之中.

[]Laptop: acer 5022 /AMD64/ati X600/1G/100G
OS: acer WinXp / Gentoo 2006.0 AMD64
[]Desktop:P4 2.4 NorthWood/SiS 651/521M/80G
OS: Xp.Pro.en / Ubuntu 6.06
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 yongyi » 2005-06-18 10:34

debian要用apt-get intall Mozilla Firefox


在ubuntu5.04下也是的。
在ubuntu5.10才变为firefox了的。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
杨珂
帖子: 92
注册时间: 2005-05-11 17:36
来自: 四川南充
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 杨珂 » 2005-06-18 10:51

我也没在Ubuntu下用apt装firefox,装系统时就装好了。
我和他人紧紧相连, 密不可分, 我们都在同一种生活之中.

[]Laptop: acer 5022 /AMD64/ati X600/1G/100G
OS: acer WinXp / Gentoo 2006.0 AMD64
[]Desktop:P4 2.4 NorthWood/SiS 651/521M/80G
OS: Xp.Pro.en / Ubuntu 6.06
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#6

帖子 firehare » 2005-06-18 19:33

Debian的源同Ubuntu的源最好不要混用
以前我想从Debian通过改源的方法更新到Ubuntu时,就有很多问题!
我心无畏,源自于我心无知。
图片
回复

回到 “老旧版本支持”