当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [请教]ubuntu7.10的源问题[已解决]
帖子发表于 : 2008-01-06 11:24 

注册: 2007-12-28 23:54
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
现在装了7.10后,发现很多东西都不能直接用。像gcc都不能直接用,要先去下载几个东西? 我觉得ubuntu 应该不会这样吧,肯定是我自己在哪安装时出了问题吧。 网上也搜不到类似的问题。所以问下大家,如果直接安装好 7.10,gcc能不能直接用?

我在网上看要安装 build-essential libc6-dev。可是源里都是2.5版的,而我的 libc 是2.6的,所以安装不上去。这个怎么解决呢?以前我用 7.04时一直用 中科大的源,很好。

是不是因为源里的东西比较老了? 那我应该怎么办呢?重新装回 7.04?这也太搓了吧。可是7.10在apt-get会出现很多这样的问题,就是:
xxx 依赖 yyy但是 zzz不会被安装


希望能得到大家的指导。谢谢!


最后由 wubingzheng 编辑于 2008-01-06 15:20,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-06 13:42 
头像

注册: 2007-01-06 21:00
帖子: 920
送出感谢: 2
接收感谢: 0 次
sudo apt-get check这个是检查依赖
apt-cache depends package 了解使用依赖
apt-cache rdepends package 是查看该包被哪些包依赖


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [请教]ubuntu7.10的源问题
帖子发表于 : 2008-01-06 14:01 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
wubingzheng 写道:
现在装了7.10后,发现很多东西都不能直接用。像gcc都不能直接用,要先去下载几个东西? 我觉得ubuntu 应该不会这样吧,肯定是我自己在哪安装时出了问题吧。 网上也搜不到类似的问题。所以问下大家,如果直接安装好 7.10,gcc能不能直接用?

印象中,gcc编译器默认就有,但是头文件/库什么的没有。所以即使你要编译一个简单的hello world程序,也需要装build-essential包

wubingzheng 写道:
我在网上看要安装 build-essential libc6-dev。可是源里都是2.5版的,而我的 libc 是2.6的,所以安装不上去。这个怎么解决呢?以前我用 7.04时一直用 中科大的源,很好。

不知道你所说的以前用7.04时一直用中科大的源是指什么? 莫非你现在设的是7.04的源?

wubingzheng 写道:
是不是因为源里的东西比较老了? 那我应该怎么办呢?重新装回 7.04?这也太搓了吧。可是7.10在apt-get会出现很多这样的问题,就是:
xxx 依赖 yyy但是 zzz不会被安装

先看看源有没有问题,不确定的话,换成官方源试试。

wubingzheng 写道:
希望能得到大家的指导。谢谢!

大家都会很热情的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-06 14:13 

注册: 2007-12-28 23:54
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
to:dbzhang800

非常感谢你详细的回答。

我好像犯了个严重的错误。我一直因为源是通用的,还纳闷不同版本的源怎么能一起使用呢。。。。

但是我后来试了几个7.10的源(中科大,cn99,上海交通大学的),但用新德里打开,里面的包显示我都装了。但是都没有gcc需要的 build-essential,也没有libc6-dev。

不知道这该怎么办。是不是我哪还有初级的错误??

第一次装的ubuntu是同学给装的,所以我一直就是用apt-get,对源也不怎么了解。

谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-06 15:20 

注册: 2007-12-28 23:54
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
搞定了。原来要 apt-get upgrade一次。

我原来都不知道这个命令是干什么用的。又学到一样。

多谢多谢。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译