当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装CodeBlocks的问题
帖子发表于 : 2008-04-29 10:53 

注册: 2007-01-22 16:00
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
我安装CodeBlocks时,提示说没有安装libwxgtk2.8-0,依赖错误。但我后来apt-get install了libwxgtk2.8-0,还是出现这个提示,我应该怎么办?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-29 20:05 

注册: 2007-07-20 18:51
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
要安装wxWidgets这个库啊

这里有下:http://www.wxwidgets.org/downloads/

安装是常用的
代码:
./configure
make
sudo make install


然后配置动态库的导入路径
将 /usr/local/lib 这一行加入到/etc/ld.so.conf文件后面
代码:
sudo gedit /etc/ld.so.conf

然后
代码:
sudo ldconfig
让系统重新配置动态库文件导入的顺序

检测下安装成功没
代码:
wx-config --version
可以查看它的版本
代码:
wx-config --cxx

应该输出:g++


我原来是这么安装的,虽版本变了,应该没什么问题吧,看看INSTALL和README文件就是


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译