当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请求帮助!编译安装EDB时出现错误。
帖子发表于 : 2008-05-29 13:31 
头像

注册: 2008-04-14 13:19
帖子: 90
地址: 广东 茂名
送出感谢: 0 次
接收感谢: 0 次
ubuntu 8.04 x86

编译安装EDB时出现下面错误:
~/Download/debugger$ qmake
~/Download/debugger$ make
cd src/ && make -f Makefile
make[1]: Entering directory `/home/konglong/Download/debugger/src'
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I../include -Iwidgets -Iedisassm -Ios/unix -I../include/os/unix -Iarch/i386 -I../include/arch/i386 -I. -I. -o Debugger.o Debugger.cpp
Debugger.cpp: In function ‘DebugEventHandlerInterface* edb::v1::setDebugEventHandler(DebugEventHandlerInterface*)’:
Debugger.cpp:111: 错误: ‘q_atomic_set_ptr’在此作用域中尚未声明
make[1]: *** [Debugger.o] 错误 1
make[1]: Leaving directory `/home/konglong/Download/debugger/src'
make: *** [sub-src-make_default] 错误 2


希望高手能帮忙解决。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 编译安装EDB时出现错误。
帖子发表于 : 2008-06-10 14:29 

注册: 2006-11-15 13:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
没装QT4。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译