[问题]在7.10上面安装code:blocks的时候出现问题了,求救!

软件和网站开发以及相关技术探讨
回复
头像
bluesky4485
帖子: 39
注册时间: 2007-11-21 22:16
送出感谢: 0
接收感谢: 0

[问题]在7.10上面安装code:blocks的时候出现问题了,求救!

#1

帖子 bluesky4485 » 2008-06-04 21:35

网上下载了一个codeblocks_8.02-0ubuntu1.deb.tar.gz 解压后有7个文件,分别如下图所示,不知道装哪个了,试了半天后来就是一个依赖的问题导致无法安装。各位看看帮忙解决一下啊。

错误信息如下:
sudo dpkg -i codeblocks/libcodeblocks0_8.02-0ubuntu1_i386.deb
选中了曾被取消选择的软件包 libcodeblocks0。
(正在读取数据库 ... 系统当前总共安装有 124186 个文件和目录。)
正在解压缩 libcodeblocks0 (从 .../libcodeblocks0_8.02-0ubuntu1_i386.deb) ...
dpkg:依赖关系问题使得 libcodeblocks0 的配置工作不能继续:
libcodeblocks0 依赖于 libwxgtk2.8-0 (>= 2.8.7);然而:
系统中 libwxgtk2.8-0 的版本为 2.8.4.0-0ubuntu3。
dpkg:处理 libcodeblocks0 (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libcodeblocks0

sudo dpkg -i codeblocks/libcodeblocks0_8.02-0ubuntu1_i386.deb
(正在读取数据库 ... 系统当前总共安装有 124344 个文件和目录。)
正预备替换 libcodeblocks0 8.02-0ubuntu1 (使用 .../libcodeblocks0_8.02-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 libcodeblocks0 ...
dpkg:依赖关系问题使得 libcodeblocks0 的配置工作不能继续:
libcodeblocks0 依赖于 libwxgtk2.8-0 (>= 2.8.7);然而:
系统中 libwxgtk2.8-0 的版本为 2.8.4.0-0ubuntu3。
dpkg:处理 libcodeblocks0 (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libcodeblocks0
附件
2008-06-04-214021_1084x118_scrot.png
解压出来的文件。
(7.22 KiB) 下载 46 次
头像
bluesky4485
帖子: 39
注册时间: 2007-11-21 22:16
送出感谢: 0
接收感谢: 0

#2

帖子 bluesky4485 » 2008-06-05 9:27

不是吧?都没人遇到过吗?还是没人装这个啊?
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 solcomo » 2008-06-05 9:35

因为你用的7.10
libwxgtk2.8-0的版本还是2.8.4.0-0ubuntu3
8.04才是2.8.7.1-0ubuntu3
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
头像
bluesky4485
帖子: 39
注册时间: 2007-11-21 22:16
送出感谢: 0
接收感谢: 0

#4

帖子 bluesky4485 » 2008-06-05 9:56

怎么解决呢?
难道7.10就装不上code:blocks吗?
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 solcomo » 2008-06-05 13:15

你如果不想升级的话可以尝试下载8.04的libwxgtk2.8-0然后安装,估计会有很多依赖也得升级
或者自己编译
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
头像
bluesky4485
帖子: 39
注册时间: 2007-11-21 22:16
送出感谢: 0
接收感谢: 0

#6

帖子 bluesky4485 » 2008-06-05 13:43

难道就没有7.10下的code:blocks?
wanghuaiye
帖子: 7
注册时间: 2007-10-21 23:34
送出感谢: 0
接收感谢: 0

#7

帖子 wanghuaiye » 2008-07-25 17:36

我也是和LZ一样的问题,在线等。。。
coolspeed
帖子: 31
注册时间: 2008-05-06 17:02
来自: 山西太原
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]在7.10上面安装code:blocks的时候出现问题了,求救!

#8

帖子 coolspeed » 2008-10-12 20:46

我8.04还是安装不上,说codeblocks-contrib和 codeblocks-dbg安不上。怎么弄啊?
lovefan
帖子: 120
注册时间: 2008-03-05 12:13
来自: china
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]在7.10上面安装code:blocks的时候出现问题了,求救!

#9

帖子 lovefan » 2008-11-19 11:54

up,我8.04也装不了,上次装成功了,用了很久,这次重装,不行了。。
我对系统不熟,大家帮忙一下,thanks
回复

回到 “软件/网站开发”