当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]Ruby开发环境配置的问题
帖子发表于 : 2008-08-19 1:12 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
哪位知道ruby在Ubuntu下的开发环境配置的具体步骤
请详细的给我讲下

我ruby下好,rails用sudo apt-get下载下来了,确找不到目录,locate rails 也没有找到。
apache的ruby模块也下了。

请告诉我下具体的步骤和配置吧。
谢谢!!

:em53 :em53 :em53


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-19 17:22 

注册: 2007-11-30 10:12
帖子: 15
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
1、install ruby
apt-get install irb libdbm-ruby1.8 libgdbm-ruby1.8 libmysql-ruby1.8 libmysqlclient14 libopenssl-ruby1.8 libruby1.8-dbg mysql-common ri ri1.8 ruby1.8-dev
apt-get install ruby

2、install rubygem
#http://rubyforge.org/frs/?group_id=126&release_id=20667
wget http://rubyforge.org/frs/download.php/3 ... -1.1.0.tgz
tar zxfv rubygems-1.1.0.tgz
cd rubygems-1.1.0
sudo ruby setup.rb
提示:
RubyGems installed the following executables:
/usr/bin/gem1.8
运行:gem1.8 update –system

3、install Rails and dependencies
sudo gem1.8 install rails –include-dependencies

4、intall Mongrel
sudo apt-get install build-essential
sudo gem1.8 install mongrel –include-dependencies

5、测试
rails 版本:
rails -v
Rails 2.0.2
建立测试应用:
rails cookbook
cd cookbook
./script/server
打开http://localhost:3000/即可看到首页


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-27 0:04 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
謝謝這位仁兄!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [问题]Ruby开发环境配置的问题
帖子发表于 : 2008-09-02 14:57 

注册: 2007-07-17 14:36
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
JCheung 写道:
哪位知道ruby在Ubuntu下的开发环境配置的具体步骤
请详细的给我讲下

我ruby下好,rails用sudo apt-get下载下来了,确找不到目录,locate rails 也没有找到。
apache的ruby模块也下了。

请告诉我下具体的步骤和配置吧。
谢谢!!

:em53 :em53 :em53





再给你推荐一个netbean


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-02 17:53 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
ls这位仁兄。netbean为何物?
IDE???


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-05 2:37 
头像

注册: 2007-08-24 20:16
帖子: 164
地址: Hangzhou, China
送出感谢: 0 次
接收感谢: 0 次
JCheung 写道:
ls这位仁兄。netbean为何物?
IDE???


netbean顾名思义就是网络豆。

Rails开发不如用rails.vim


_________________
http://www.google.com/profiles/chenk85


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-05 11:45 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
谢谢ls的仁兄!!
知道了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-09-07 9:43 
头像

注册: 2007-05-08 16:26
帖子: 2058
地址: 火星内核某分子内某原子核内
系统: arch
送出感谢: 20
接收感谢: 6
Eclipse
使用 Eclipse 插件 Ruby Development Tools
NetBeans
NetBeans 6.0已经支持ruby开发。
Vim
http://vim-ruby.rubyforge.org/
Emacs
Emacs下设置Ruby On Rails开发环境 http://longgue.javaeye.com/blog/177763


_________________
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-09-07 10:14 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
谢谢!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译