当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : QT编程,make不能通过
帖子发表于 : 2008-09-30 22:18 
头像

注册: 2007-09-26 17:34
帖子: 618
送出感谢: 0 次
接收感谢: 2
就是一个简单的hellow world程序,按照ubuntu wiki上讲的,把软件包都安装上了,而且qmake都通过了。怎么回事?
代码:
wind@wind-desktop:~/C$ qmake -project
wind@wind-desktop:~/C$ qmake
wind@wind-desktop:~/C$ make
gcc -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_SHARED -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/local/Trolltech/Qt-4.4.2/include/QtCore -I/usr/local/Trolltech/Qt-4.4.2/include/QtGui -I/usr/local/Trolltech/Qt-4.4.2/include -I. -I. -I. -o 33.o 33.c
33.c:1:24: 错误: QApplication:没有该文件或目录
33.c:2:24: 错误: QPushButton:没有该文件或目录
33.c: 在函数‘main’中:
33.c:6: 错误: ‘QApplication’未声明 (在此函数内第一次使用)
33.c:6: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
33.c:6: 错误: 所在的函数内也只报告一次。)
33.c:6: 错误: expected ‘;’ before ‘app’
33.c:8: 错误: ‘QPushButton’未声明 (在此函数内第一次使用)
33.c:8: 错误: expected ‘;’ before ‘hello’
33.c:9: 错误: ‘hello’未声明 (在此函数内第一次使用)
33.c:12: 错误: ‘app’未声明 (在此函数内第一次使用)
33.c:4: 警告: 未使用的参数‘argc’
33.c:4: 警告: 未使用的参数‘argv’
33.c:13:2: 警告: 文件未以空白行结束
make: *** [33.o] 错误 1


页首
 用户资料  
 
2 楼 
 文章标题 : Re: QT编程,make不能通过
帖子发表于 : 2009-06-02 18:19 

注册: 2008-12-27 16:28
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
ding a
woye buzhidao


_________________
linux


页首
 用户资料  
 
3 楼 
 文章标题 : Re: QT编程,make不能通过
帖子发表于 : 2009-06-19 21:54 

注册: 2008-10-31 22:12
帖子: 6546
系统: 践兔
送出感谢: 18
接收感谢: 25
很无语,qt应该用c++而不是C
引用:
首先编写源代码。 新建文件夹qt4hello,然后再里面新建文件 main.cpp,内容如下:
代码:
#include <QApplication>
#include <QPushButton>
 
int main(int argc, char *argv[])
{
    QApplication app(argc, argv);
 
    QPushButton hello("Hello Ubuntu!");
    hello.resize(100, 30);
 
    hello.show();
    return app.exec();
}


_________________
代码:
] ls -ld //


页首
 用户资料  
 
4 楼 
 文章标题 : Re: QT编程,make不能通过
帖子发表于 : 2009-06-22 16:50 
头像

注册: 2009-06-21 19:38
帖子: 210
地址: CUMT
送出感谢: 0 次
接收感谢: 0 次
:em04 Qt什么时候支持C了?


_________________
代码:
sudo apt-get install girlfriend
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。
下列的信息可能会对解决问题有所帮助:
下列的软件包有不能满足的依赖关系:
girlfriend: 依赖: house但是它将不会被安装
girlfriend: 依赖: car但是它将不会被安装
house,car: 依赖: money但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
5 楼 
 文章标题 : Re: QT编程,make不能通过
帖子发表于 : 2009-08-16 14:40 

注册: 2008-10-31 22:12
帖子: 6546
系统: 践兔
送出感谢: 18
接收感谢: 25
还有,应该用qmake-qt4


_________________
代码:
] ls -ld //


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译