当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 19:58 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
该开始装的eclipse不能新建web工程
现在好不容易能编辑jsp页面了,可是不能编译运行,
也就是新建了web工程之后,就算直接运行也会报告内部错误,但是没有错误描述
tomcat能启动,可是内置浏览器都不会自动弹出来已经报错了

请问各位谁知道怎么解决

或者谁正在用myeclipse开发jsp的请指点一下你们怎么配置了
或者干脆共享一下你们的安装包哈~

谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 21:41 

注册: 2008-10-15 17:20
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
我正在用,但我服务tomcat启动的时候,console里面报出来,8080地址已被用。启动不了。Help me please!!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 21:54 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
你是用的自带的还是自己安装的tomcat阿
确保只有一个tomcat开启
或者自己换个端口..

另外你安装的哪个版本阿?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:00 

注册: 2008-10-15 17:20
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
我的已经解决了。不知楼主可否将错误报上来呢?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:07 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
4楼的我看到你说解决了真就看到希望了

我的问题在于myeclipse提示出错
但是没有错误内容

An internal error occurred during: "Launching New_configuration".
null argument:


-------
没有别的提示了...
单独启动tomcat没问题,就是不能运行


页首
 用户资料  
 
6 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:15 

注册: 2007-03-19 19:15
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
一般来说,别用源上的eclipse,我用了几次都不对劲,单独下一个,tomcat也是,要解压缩版的,要是安装了源上的tomcat,又自己单独安装了一个,那么要么停掉源上安的那个(源上安装的一般默认开机启动,会占了8080端口),好像是 sudo /etc/init.d/tomcat stop 然后在开机启动里取消。
还有eclipse和myeclipse的相应版本要正确。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:21 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我就是自己另下的myecclipse
用的是他自带的tomcat
就是4楼的错误总是绊着过不去阿...我这个急阿
java工程就能成功运行
可我要开发jsp阿

请各位高手多多帮忙哈

我11点熄灯,会一直关注本帖
今天解决不了明天继续
直到秒杀那个错误


页首
 用户资料  
 
8 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:24 

注册: 2007-03-19 19:15
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
跟我一样可怜的大学生吧?
myeclipse自带的tomcat,经常不行,一般自己另外下载。
实在不行,祭出最后一招,全部删除,然后重装。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:28 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
8楼真乃知己阿

可惜我已经删除重装三四次了
问题依旧
昨天下午成功运行过一次
然后及其兴奋,马上冲下去吃饭了(为了这个问题已经很久没吃饭了)
结果回来一开机又不行了...

当时死的心都有了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:40 

注册: 2007-03-19 19:15
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
源里的eclipse?
单独下个吧 eclipse3.3就可以了 用相应版本的myeclipse再试试。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:44 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我是直接下了一个MyEclipse6.5的bin
插件都是自动下载的,装好了连jdk都带了
运行java没问题

单独安装的是最先尝试的,那时候不能新建web工程

楼上的你装的哪几个阿
拜托详细说下,最好给个连接,我真的很需要,谢谢了


页首
 用户资料  
 
12 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:49 

注册: 2007-03-19 19:15
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
具体那个eclipse版本配myeclipse版本自己从myeclipse的官网上查吧,很清楚的,然后找个单独的有完全权限的文件夹,分别建立相应的目录安装,可恶的myeclipse,没有all-in-one for linux的版本。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-06 22:54 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
先谢谢starster

我明天在全部重新搞一下试试

你的出现给了我很多信心

今天先下了,要断电了,明天再来刷贴

3Q~


页首
 用户资料  
 
14 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-07 22:33 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
刚装上了MyEclpse5.5
但是依然启动不了,貌似没有支持的浏览器...


页首
 用户资料  
 
15 楼 
 文章标题 : Re: MyEclipse开发web工程的问题:运行出错
帖子发表于 : 2008-11-08 2:53 

注册: 2008-11-01 23:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
运行jsp工程后tomcat自动启动,但是启动完了就没反应了,不能自动打开浏览器窗口
我已经重新设置过浏览器了
依然不解。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译