当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 快被Qt 给逼疯了
帖子发表于 : 2009-02-09 4:21 

注册: 2008-02-15 0:45
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
http://wiki.ubuntu.org.cn/Gtk%E4%B8%8EQ ... D%E7%BD%AE

究竟怎么安装Qt4啊 根本就像那些简单的命令行那样就好了 一大堆的依赖问题 ! 根本就装不了 ... 大侠们快救救我 !

代码:
sudo apt-get install libqt4-dev qt4-designer qt4-doc


代码:
sudo apt-get install kde4-devel


都没用 ! 

引用:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt4-dev: Depends: libqt4-assistant (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-dbus (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-designer (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-help (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-network (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-qt3support (= 4.4.0-1ubuntu5~hardy1) but it is not going to be installed
Depends: libqt4-script (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-sql (= 4.4.0-1ubuntu5~hardy1) but it is not going to be installed
Depends: libqt4-svg (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-test (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-webkit (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-xml (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-xmlpatterns (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqtcore4 (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqtgui4 (= 4.4.0-1ubuntu5~hardy1) but it is not installable
qt4-designer: Depends: libqt4-designer (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-network (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqt4-xml (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqtcore4 (= 4.4.0-1ubuntu5~hardy1) but it is not installable
Depends: libqtgui4 (= 4.4.0-1ubuntu5~hardy1) but it is not installable
E: Broken packages
qzi@qzi-desktop:~/Desktop/qt3hello$ sudo apt-get install kde4-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kde4-devel: Depends: kde4-core (>= 3.3) but it is not going to be installed
Depends: kdebase-dev-kde4 (>= 4:4.0.0) but it is not going to be installed
Depends: kdelibs5-dev (>= 4:4.0.0) but it is not going to be installed
Depends: kdepimlibs5-dev (>= 4:4.0.0) but it is not going to be installed
Depends: kdesdk-kde4 (>= 4:4.0.0) but it is not going to be installed
Depends: libkonq5-dev (>= 4:4.0.0) but it is not going to be installed
Depends: libphonon-dev (>= 4:4.0.0) but it is not going to be installed
Depends: libplasma-dev (>= 4:4.0.0) but it is not going to be installed
Depends: qt4-designer but it is not going to be installed
E: Broken packages


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-02-09 10:19 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
ubuntu版本太老


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-02-09 16:04 

注册: 2008-02-15 0:45
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
ubuntu版本太老


ubuntu 8.04


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-02-22 10:04 

注册: 2007-05-11 17:27
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
斑竹...
该出手时就出手吧.


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-03-07 21:18 

注册: 2008-11-29 22:38
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
很简单了,前几天Qt4.5发布了,有一个SDK.
去Qt的网站上下载一个bin文件,安装上就好了.
什么都有.
不过个人感觉那个Qt Create用起来不是很爽.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-03-09 18:14 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
可能加的源和ubuntu版本不符,检查下sources.list


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-03-09 18:50 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
用sudo aptitude试试


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 快被Qt 给逼疯了
帖子发表于 : 2009-03-09 19:07 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
如果 8.04 的话楼主要不要试试 sudo apt-get build-dep kate-kde4 。这个要好用些。

8.04 要装 Qt 4.4 的话需要开 backports 。4.5 就只能到官方下了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译