当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Compile issue with gcc, Help needed!
帖子发表于 : 2009-02-17 10:34 

注册: 2008-11-11 15:54
帖子: 232
送出感谢: 0 次
接收感谢: 0 次
I compiled my program and found that , see below.

How can i fix ?????????.

Help is appreciated. THanks.

$ make
make all-am
make[1]: Entering directory `/home/daniel/work/usi_nas_findd'
if gcc -DHAVE_CONFIG_H -I. -I. -I. -I include/ -g -O2 -MT usi_nas_findd-usi_nas_cmd.o -MD -MP -MF ".deps/usi_nas_findd-usi_nas_cmd.Tpo" -c -o usi_nas_findd-usi_nas_cmd.o `test -f 'src/usi_nas_cmd.c' || echo './'`src/usi_nas_cmd.c; \
then mv -f ".deps/usi_nas_findd-usi_nas_cmd.Tpo" ".deps/usi_nas_findd-usi_nas_cmd.Po"; else rm -f ".deps/usi_nas_findd-usi_nas_cmd.Tpo"; exit 1; fi
src/usi_nas_cmd.c: ???'usiNas_readfile_linelimit'?:
src/usi_nas_cmd.c:26: ??: ????? warn_unused_result ???'fgets'????
src/usi_nas_cmd.c: ???'usiNas_system_serialNumber'?:
src/usi_nas_cmd.c:51: ??: ??'%x'????'unsigned int',??? 2 ????'char *'
src/usi_nas_cmd.c: ???'usiNas_system_hostName'?:
src/usi_nas_cmd.c:76: ??: ??'%x'????'unsigned int',??? 2 ????'char *'
src/usi_nas_cmd.c: ???'cmdGetNasBrowsePath'?:
src/usi_nas_cmd.c:315: ??: ??'%s'????'char *',??? 3 ????'void *'
src/usi_nas_cmd.c: ???'scanDir'?:
src/usi_nas_cmd.c:467: ??: 'list'???(??????????)
src/usi_nas_cmd.c:467: ??: (????????????,???????????
src/usi_nas_cmd.c:467: ??: ?????????????)
src/usi_nas_cmd.c:498: ??: 's'???????
src/usi_nas_cmd.c:499: ??: 'DIR'???(??????????)
src/usi_nas_cmd.c:499: ??: 'dir'???(??????????)
src/usi_nas_cmd.c:540: ??: ??????????,??????
src/usi_nas_cmd.c:542: ??: ????????????
src/usi_nas_cmd.c:543: ??: ????????????
src/usi_nas_cmd.c:543: ??: ????????????
src/usi_nas_cmd.c:543: ??: ????????????
src/usi_nas_cmd.c:543: ??: ????????????
src/usi_nas_cmd.c:543: ??: ????????????
src/usi_nas_cmd.c:543: ??: ????????????


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Compile issue with gcc, Help needed!
帖子发表于 : 2009-02-17 10:56 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
咋都是??? export LC_ALL=C 搞出英文来再看看


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Compile issue with gcc, Help needed!
帖子发表于 : 2009-02-17 13:50 

注册: 2008-11-11 15:54
帖子: 232
送出感谢: 0 次
接收感谢: 0 次
yeah, I have corretted this, due to fcitx.
As it export chinese environment. when I remove these variables, it goes back to normal output.

Thanks. :em01


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译