当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-03-17 10:41 

注册: 2009-03-17 10:29
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
下载并安装了QT4。5,用QT Creater创建了一个简单的工程,可在编译调试的时候出现错误:cannot find -lfreetype ,请问是什么原因?是不是还要装什么文件啊?谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-03-24 18:38 

注册: 2009-03-11 10:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
:em05 我也有此问题,Qt4.5在GNOME环境下似乎不行呀.... :em04


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-03-27 20:53 
头像

注册: 2007-09-26 17:34
帖子: 618
送出感谢: 0 次
接收感谢: 2
qt4包含的库:
core核心
gui图形
network网络
opengl opengl接口
script脚本
sql数据库
svg
webkit网页渲染引擎
xml
xml patterns
phonon
qt3 support qt3支持
test
dbus

对于初学者来说,只需安装core和gui就可以运行了
在ubuntu里,这2个库对应的名字为libqt4-core和libqt4-gui


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-04-04 9:13 

注册: 2008-11-29 21:30
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
你还要装Qmake,我以前也遇到过。后来装了就没事了。你先运行一下“终端”
输入: qmake *.pro
它会提示你出错,并告诉你需要安装的东西,按它的提示你就可以安装了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-04-04 9:28 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
fcloud 写道:
下载并安装了QT4。5,用QT Creater创建了一个简单的工程,可在编译调试的时候出现错误:cannot find -lfreetype ,请问是什么原因?是不是还要装什么文件啊?谢谢


Linux环境本身需要QT,你最简单的解决方式是使用 Ubuntu 9.04 ,其中自带 Qt 4.5 解决这些问题要比较容易。

自己装当然不是不行,不过如果对解决-lfreetype这类问题,不能找身边的人的话,我建议还是使用Windows版本比较合适。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-04-11 22:56 
头像

注册: 2008-04-14 13:19
帖子: 90
地址: 广东 茂名
送出感谢: 0 次
接收感谢: 0 次
fcloud 写道:
下载并安装了QT4。5,用QT Creater创建了一个简单的工程,可在编译调试的时候出现错误:cannot find -lfreetype ,请问是什么原因?是不是还要装什么文件啊?谢谢


试一下
sudo apt-get install libfreetype6-dev

可能下面还会出现cannot find -lxxx 什么的,这是找不到这个连接库,你到新立得里面搜xxx,然后安装就行了


_________________
最重要的,
拥有跟随内心与直觉的勇气,
因为你的内心与直觉或多或少已经知道你真正想要成为什么样的人~
我的主页:http://sites.google.com/site/konglinglong/


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-04-23 17:46 
头像

注册: 2009-04-20 11:50
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
肯定会遇到依赖链~~找个没完没了了~~

有没有完整些的库呢,做基本开发为什么还会缺少这么多库?


_________________
呜,笨猪~~


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 如何在Ubuntu8.10 Gnome环境下安装运行QT4.5?
帖子发表于 : 2009-04-25 23:14 

注册: 2008-09-25 21:31
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
很简单啥 :em11
查看链接http://forum.ubuntu.org.cn/viewtopic.php?f=88&t=190878&p=1233718#p1233718


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译