当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 编译e17的cvs版本出错!
帖子发表于 : 2005-09-16 17:35 

注册: 2005-05-17 14:45
帖子: 334
送出感谢: 0 次
接收感谢: 0 次
编译eet时出错了!
zengsun@sun:~/e17/libs/eet$ ./autogen.sh
Running aclocal...
aclocal:configure.in:17: warning: macro `AM_ENABLE_SHARED' not found in library
aclocal:configure.in:18: warning: macro `AM_PROG_LIBTOOL' not found in library
Running autoheader...
Running autoconf...
configure.in:17: error: possibly undefined macro: AM_ENABLE_SHARED
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:18: error: possibly undefined macro: AM_PROG_LIBTOOL
请问这个问题如何解决?


_________________
现在还是在学java!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 编译e17的cvs版本出错!
帖子发表于 : 2005-09-16 18:25 
头像

注册: 2005-07-01 18:56
帖子: 887
地址: 广州市
送出感谢: 0 次
接收感谢: 3
zengsun 写道:
编译eet时出错了!
zengsun@sun:~/e17/libs/eet$ ./autogen.sh
Running aclocal...
aclocal:configure.in:17: warning: macro `AM_ENABLE_SHARED' not found in library
aclocal:configure.in:18: warning: macro `AM_PROG_LIBTOOL' not found in library
Running autoheader...
Running autoconf...
configure.in:17: error: possibly undefined macro: AM_ENABLE_SHARED
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:18: error: possibly undefined macro: AM_PROG_LIBTOOL
请问这个问题如何解决?

请选安装这个包再编译一次,有问题继续...
代码:
apt-get install libtool


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-19 9:06 

注册: 2005-05-17 14:45
帖子: 334
送出感谢: 0 次
接收感谢: 0 次
编译e有问题!
Running aclocal...
aclocal:configure.in:147: warning: macro `AM_GNU_GETTEXT' not found in library
aclocal:configure.in:148: warning: macro `AM_GNU_GETTEXT_VERSION' not found in library
Running autoheader...
Running autoconf...
configure.in:147: error: possibly undefined macro: AM_GNU_GETTEXT
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:148: error: possibly undefined macro: AM_GNU_GETTEXT_VERSION
zengsun@sun:~/e17/apps/e$ ./autogen.sh
Running aclocal...
aclocal:configure.in:147: warning: macro `AM_GNU_GETTEXT' not found in library
aclocal:configure.in:148: warning: macro `AM_GNU_GETTEXT_VERSION' not found in library
Running autoheader...
Running autoconf...
configure.in:147: error: possibly undefined macro: AM_GNU_GETTEXT
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:148: error: possibly undefined macro: AM_GNU_GETTEXT_VERSION


_________________
现在还是在学java!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-09-19 9:11 
头像

注册: 2005-07-01 18:56
帖子: 887
地址: 广州市
送出感谢: 0 次
接收感谢: 3
代码:
apt-get install gettext-base gettext liblocale-gettext-perl


_________________
I will be back!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-09-19 13:31 

注册: 2005-05-17 14:45
帖子: 334
送出感谢: 0 次
接收感谢: 0 次
总算用上e17,
但编译eclair时又出现以下错误:
checking pkg-config is at least version 0.9.0... yes
checking for SQLITE... configure: error: Package requirements (sqlite3) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the SQLITE_CFLAGS and SQLITE_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
不知如何解决。


_________________
现在还是在学java!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-09-19 15:10 

注册: 2005-05-17 14:45
帖子: 334
送出感谢: 0 次
接收感谢: 0 次
发现一个问题,在e17中使用命令行:gnome-theme-manager
结果所有gtk程序使用在gnome环境的样式,即使退出程序也没有影响!
有没有办法在e17开始时就使用样式?就像xfce4一样。


_________________
现在还是在学java!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-09-19 16:12 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
zengsun 写道:
总算用上e17,
但编译eclair时又出现以下错误:
checking pkg-config is at least version 0.9.0... yes
checking for SQLITE... configure: error: Package requirements (sqlite3) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the SQLITE_CFLAGS and SQLITE_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
不知如何解决。


提示已经说的很清楚了啊,要么装sqlite3,如果已经装了,又没装到标准路径上,那就调整PKG_CONFIG_PATH环境变量。

或者……


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-09-20 8:43 

注册: 2005-05-17 14:45
帖子: 334
送出感谢: 0 次
接收感谢: 0 次
我装了sqlite3,一样报错。
什么是标准路径?
PKG_CONFIG_PATH 环境变量的值是什么?


_________________
现在还是在学java!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译