wxWidget项目编译出错

软件和网站开发以及相关技术探讨
回复
fox6.0
帖子: 5
注册时间: 2008-10-31 17:17
送出感谢: 0
接收感谢: 0

wxWidget项目编译出错

#1

帖子 fox6.0 » 2010-12-20 15:04

用CodeBlocks 创建WxWidget项目后进行编译时提示"wx/wxprec.h","wx/wx.h"等错误,找了一个解决办法如下:
在新建project后在code blocks中设置project>builder options:

在终端运行

# wx-config --cxxflags

将得到的结果

-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread

贴到Compiler settings >> Other options中.


在终端运行

# wx-config --libs

将得到的结果
-pthread -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_ba
贴到Linker options >> Other linker options中.
回复

回到 “软件/网站开发”