Android SDK能够运行但是出错..求大家帮忙

软件和网站开发以及相关技术探讨
回复
googolmo
帖子: 1
注册时间: 2010-03-11 15:30
送出感谢: 0
接收感谢: 0

Android SDK能够运行但是出错..求大家帮忙

#1

帖子 googolmo » 2011-02-02 13:33

我是64位ATI的显卡..用的开源显卡驱动..但是AndroidSDK能够启动..也能创建AVD可是启动模拟器的时候就会报错..具体错误信息如下:

代码: 全选

java.awt.HeadlessException
	at sun.awt.HeadlessToolkit.getScreenResolution(HeadlessToolkit.java:221)
	at com.android.sdkuilib.internal.widgets.AvdStartDialog.getMonitorDpi(AvdStartDialog.java:420)
	at com.android.sdkuilib.internal.widgets.AvdStartDialog.createDialogContent(AvdStartDialog.java:179)
	at com.android.sdkuilib.ui.GridDialog.createDialogArea(GridDialog.java:73)
	at org.eclipse.jface.dialogs.Dialog.createContents(Dialog.java:760)
	at org.eclipse.jface.window.Window.create(Window.java:431)
	at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
	at org.eclipse.jface.window.Window.open(Window.java:790)
	at com.android.sdkuilib.internal.widgets.AvdSelector.onStart(AvdSelector.java:1027)
	at com.android.sdkuilib.internal.widgets.AvdSelector.access$600(AvdSelector.java:75)
	at com.android.sdkuilib.internal.widgets.AvdSelector$7.widgetSelected(AvdSelector.java:316)
	at org.eclipse.swt.widgets.TypedListener.handleEvent(Unknown Source)
	at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
	at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
	at com.android.sdkuilib.internal.repository.UpdaterWindowImpl.open(UpdaterWindowImpl.java:105)
	at com.android.sdkuilib.repository.UpdaterWindow.open(UpdaterWindow.java:98)
	at com.android.sdkmanager.Main.showMainWindow(Main.java:312)
	at com.android.sdkmanager.Main.doAction(Main.java:265)
	at com.android.sdkmanager.Main.run(Main.java:99)
	at com.android.sdkmanager.Main.main(Main.java:88)
pionere
帖子: 1
注册时间: 2011-04-16 23:41
送出感谢: 0
接收感谢: 0

Re: Android SDK能够运行但是出错..求大家帮忙

#2

帖子 pionere » 2011-04-16 23:46

Hi!
I got the same exception when I had only openjdk-6-jre-headless and openjdk-6-jre-lib packages installed.
I had to install openjdk-6-jre as well and now it seems to work, although a bit slow...
HTH
mayan31370
帖子: 4
注册时间: 2011-05-06 17:47
送出感谢: 0
接收感谢: 0

Re: Android SDK能够运行但是出错..求大家帮忙

#3

帖子 mayan31370 » 2011-05-06 18:01

建议使用sun的jdk和jre
我也在ubuntu下开发android
从来没出过问题
回复

回到 “软件/网站开发”