求助:JSP显示MYSQL中文时候出现乱码

软件和网站开发以及相关技术探讨
回复
aaronbai
帖子: 163
注册时间: 2006-10-15 10:12
送出感谢: 0
接收感谢: 0

求助:JSP显示MYSQL中文时候出现乱码

#1

帖子 aaronbai » 2006-11-26 12:44

在EDGY中安装的MYSQL,原来可以在终端下显示中文,MYSQL QUERY Brower一直显乱码


于是我在MYSQL终端执行:


SET character_set_client = GB2312;
SET character_set_connection = GB2312;
SET character_set_database = GB2312;
SET character_set_results = GB2312;
SET character_set_server = GB2312;

SET collation_connection = GB2312_bin;
SET collation_database = GB2312_bin;
SET collation_server = GB2312_bin;


结果还是乱码!

另外,在JSP页面显示中文也是乱码!!



~$ cat /etc/mysql/my.cnf
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/serve ... ables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords = 1
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
#bind-address = 127.0.0.1 是否允许其他机器访问MySQL了
#
# * Fine Tuning
#
key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 128K
thread_cache_size = 8
#
# * Query Cache Configuration
#
query_cache_limit = 1048576
query_cache_size = 16777216
query_cache_type = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement Smile
#
# Here you can see queries with especially long duration
#log_slow_queries = /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days = 10
max_binlog_size = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * MyISAM
#
# MyISAM is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more MyISAM related options. There are many!
# You might want to disable MyISAM to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer = 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1
Gmail: baifh03@gmail.com
MSN:aaronminwoo@hotmail.com
喜欢LINUX的加我!
一起学习讨论!
jk88811
帖子: 55
注册时间: 2006-02-16 9:42
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 jk88811 » 2006-12-24 16:57

字符编码我一直使用utf-8, 在Windows控制台会显示乱码,但查询分析器正常

在Linux下一切OK
zhmtiger
帖子: 18
注册时间: 2007-09-04 15:37
送出感谢: 0
接收感谢: 0

#3

帖子 zhmtiger » 2007-09-30 17:25

关键是连mysql时的编码要弄好,最好GBK,要不然插入数据时就是乱码,至于页面上的编码只要gb2312就好,不用再改了,
我用resin的连接池,连的时候直接指定编码为GBK就好了,另外有时侯驱动程序不同,也可能有差别,要注意一下!
头像
maninred
帖子: 164
注册时间: 2007-08-24 20:16
来自: Hangzhou, China
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 maninred » 2007-10-03 10:11

zhmtiger 写了:关键是连mysql时的编码要弄好,最好GBK,要不然插入数据时就是乱码,至于页面上的编码只要gb2312就好,不用再改了,
我用resin的连接池,连的时候直接指定编码为GBK就好了,另外有时侯驱动程序不同,也可能有差别,要注意一下!
全部用utf-8好不好?还想用gbk的话你不要用Linux,用回你的win好了。Linux就是一个很好的utf-8的OS。这就是为什么用utf-8有时在win下会乱码的原因。很多公司都规定全部用utf-8了吧。
头像
yexin218
帖子: 461
注册时间: 2007-08-22 17:36
来自: 澳门
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yexin218 » 2007-10-03 10:41

我很敏捷,我是网上的蜘蛛;我很茫然,我是网中的猎物!
欢迎到我的Blog※代码回音※
头像
chaoyagami
帖子: 207
注册时间: 2007-05-27 21:25
来自: 江西南昌
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 chaoyagami » 2007-10-10 18:11

应该用UTF-8编码。
NetBeans 6.0于12月3日正式发布。
www.netbeans.org
回复

回到 “软件/网站开发”