[分享]安装Code::Blocks开发环境

软件和网站开发以及相关技术探讨
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

[分享]安装Code::Blocks开发环境

#1

帖子 forrid » 2007-06-09 12:00

今日安装成功Code::Blocks——类似于VC++ 6.0的程序开发环境,特与广大Ubuntuer分享。

具体安装步骤如下:
1、安装必要组件

代码: 全选

sudo apt-get install build-essential

代码: 全选

sudo apt-get install gdb
2、更新源

代码: 全选

gksudo gedit /etc/apt/sources.list
添加(以feisty为例):

代码: 全选

deb http://apt.tt-solutions.com/ubuntu/ feisty main
3、获取密钥

代码: 全选

wget http://www.tt-solutions.com/vz/key.asc

代码: 全选

sudo apt-key add key.asc
4、安装最新 wxWidgets 库

代码: 全选

sudo apt-get update

代码: 全选

sudo apt-get install libwxgtk2.8-0 libwxgtk2.8-dev wx2.8-headers wx-common
5、设置 wxWidgets 默认版本

代码: 全选

sudo update-alternatives --config wx-config
从列表中选择一项即可。
6、下载 Code::Blocks 每夜构建版本
下载地址:http://forums.codeblocks.org/index.php/board,20.0.html
7、安装 Code::Blocks

代码: 全选

sudo dpkg -i CB_20070608_rev4078_Ubuntu6.10+7.04_wx2.8.4.deb
其中,CB_20070608_rev4078_Ubuntu6.10+7.04_wx2.8.4.deb是2007年6月8日最新版本,以此类推。

参考 http://wiki.codeblocks.org/

吾生也有涯,而知也无涯,以有涯随无涯,SB啊~~~~~~~~~~
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

#2

帖子 forrid » 2007-06-10 21:41

没人顶啊,可怜~~~
silverwang2007
帖子: 9
注册时间: 2006-12-24 14:09
送出感谢: 0
接收感谢: 0

#3

帖子 silverwang2007 » 2007-06-11 0:38

我按照你说的方法安装并配置了wx,但是在安装的时候却出现依赖问题。详细出错信息如下:

dpkg:依赖关系问题使得 codeblocks 的配置工作不能继续:
codeblocks 依赖于 libwxbase2.8-0 (>= 2.8.4.0);然而:
系统中 libwxbase2.8-0 的版本为 2.8.1.1-0ubuntu4。
codeblocks 依赖于 libwxgtk2.8-0 (>= 2.8.4.0);然而:
系统中 libwxgtk2.8-0 的版本为 2.8.1.1-0ubuntu4。
codeblocks 依赖于 libwxgtk2.8-0 (>= 2.8.4);然而:
系统中 libwxgtk2.8-0 的版本为 2.8.1.1-0ubuntu4。
codeblocks 依赖于 libwxbase2.8-0 (>= 2.8.4);然而:
系统中 libwxbase2.8-0 的版本为 2.8.1.1-0ubuntu4。
dpkg:处理 codeblocks (--install)时出错:
依赖关系问题 - 仍未被配置

我的wx-config的信息如下:

There are 2 alternatives which provide `wx-config'.

Selection Alternative
-----------------------------------------------
1 /usr/lib/wx/config/base-unicode-release-2.8
*+ 2 /usr/lib/wx/config/gtk2-unicode-release-2.8

我尝试了1和2,均出现这个问题。
这个问题怎么解决呢?
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

#4

帖子 forrid » 2007-06-11 18:38

试试

代码: 全选

sudo apt-get install libwxbase2.8-0 libwxbase2.8-dev

吾生也有涯,而知也无涯,以有涯随无涯,SB啊~~~~~~~~~~
silverwang2007
帖子: 9
注册时间: 2006-12-24 14:09
送出感谢: 0
接收感谢: 0

#5

帖子 silverwang2007 » 2007-06-11 22:49

我的系统里的这两个包已经是最新的了。
qianghr
帖子: 67
注册时间: 2007-03-09 14:23
送出感谢: 0
接收感谢: 0

#6

帖子 qianghr » 2007-06-13 16:55

ls的哥们 源里的wxWidget版本低哪 按楼主说的应该可以的
ray58750034
帖子: 24
注册时间: 2007-06-19 8:55
送出感谢: 0
接收感谢: 0

#7

帖子 ray58750034 » 2007-06-25 23:46

Nice job!
silverwang2007
帖子: 9
注册时间: 2006-12-24 14:09
送出感谢: 0
接收感谢: 0

#8

帖子 silverwang2007 » 2007-07-17 22:58

我还是放弃在Linux上用Code::Blocks了,现在在用NetBeans+C++ Pack。很好用的。各位有时间也可以试试。
cjjhr99
帖子: 75
注册时间: 2007-06-04 1:55
送出感谢: 0
接收感谢: 0

#9

帖子 cjjhr99 » 2007-07-26 2:53

CB_20070723_rev4300_Ubuntu6.10+7.04_wx2.8.4.tar.gz
我下载后是以上的文件名,是不是直接把扩展名改成.deb
然后 sudo dpkg -i CB_20070723_rev4300_Ubuntu6.10+7.04_wx2.8.4.deb啊?


dpkg-deb: “CB_20070723_rev4300_Ubuntu6.10+7.04_wx2.8.4.deb”并非 debian 格式的包文件
dpkg:处理 CB_20070723_rev4300_Ubuntu6.10+7.04_wx2.8.4.deb (--install)时出错:
子进程·dpkg-deb --control·返回了错误号·2
在处理时有错误发生:
CB_20070723_rev4300_Ubuntu6.10+7.04_wx2.8.4.deb

我运行后的结果却是这样啊 ,这是为什么? 求助。
cjjhr99
帖子: 75
注册时间: 2007-06-04 1:55
送出感谢: 0
接收感谢: 0

#10

帖子 cjjhr99 » 2007-07-26 3:22

终于找到方法里,原来是要把它解压出来,然后一个一个安装。

可安装后又出现问题里 每次运行这个IDE到出现 TODAY TIP的时候就没有响应 CPU100% 这是为什么?
cjjhr99
帖子: 75
注册时间: 2007-06-04 1:55
送出感谢: 0
接收感谢: 0

#11

帖子 cjjhr99 » 2007-07-26 11:19

郁闷,重新安装后还是一样 是不是没的救啊
shaoshuai_496
帖子: 99
注册时间: 2007-07-22 14:50
来自: 哈尔滨工业大学
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 shaoshuai_496 » 2007-07-26 18:14


我们C语言就用这个
cjjhr99
帖子: 75
注册时间: 2007-06-04 1:55
送出感谢: 0
接收感谢: 0

#13

帖子 cjjhr99 » 2007-07-26 23:19

每次运行这个IDE到出现 TODAY TIP的时候就没有响应 CPU100% 这是为什么?
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#14

帖子 windwiny » 2007-07-27 8:42

原来是在论坛里下载啊。。。。每次去它的主页版本都是1.0rc2
还以为这个项目早死掉了
头像
oyasmi
帖子: 173
注册时间: 2007-06-04 9:54
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 oyasmi » 2007-07-29 8:30

装上了,挺好用的,谢谢楼主!
等待青春散场;等待年华老去!
回复

回到 “软件/网站开发”