求教一个有关eclipse的问题

软件和网站开发以及相关技术探讨
回复
winzzy
帖子: 29
注册时间: 2006-04-22 5:05
送出感谢: 0
接收感谢: 0

求教一个有关eclipse的问题

#1

帖子 winzzy » 2007-06-09 15:18

点运行的时候弹出的错误
错误->An internal error occurred during:"Launching".

root/workspace/.metadata/.log 中的错误提示
!SESSION 2007-06-09 15:03:50.106 -----------------------------------------------
eclipse.buildId=M20070212-1330
java.fullversion=GNU libgcj 4.1.2 20070502 (Red Hat 4.1.2-12)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=zh_CN
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.update.configurator 2007-06-09 15:03:51.943
!MESSAGE Could not install bundle plugins/org.eclipse.pde.build/ Bundle "org.eclipse.pde.build" version "3.2.1.r321_v20060823" has already been installed from: update@plugins/org.eclipse.pde.build_3.2.1.r321_v20060823/

!ENTRY org.eclipse.core.jobs 4 2 2007-06-09 15:04:26.728
!MESSAGE An internal error occurred during: "Launching".
!STACK 0
java.lang.NullPointerException
at org.eclipse.cdt.launch.internal.LocalCDILaunchDelegate.runLocalApplication(LocalCDILaunchDelegate.java:83)
at org.eclipse.cdt.launch.internal.LocalCDILaunchDelegate.launch(LocalCDILaunchDelegate.java:62)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(org.eclipse.debug.core_3.2.1.v20060823.jar.so)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(org.eclipse.debug.core_3.2.1.v20060823.jar.so)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(org.eclipse.debug.ui_3.2.2.r322_v20070202.jar.so)
at org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(org.eclipse.debug.ui_3.2.2.r322_v20070202.jar.so)
at org.eclipse.core.internal.jobs.Worker.run(org.eclipse.core.jobs_3.2.0.v20060603.jar.so)

这个问题如何解决,先谢了:)
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2007-06-09 15:30

没有安装完全吧?你是怎么装的?
关注我的blog: ε==3
winzzy
帖子: 29
注册时间: 2006-04-22 5:05
送出感谢: 0
接收感谢: 0

#3

帖子 winzzy » 2007-06-09 16:06

Fedora FC7 yum安装的
CDT是去http://www.eclipse.org/cdt/downloads.php 下载的
安装方式
在usr/share/eclipse文件夹中新建CDT文件夹,把下载的文件解压到里边,解压完的文件夹叫eclipse
在links文件夹中建立连接cdt.link,内容如下
path=/usr/share/eclipse/CDT
从起eclipse:)

我感觉是安装成功了--!,但一运行就,出错误提示--!
不是启动的时候出错,是编辑完代码,点run的时候--!
-------------
添加一个自己常用的使用技巧吧audacious如果显示歌曲名称乱码,可以通过如下办法解决
首选项->播放列表->使用自动编码检测器->chinese解决:)
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#4

帖子 bones7456 » 2007-06-09 16:24

原来是用yum装的啊?呵呵!!

可能你的CDT版本和eclipse版本不兼容吧,建议不要用下载后解压的方式安装.
eclipse节目上有个菜单叫"软件升级"什么的,在里面输入个CDT的URL就会自己找到相应版本,并进行下载安装的,具体我现在每法试验,你自己找一下.
关注我的blog: ε==3
winzzy
帖子: 29
注册时间: 2006-04-22 5:05
送出感谢: 0
接收感谢: 0

#5

帖子 winzzy » 2007-06-09 21:54

我曾经试着完全用yum的方式完全安装,包括cdt--!,但和这次的情况一样,也是弹出这个错误。我想我可能会再去尝试一次的,哈。谢了,呵呵
------------
我linux技巧,在xfce中,我没找到系统监视器(gnome-system-monitor),曾经郁闷了下,也许对于一些人不重要,哈,但我习惯用。后来找到解决办法,用gnome的 点alt+f2 输入命令 gnome-system-monitor
winzzy
帖子: 29
注册时间: 2006-04-22 5:05
送出感谢: 0
接收感谢: 0

#6

帖子 winzzy » 2007-06-11 12:41

不成,哈。看来还得给一个可行的解决办法:)
-----------
技巧 用amule可能开始没有服务器,这时候可以回windows去开emule,复制几个服务器回来就可以了:),速度基本诧异不大:)
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#7

帖子 bones7456 » 2007-06-11 12:50

我的eclipse是版本:3.2.0 的,
CDT安装方法:帮助-软件更新-查找并安装,选择“搜索要安装的新部件”,下一步后,点个新建站点,随便输个名字,URL输入:http://download.eclipse.org/tools/cdt/releases/callisto,选中刚添加的站点,点击完成。后面按提示做就好了。
还有,可能要在/etc/eclipse/java_home这个文件里面指定一个比较新的jvm版本。

再不行估计就是yum版本的eclipse有问题了。呵呵
关注我的blog: ε==3
winzzy
帖子: 29
注册时间: 2006-04-22 5:05
送出感谢: 0
接收感谢: 0

#8

帖子 winzzy » 2007-06-11 16:15

--------
不是源的问题哈,不然早有人反应了,哈,我的配置有问题
编写和调试java的程序一点问题没有,算了,就那这个弄java吧:)
----------
技巧
用tvtime的时候可能能看到的频道相对于windows下,少了许多,这时候
可以尝试下修改tuner
比如我就用 modprobe saa7134 card=3 tuner=27
和windows下一样,哈
有时候关闭tvtime你还会发现有声音,可以尝试如下命令
rmmod saa7134
:)
回复

回到 “软件/网站开发”