依赖问题build-essential和gcc-4.0

软件和网站开发以及相关技术探讨
回复
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

依赖问题build-essential和gcc-4.0

#1

帖子 glade » 2005-11-13 23:09

安装build-essential很烦人,老是连带gcc-4.0
把所有它依赖的包都装了以后
apt-get install build-essential
提示:
build-essential: 依赖: gcc (>= 4:4.0) 但是它将不会被安装
依赖: g++ (>= 4:4.0) 但是它将不会被安装
已经装了gcc-3.4,g++-3.4 不想装gcc-4.0
我到debian网站去看了一下,它似乎不依赖gcc-4.0
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#2

帖子 glade » 2005-11-13 23:24

用下载的包强制安装以后

每次apt-get安装软件,末尾有一段:

您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
build-essential: 依赖: gcc (>= 3:3.3) 但是它将不会被安装
依赖: g++ (>= 3:3.3) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

用apt-get -f install则要我安装
g++ g++-4.0 gcc gcc-4.0 libstdc++6-4.0-dev

可是我apt-get install gcc-3.4已经是最新版本了
回复

回到 “软件/网站开发”