当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装ati7.12驱动成功后无法开启compiz(解决)
帖子发表于 : 2008-01-23 19:37 

注册: 2008-01-07 14:14
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
下面是测试的结果
x:~$ sudo aticonfig --initial
[sudo] password for x:
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0
x:~$ sudo aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0
x:~$

x:~$ glxinfo |grep -e 'direct' -e 'OpenGL'
direct rendering: Yes
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X300/X550/X1050 Series
OpenGL version string: 2.1.7170 Release
OpenGL extensions:
x:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X300/X550/X1050 Series
OpenGL version string: 2.1.7170 Release

x:~$ glxgears
x:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
1811 frames in 5.0 seconds = 362.200 FPS
x:~$


glxgears返回一个平面的齿轮图
fgl_glxgears返回一个桌面立方体,中间为三个齿轮在转动

输入compiz --replace后的结果
x:~$ compiz --replace
.: 3: Can't open /etc/xdg/compiz/compiz-manager.ubuntu
x:~$

请问要怎么解决?


附件:
nn.jpg
nn.jpg [ 158.64 KiB | 被浏览 679 次 ]



最后由 独孤一梦 编辑于 2008-01-25 16:09,总共编辑了 1 次
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-24 13:33 
头像

注册: 2007-10-18 13:50
帖子: 264
系统: Ubuntu 14.10
送出感谢: 0 次
接收感谢: 0 次
十一. 先开启系统自带的compiz-fusion。先把compiz装全了,命令如下:
代码:
sudo apt-get install compiz compiz-bcop compizconfig-settings-manager compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig0 libcompizconfig-backend-gconf libdecoration0 python-compizconfig emerald -y

对于Kubuntu用户输入以下命令:
代码:
sudo apt-get install compiz compiz-bcop compizconfig-settings-manager compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-kde compiz-plugins libcompizconfig0 libcompizconfig-backend-kconfig libdecoration0 python-compizconfig emerald -y

十二. 装完之后,还有重要的一步,因为Ubuntu7.10发布的时候ATI的显卡驱动还不支持AIGLX,所以要借助XGL才能开启compiz,但是现在装的最新的驱动已经提供了AIGLX的支持,不再需要XGL了。所以必须经过以下操作才能屏蔽掉XGL的检测。
1。
代码:
sudo gedit /etc/X11/xorg.conf

查看一下文件中是否有这一段存在
引用:
# Section "Extensions"
# Option "Composite" "0"
# EndSection

有的话就删掉,没有就不要动了。
2。然后再让compiz识别fglrx。命令:
代码:
mkdir -p ~/.config/compiz && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager

3。然后修改compiz初始文件
代码:
sudo gedit /usr/bin/compiz

找到下面的语句,将fglrx加入
引用:
# Driver whitelist
WHITELIST="fglrx nvidia intel ati radeon i810"

4。再找到下面的语句,
引用:
# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
T=" 1002:5954 1002:5854 1002:5955" # ati rs480
T="$T 1002:4153" # ATI Rv350
T="$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12" # intel 965
T="$T 8086:2972" # i965 (x3000)
T="$T 1002:3152 1002:3150 1002:5462 1002:5653 " # ati X300 X600,X600 X700
BLACKLIST_PCIIDS="$T"

将上面的语句段改为:
引用:
# blacklist based on the pci ids
# BLACKLIST_PCIIDS="$T"
BLACKLIST_PCIIDS=""

5。再找到第30-35行,修改为以下内容:
引用:
COMPIZ_BIN_PATH="/usr/bin/" # For window decorators and compiz
PLUGIN_PATH="/usr/lib/compiz/"
GLXINFO="/usr/bin/glxinfo"
KWIN="/usr/bin/kwin"
METACITY="/usr/bin/metacity"
COMPIZ_NAME="compiz.real" # Final name for compiz (compiz.real)

6。重启一下 X-window,看一下compiz能否启动。按ALT+F2输入"compiz --replace",回车。看到了吧。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-25 0:07 

注册: 2008-01-07 14:14
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
严格按照2楼的方法来做的结果还是一样
其实我装驱动就是按2楼的提供的方法来装的
compiz --replace
.: 3: Can't open /etc/xdg/compiz/compiz-manager.ubuntu


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-25 0:33 
头像

注册: 2007-10-18 13:50
帖子: 264
系统: Ubuntu 14.10
送出感谢: 0 次
接收感谢: 0 次
独孤一梦 写道:
严格按照2楼的方法来做的结果还是一样
其实我装驱动就是按2楼的提供的方法来装的
compiz --replace
.: 3: Can't open /etc/xdg/compiz/compiz-manager.ubuntu

我是没办法了,我在三种显卡上试过,9550,X800GTO,X1600Pro都没有任何问题
也没有听他人说过跟你一样的问题,理论上说,显卡驱动装好,compiz装全设置好
就没有问题了。你的安装过程我也不了解,不知道你到底配置的对不对,帮不到你。
实在抱歉。对了,你的显卡型号是什么,具体说一下。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-25 16:08 

注册: 2008-01-07 14:14
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
zhizunbao 写道:
独孤一梦 写道:
严格按照2楼的方法来做的结果还是一样
其实我装驱动就是按2楼的提供的方法来装的
compiz --replace
.: 3: Can't open /etc/xdg/compiz/compiz-manager.ubuntu

我是没办法了,我在三种显卡上试过,9550,X800GTO,X1600Pro都没有任何问题
也没有听他人说过跟你一样的问题,理论上说,显卡驱动装好,compiz装全设置好
就没有问题了。你的安装过程我也不了解,不知道你到底配置的对不对,帮不到你。
实在抱歉。对了,你的显卡型号是什么,具体说一下。

谢谢了,我按其它方法加源装0.6.9版本的就可以了
装的软件全部都是你贴子里要求装的,但我是用加源用adept装的
我发现你的kubuntu的那个sudo确实有问题,sudo apt-get install compiz compiz-bcop compizconfig-settings-manager compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-kde compiz-plugins libcompizconfig0 libcompizconfig-backend-kconfig libdecoration0 python-compizconfig emerald -y
我仔细看了下,用那个命令后会装上compiz-gnome和compiz-kde这两个都装上了,而且在adept里没法把compiz-gnome给卸载掉,卸载他也会自动卸载掉compiz,你自己也可以在kubuntu上不加y试试,他会显示把compiz-gnome给装上的,所以kde还是不要用上面那个命令的好
我加源后把你要求装的那16个包一个个通过adept装上,其间选择compiz时要求装compiz-gnome,但这时可以把他取消不装,手动选compiz-kde,这样子就搞定了。我以前下载你提供的网址里面的包也没装成功,哈哈,步骤我严格按要求装的,一步不错,一步不漏
重装了几十次系统后,终于可以搞定而且知道问题在哪了

谢谢你多次解答!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-25 23:56 
头像

注册: 2007-10-18 13:50
帖子: 264
系统: Ubuntu 14.10
送出感谢: 0 次
接收感谢: 0 次
呵呵,弄好就行了。你也真有毅力,装了那么多次系统。呵呵!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-26 16:39 

注册: 2008-01-07 14:14
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
zhizunbao 写道:
呵呵,弄好就行了。你也真有毅力,装了那么多次系统。呵呵!

呵呵,每一次新装系统就先按你贴子装3D。不成功就重装,机子现在都出问题了,有点后悔了 :lol:
现在搞定后发现7.10的装了驱动后比8.04没装驱动效果还要差,郁闷
开了3D就看不了电影了,没图像了,用8.04还可以开3D看电影,呵呵,有点有失


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译