最心compiz0.6.99安装问题,一起来研究解决分享下,谢谢

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
chenpinyou
帖子: 53
注册时间: 2008-02-23 10:37
送出感谢: 0
接收感谢: 0

最心compiz0.6.99安装问题,一起来研究解决分享下,谢谢

#1

帖子 chenpinyou » 2008-02-29 18:59

我是根据http://forum.ubuntu.org.cn/viewtopic.php?t=102298
这篇文章安装compiz,出现了下面问题,谁能帮个忙,谢谢


dpkg:依赖关系问题使得 compiz 的配置工作不能继续:
compiz 依赖于 compiz-plugins;然而:
未曾安装软件包“compiz-plugins”。
dpkg:处理 compiz (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 compiz-bcop (0.6.99+git20071021+Qubuntu0) ...
dpkg:依赖关系问题使得 compizconfig-settings-manager 的配置工作不能继续:
compizconfig-settings-manager 依赖于 compiz-plugins;然而:
未曾安装软件包“compiz-plugins”。
dpkg:处理 compizconfig-settings-manager (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 compiz-core (1:0.7.1+git20080219+Qubuntu0) ...
dpkg:依赖关系问题使得 compiz-dev 的配置工作不能继续:
compiz-dev 依赖于 libgl1-mesa-dev | libgl-dev;然而:
未曾安装软件包“libgl1-mesa-dev”。
未曾安装软件包“libgl-dev”。
compiz-dev 依赖于 libxcomposite-dev;然而:
未曾安装软件包“libxcomposite-dev”。
compiz-dev 依赖于 libxdamage-dev;然而:
未曾安装软件包“libxdamage-dev”。
compiz-dev 依赖于 libxfixes-dev;然而:
未曾安装软件包“libxfixes-dev”。
compiz-dev 依赖于 libxcursor-dev;然而:
未曾安装软件包“libxcursor-dev”。
compiz-dev 依赖于 libxinerama-dev;然而:
未曾安装软件包“libxinerama-dev”。
compiz-dev 依赖于 libxrandr-dev;然而:
未曾安装软件包“libxrandr-dev”。
compiz-dev 依赖于 libice-dev;然而:
未曾安装软件包“libice-dev”。
compiz-dev 依赖于 libsm-dev;然而:
未曾安装软件包“libsm-dev”。
compiz-dev 依赖于 libstartup-notification0-dev;然而:
未曾安装软件包“libstartup-notification0-dev”。
dpkg:处理 compiz-dev (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 compiz-fusion-plugins-main 的配置工作不能继续:
compiz-fusion-plugins-main 依赖于 compiz-plugins;然而:
未曾安装软件包“compiz-plugins”。
dpkg:处理 compiz-fusion-plugins-main (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 compiz-fusion-plugins-unsupported 的配置工作不能继续:
compiz-fusion-plugins-unsupported 依赖于 compiz-fusion-plugins-main;然而:
软件包 compiz-fusion-plugins-main 还没有被配置。
dpkg:处理 compiz-fusion-plugins-unsupported (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 libcompizconfig0 (0.6.99+git20080215+Qubuntu0) ...

dpkg:依赖关系问题使得 libcompizconfig0-dev 的配置工作不能继续:
libcompizconfig0-dev 依赖于 compiz-dev;然而:
软件包 compiz-dev 还没有被配置。
dpkg:处理 libcompizconfig0-dev (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 libcompizconfig-backend-gconf (0.6.99+git20080210+Qubuntu0) ...
正在设置 libdecoration0 (1:0.7.1+git20080219+Qubuntu0) ...

正在设置 libdecoration0-dev (1:0.7.1+git20080219+Qubuntu0) ...
正在设置 python-compizconfig (0.6.99+git20080214+Qubuntu0) ...

dpkg:依赖关系问题使得 compiz-fusion-plugins-extra 的配置工作不能继续:
compiz-fusion-plugins-extra 依赖于 compiz-fusion-plugins-main;然而:
软件包 compiz-fusion-plugins-main 还没有被配置。
dpkg:处理 compiz-fusion-plugins-extra (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 compiz-gnome (1:0.7.1+git20080219+Qubuntu0) ...

正在设置 libemeraldengine0 (0.5.2+git20080131+Qubuntu0) ...

正在设置 libemeraldengine-dev (0.5.2+git20080131+Qubuntu0) ...
正在设置 emerald (0.5.2+git20080131+Qubuntu0) ...

正在设置 emerald-themes (0.6.99+git20071015+Qubuntu0) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
在处理时有错误发生:
compiz-plugins_0.7.1+git20080219+Qubuntu0_i386.deb
compiz
compizconfig-settings-manager
compiz-dev
compiz-fusion-plugins-main
compiz-fusion-plugins-unsupported
libcompizconfig0-dev
compiz-fusion-plugins-extra
johnapple@johnapple-desktop:~/compiz$
头像
异域追梦者
帖子: 424
注册时间: 2008-02-18 0:25
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 异域追梦者 » 2008-02-29 19:31

把依赖的先安了吧 活说每次看这种帖头都大
图片
chenpinyou
帖子: 53
注册时间: 2008-02-23 10:37
送出感谢: 0
接收感谢: 0

#3

帖子 chenpinyou » 2008-02-29 19:43

我已经下全了那些COMPIZ的了阿,怎么还要有其他依赖?
其他依赖我到哪里去找?
头像
hecha
帖子: 364
注册时间: 2007-09-23 13:36
送出感谢: 0
接收感谢: 2 次

#4

帖子 hecha » 2008-02-29 20:28

那些软件包要按顺序一个个装,它说要什么你就先装什么。
头像
zhizunbao
帖子: 264
注册时间: 2007-10-18 13:50
系统: Ubuntu 14.10
送出感谢: 0
接收感谢: 0

Re: 最心compiz0.6.99安装问题,一起来研究解决分享下,谢谢

#5

帖子 zhizunbao » 2008-03-01 0:52

chenpinyou 写了:我是根据http://forum.ubuntu.org.cn/viewtopic.php?t=102298
这篇文章安装compiz,出现了下面问题,谁能帮个忙,谢谢


dpkg:依赖关系问题使得 compiz 的配置工作不能继续:
compiz 依赖于 compiz-plugins;然而:
未曾安装软件包“compiz-plugins”。
dpkg:处理 compiz (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 compiz-bcop (0.6.99+git20071021+Qubuntu0) ...
dpkg:依赖关系问题使得 compizconfig-settings-manager 的配置工作不能继续:
compizconfig-settings-manager 依赖于 compiz-plugins;然而:
未曾安装软件包“compiz-plugins”。
dpkg:处理 compizconfig-settings-manager (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 compiz-core (1:0.7.1+git20080219+Qubuntu0) ...
dpkg:依赖关系问题使得 compiz-dev 的配置工作不能继续:
compiz-dev 依赖于 libgl1-mesa-dev | libgl-dev;然而:
未曾安装软件包“libgl1-mesa-dev”。
未曾安装软件包“libgl-dev”。
compiz-dev 依赖于 libxcomposite-dev;然而:
未曾安装软件包“libxcomposite-dev”。
compiz-dev 依赖于 libxdamage-dev;然而:
未曾安装软件包“libxdamage-dev”。
compiz-dev 依赖于 libxfixes-dev;然而:
未曾安装软件包“libxfixes-dev”。
compiz-dev 依赖于 libxcursor-dev;然而:
未曾安装软件包“libxcursor-dev”。
compiz-dev 依赖于 libxinerama-dev;然而:
未曾安装软件包“libxinerama-dev”。
compiz-dev 依赖于 libxrandr-dev;然而:
未曾安装软件包“libxrandr-dev”。
compiz-dev 依赖于 libice-dev;然而:
未曾安装软件包“libice-dev”。
compiz-dev 依赖于 libsm-dev;然而:
未曾安装软件包“libsm-dev”。
compiz-dev 依赖于 libstartup-notification0-dev;然而:
未曾安装软件包“libstartup-notification0-dev”。
dpkg:处理 compiz-dev (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 compiz-fusion-plugins-main 的配置工作不能继续:
compiz-fusion-plugins-main 依赖于 compiz-plugins;然而:
未曾安装软件包“compiz-plugins”。
dpkg:处理 compiz-fusion-plugins-main (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 compiz-fusion-plugins-unsupported 的配置工作不能继续:
compiz-fusion-plugins-unsupported 依赖于 compiz-fusion-plugins-main;然而:
软件包 compiz-fusion-plugins-main 还没有被配置。
dpkg:处理 compiz-fusion-plugins-unsupported (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 libcompizconfig0 (0.6.99+git20080215+Qubuntu0) ...

dpkg:依赖关系问题使得 libcompizconfig0-dev 的配置工作不能继续:
libcompizconfig0-dev 依赖于 compiz-dev;然而:
软件包 compiz-dev 还没有被配置。
dpkg:处理 libcompizconfig0-dev (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 libcompizconfig-backend-gconf (0.6.99+git20080210+Qubuntu0) ...
正在设置 libdecoration0 (1:0.7.1+git20080219+Qubuntu0) ...

正在设置 libdecoration0-dev (1:0.7.1+git20080219+Qubuntu0) ...
正在设置 python-compizconfig (0.6.99+git20080214+Qubuntu0) ...

dpkg:依赖关系问题使得 compiz-fusion-plugins-extra 的配置工作不能继续:
compiz-fusion-plugins-extra 依赖于 compiz-fusion-plugins-main;然而:
软件包 compiz-fusion-plugins-main 还没有被配置。
dpkg:处理 compiz-fusion-plugins-extra (--install)时出错:
依赖关系问题 - 仍未被配置
正在设置 compiz-gnome (1:0.7.1+git20080219+Qubuntu0) ...

正在设置 libemeraldengine0 (0.5.2+git20080131+Qubuntu0) ...

正在设置 libemeraldengine-dev (0.5.2+git20080131+Qubuntu0) ...
正在设置 emerald (0.5.2+git20080131+Qubuntu0) ...

正在设置 emerald-themes (0.6.99+git20071015+Qubuntu0) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
在处理时有错误发生:
compiz-plugins_0.7.1+git20080219+Qubuntu0_i386.deb
compiz
compizconfig-settings-manager
compiz-dev
compiz-fusion-plugins-main
compiz-fusion-plugins-unsupported
libcompizconfig0-dev
compiz-fusion-plugins-extra
johnapple@johnapple-desktop:~/compiz$
我早说过,所有dev包用不着安装,这样就不会有依赖问题,怎么不听劝告呢。
chenpinyou
帖子: 53
注册时间: 2008-02-23 10:37
送出感谢: 0
接收感谢: 0

#6

帖子 chenpinyou » 2008-03-01 22:47

谢谢!我已经安装好COMPIZ了,我是通过下面这篇文章安好的,一起分享下,但是我安X550XT显卡驱动程序8.02,又出了问题

gutsy下安装最新的 compiz 0.6.99(源)

huangbt 发表于: 2008-2-01 08:12 来源: 远景无限博客
请大家爱惜一点、经济一点使用该源,否则难保哪天又出现带宽超额。
这个是我无意中搜到的,但发现源有问题,与Quattro沟通后终于今日更新,不敢独享。
添加源到/etc/apt/sources.list:

CODE:
# Quattro's Ubuntu Gutsy EyeCandy Repository (GPG key: 641AC84F)
deb http://kwatrow.nl/repo Gutsy compiz-fusion-git然后

CODE:
wget http://kwatrow.nl/repo/Quattro.gpg -O- | sudo apt-key add -安装:把原有的compiz统统用新立得彻底删除干净
或者命令行

CODE:
sudo apt-get autoremove --purge compiz compiz-* emerald*然后

CODE:
sudo apt-get install compiz compizconfig-settings-manager compiz-core compiz-fusion-plugins-extra compiz-fusion-plugins-unsupported emerald emerald-themes至此更新完毕。
进一步设置:如果想让emerald作为第一装饰器,那么需要修改/usr/bin/compiz。

CODE:
sudo nano /usr/bin/compiz找到

CODE:
# Defines the decorator and arguments.
# Set it to empty to make the script use the best decorator for your environment
DECORATOR=""
DECORATORARGS=""改为

CODE:
# Defines the decorator and arguments.
# Set it to empty to make the script use the best decorator for your environment
DECORATOR="emerald"
DECORATORARGS="--replace"保存退出即可。重新登录一次看看是不是ok了。
转自

CODE:
viewtopic.php?t=94178
回复

回到 “桌面特效”