当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]compiz f 0.7.2 真是不好编译啊
帖子发表于 : 2008-03-08 11:23 

注册: 2007-09-06 16:07
帖子: 466
送出感谢: 0 次
接收感谢: 0 次
在解包compiz-0.7.2后
执行./configure --prefix=/usr/local后
最后显示
checking for COMPIZ... configure: error: Package requirements (x11-xcb xcomposite xfixes xdamage xrandr xinerama ice sm libxml-2.0 libxslt libstartup-notification-1.0 >= 0.7) were not met:

No package 'x11-xcb' found

上网查了一下,下载了libX11-X11R7.2-....的包
结果这个包也configure不了
checking for X11... configure: error: Package requirements (xextproto xtrans xcb-xlib >= 0.9.92) were not met:

No package 'xcb-xlib' found

然后又搞了xtrans、libXext、libXfixes都装好了,但是libX11-X11R7.2还是出上面的错

暂时还是解决不了

难道非要打no-x11-xcb的补丁不成?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-08 11:56 
头像

注册: 2006-05-24 21:38
帖子: 685
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
哈哈,我也玩了,也这个包,后来放弃了。


_________________
我只是一个ARCH的FANS,来自RH和UBUNTU的滋润!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-08 12:43 

注册: 2007-05-13 15:20
帖子: 333
送出感谢: 0 次
接收感谢: 0 次
以前找到的patch,在0.7那里可用,现在没时间试,自己试试啦, 看看0.72下可不可用


附件:
100_disable-libx11-xcb-support.patch.gz [672 Bytes]
被下载 66 次
页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-15 16:11 
头像

注册: 2006-05-24 21:38
帖子: 685
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
LS的如何打patch啊


_________________
我只是一个ARCH的FANS,来自RH和UBUNTU的滋润!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-04 22:59 

注册: 2008-04-04 0:46
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我也是的啊,怎么弄都不行~


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-13 10:43 

注册: 2008-04-13 10:37
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
到新立德软软件包管理器里安装XCB-DEV 和libXCB-dev的软件包。但我编译安装完后发现compiz提示段错误。不知如何解决。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译