[问题]新手救助,装awn时出的问题

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
paipai18
帖子: 5
注册时间: 2008-03-18 16:02
送出感谢: 0
接收感谢: 0

[问题]新手救助,装awn时出的问题

#1

帖子 paipai18 » 2008-03-18 16:18

我按照网上的一篇文章来安装AWN

[具体步骤如下]

添加下面的源
deb http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator
deb-src http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator

在终端里依次执行下面的指令
wget http://download.tuxfamily.org/syzygy42/reacocard.asc
sudo apt-key add reacocard.asc
rm reacocard.asc
sudo apt-get update
sudo apt-get install avant-window-navigator-bzr awn-core-applets-bzr
sudo apt-get install bzr
bzr co http://bazaar.launchpad.net/~awn-curves ... awn-curves awn-curves
cd awn-curves
./autogen.sh && make
sudo make install

[问题]
在执行到./autogen.sh && make时出问题了
终端里提示:
You need to install the gnome-common module and make
sure the gnome-autogen.sh script is in your $PATH.

我尝试让$PATH包括awn-curves目录
还尝试把autogen.sh 文件复制到/usr/sbin/里

都不行。

请高手们支招
在线等

[附]
这些步骤来自这篇文章:http://www.mobile01.com/newsdetail.php?id=4006
头像
daf3707
论坛版主
帖子: 12668
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#2

帖子 daf3707 » 2008-03-18 16:36

直接用新立得搜avant-window-navigator安装不就得了吗?
头像
异域追梦者
帖子: 424
注册时间: 2008-02-18 0:25
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 异域追梦者 » 2008-03-18 19:47

试试安装gnome-common
图片
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

#4

帖子 HuntXu » 2008-03-19 0:37

没装依赖吧~
awn的readme和INSTALL写的挺好,自己不多看看...
头像
paipai18
帖子: 5
注册时间: 2008-03-18 16:02
送出感谢: 0
接收感谢: 0

#5

帖子 paipai18 » 2008-03-20 13:16

[quote="异域追梦者"]试试安装gnome-common[/quote]

装完gonme-common后
我再执行 ./autogen.sh && make 终端反馈的如下:

/usr/bin/gnome-autogen.sh
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.61
checking for automake >= 1.9...
testing automake-1.10... not found.
testing automake-1.9... found 1.9.6
checking for libtool >= 1.5...
testing libtoolize... found 1.5.24
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build avant-panel-menu. Download the appropriate package for
from your distribution or get the source tarball at
ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz

checking for intltool >= 0.30...
testing intltoolize... found 0.36.2
checking for pkg-config >= 0.14.0...
testing pkg-config... found 0.22
Checking for required M4 macros...
glib-gettext.m4 not found
***Error***: some autoconf macros required to build avant-panel-menu
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?


我没仔细研究过里面的E文文件
这样装程序好郁闷啊

我换换别的办法装 装 试试
头像
paipai18
帖子: 5
注册时间: 2008-03-18 16:02
送出感谢: 0
接收感谢: 0

#6

帖子 paipai18 » 2008-03-20 13:17

HuntXu 写了:没装依赖吧~
awn的readme和INSTALL写的挺好,自己不多看看...
一堆E文,我现在又没什么时间看……汗
头像
lafuers
帖子: 107
注册时间: 2008-03-23 17:49
送出感谢: 0
接收感谢: 0

#7

帖子 lafuers » 2008-03-23 17:51

搜索解决这个问题时看到这个:
https://answers.launchpad.net/ubuntu/+question/10347
里面说要执行:
sudo apt-get install build-essential
头像
paipai18
帖子: 5
注册时间: 2008-03-18 16:02
送出感谢: 0
接收感谢: 0

#8

帖子 paipai18 » 2008-03-24 16:40

[quote="lafuers"]搜索解决这个问题时看到这个:
https://answers.launchpad.net/ubuntu/+question/10347
里面说要执行:
sudo apt-get install build-essential[/quote]


谢谢,正在看。。。
头像
wc_111191
帖子: 471
注册时间: 2008-02-02 23:05
来自: 天津
送出感谢: 0
接收感谢: 0

#9

帖子 wc_111191 » 2008-03-24 19:24

为什么不用:
sudo apt-get install avant-window-navigator
多方便啊
回复

回到 “桌面特效”