当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求一份 linux+ati9550+compiz-fusion 教程一份!!!
帖子发表于 : 2008-03-26 0:52 

注册: 2008-03-23 23:28
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
小弟 已经在redhat 5 fedora 9 和现在的ubuntu 7.10 上都试过了 查了很多资料 很无奈 我的ati 9550 驱动就是装不上 我在ubuntu 7.10 最后一次装 就是刚刚 用的驱动是官方的:ati-driver-installer-8-3-x86.x86_64.run! 安装完后 发现 ati 的控制台里的3D选项的 前两个 是不可选的了! 是说官方驱动不支持开启3D了??哎!所以在此 求助一份教程 完整的教程 系统是什么都可以 fedora ubuntu redhat 企业 问题是 ati 的显卡驱动 和驱动3D加速问题!看别人试这compiz-fusion 的特效 很是羡慕! 我也问了很多人 他们说ati 9550 能跑3D桌面!希望成功的人 分享一下经验 !在此现谢谢大家!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-26 7:23 
头像

注册: 2007-10-18 13:50
帖子: 264
系统: Ubuntu 14.10
送出感谢: 0 次
接收感谢: 0 次
9550当然可以,我曾经帮同学装过。虽然我的X800GTO比你的显卡强点儿,但是安装过程一样。你找一下我发过的帖子,要编译安装deb包就可以了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-26 20:58 

注册: 2008-03-23 23:28
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我看了你的教程 正在参照你的 [原创]ATI-8.01驱动开compiz确保成功 2008-01-23号的 你用的是8.01官方驱动 我手里有8.02 和8.3 !问下 8.3能安你的方法安装成功嘛??


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-26 21:58 

注册: 2008-03-23 23:28
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我根据你的帖子 到了sudo dpkg -i xorg-driver-fglrx_8.452.1-1*.deb fglrx-kernel-source_8.452.1-1*.deb fglrx-amdcccle_8.452.1-1*.deb 这一步的时候 我生成的是:
fglrx-amdcccle_8.455.2-0ubuntu1_i386.deb
fglrx-installer_8.455.2-0ubuntu1_i386.changes
fglrx-kernel-source_8.455.2-0ubuntu1_i386.deb
xorg-driver-fglrx_8.455.2-0ubuntu1_i386.deb
xorg-driver-fglrx-dev_8.455.2-0ubuntu1_i386.deb

以上5个文件 我看的写的根据我生成的 更改为:sudo dpkg -i xorg-driver-fglrx_8.455.2-0*.deb fglrx-kernel-source_8.455.2-0*.deb fglrx-amdcccle_8.455.2-0*.deb
出现一下问题:
(正在读取数据库 ... 系统当前总共安装有 94768 个文件和目录。)
正预备替换 xorg-driver-fglrx 8.455.2-0ubuntu1 (使用 xorg-driver-fglrx_8.455.2-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 xorg-driver-fglrx ...
正预备替换 fglrx-kernel-source 8.455.2-0ubuntu1 (使用 fglrx-kernel-source_8.455.2-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 fglrx-kernel-source ...
正预备替换 fglrx-amdcccle 8.455.2-0ubuntu1 (使用 fglrx-amdcccle_8.455.2-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 fglrx-amdcccle ...
dpkg:依赖关系问题使得 xorg-driver-fglrx 的配置工作不能继续:
xorg-driver-fglrx 依赖于 libstdc++5;然而:
未曾安装软件包“libstdc++5”。
dpkg:处理 xorg-driver-fglrx (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-kernel-source 的配置工作不能继续:
fglrx-kernel-source 依赖于 dkms;然而:
未曾安装软件包“dkms”。
dpkg:处理 fglrx-kernel-source (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-amdcccle 的配置工作不能继续:
fglrx-amdcccle 依赖于 xorg-driver-fglrx;然而:
软件包 xorg-driver-fglrx 还没有被配置。
dpkg:处理 fglrx-amdcccle (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
xorg-driver-fglrx
fglrx-kernel-source
fglrx-amdcccle

我感觉是 第一部没弄好 我就
sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms –y
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
build-essential 已经是最新的版本了。
fakeroot 已经是最新的版本了。
debhelper 已经是最新的版本了。
debconf 已经是最新的版本了。
现在没有可用的软件包 dkms,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 dkms 还没有可供安装的候选者

后来我又把命令更改了一下:sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
build-essential 已经是最新的版本了。
fakeroot 已经是最新的版本了。
debhelper 已经是最新的版本了。
debconf 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
fglrx-kernel-source: 依赖: dkms 但却无法安装它
libstdc++5: 依赖: gcc-3.3-base (>= 1:3.3.6-15ubuntu2) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

清帮忙告知应该怎么解决??加个源??我源盘 一直在光驱里的!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-26 22:06 
头像

注册: 2007-10-21 18:36
帖子: 3235
地址: 汕头/广东/中国
送出感谢: 2
接收感谢: 3
玩3D桌面的话奉劝你不要自己安装那些最新的驱动。用新立得就可以轻松解决的。
把原来的驱动删除,装xserver-xgl。compiz-config-setting-manager。加上受限驱动里面的打勾。


_________________
老子的哲学是“”,庄子的哲学是“
人有一技在身,则逍遥游而无不为


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-26 22:22 

注册: 2008-03-23 23:28
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我加了受限驱动 打上勾后 就黑屏进不料系统了!很无奈!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-26 22:29 

注册: 2008-03-23 23:28
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
刚刚 输入sudo apt-get install -f 后出现:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
gcc-3.3-base libstdc++5
下列软件包将被【卸载】:
fglrx-kernel-source
下列【新】软件包将被安装:
gcc-3.3-base libstdc++5
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
有 3 个软件包没有被完全安装或卸载。
需要下载 0B/447kB 的软件包。
解压缩后将会空出 2765kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 94767 个文件和目录。)
正在删除 fglrx-kernel-source ...
选中了曾被取消选择的软件包 gcc-3.3-base。
(正在读取数据库 ... 系统当前总共安装有 94749 个文件和目录。)
正在解压缩 gcc-3.3-base (从 .../gcc-3.3-base_3.3.6-15ubuntu2_i386.deb) ...
选中了曾被取消选择的软件包 libstdc++5。
正在解压缩 libstdc++5 (从 .../libstdc++5_3.3.6-15ubuntu2_i386.deb) ...
正在设置 gcc-3.3-base (1:3.3.6-15ubuntu2) ...
正在设置 libstdc++5 (1:3.3.6-15ubuntu2) ...

正在设置 xorg-driver-fglrx (8.455.2-0ubuntu1) ...

配置文件“/etc/xdg/compiz/compiz-manager”
==> 在安装后曾被删除(您或者某个脚本删除了它)。
==> 软件包的提交者同时提供了一个更新了的版本。
您现在希望如何处理呢? 您有以下几个选择:
Y 或 I :安装软件包维护者所提供的版本
N 或 O :保留您原来安装的版本
D :显示两者的区别
Z :把当前进程切换到后台,然后查看现在的具体情况
缺省的处理方法是保留您当前使用的版本。
*** compiz-manager (Y/I/N/O/D/Z) [缺省选项=N] ? N
* Starting atieventsd [ OK ]

正在设置 fglrx-amdcccle (8.455.2-0ubuntu1) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place


可是: sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms –y
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
build-essential 已经是最新的版本了。
fakeroot 已经是最新的版本了。
debhelper 已经是最新的版本了。
debconf 已经是最新的版本了。
libstdc++5 已经是最新的版本了。
libstdc++5 设定为手动安装.
E: 无法找到软件包 dkms


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-27 2:01 

注册: 2008-03-23 23:28
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
谢谢 zhizunbao 的教程!!显卡 已经安好了 可 3D桌面还是不行 我安你帖子的后半部分操作 在sudo apt-get install compiz compiz-bcop compizconfig-settings-manager compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig0 libcompizconfig-backend-gconf libdecoration0 python-compizconfig emerald -y

这步的时候 出现好多依赖问题 和找不到包的问题 我删删减减 把能装的装上了 可你后面说的要修改的地方我一个都没有 然后我就重启了 我再进桌面就显示出现上下两个白条 然后消失了 就卡死了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译