当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]求人不如求已,我的ATI x1600+22寸宽屏启动3D桌面的经历
帖子发表于 : 2008-04-16 10:23 

注册: 2008-04-11 23:14
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
前些日子我又买了一块硬盘,过去的40G老硬盘挂成了从盘。想把它利用起来。
早几个月前我从ubuntu申请了两张光盘,是64位和32位的各一张,不过版本是7.04的,那会儿也安装过,只是进去后跟本不像我想象的那样,再加上配完显卡后黑屏,就再没用过。
现在又想 重拾ubuntu,就为了那个3D的桌面。

启动计算机,上www.ubuntu.org.cn ,下载了32位的7.10版(听说64位环境下软件兼容性上会有这样那样的问题)。然后找来一张CD-R光盘,刻录。(听说硬盘安装比较麻烦)

然后把新硬盘的硬盘线给拔了(之前在新硬盘上装windows的时候就因为在老硬盘上有过系统,在引导的时候出过问题)。

从光盘启动

顺利进入引导,选择中文,顺利安装.......

安装完毕后,重启,进入ubuntu系统,此时的分辨率默认给识别成1024*760。
按照之前在wiki中记录的资料,进行初始设置。选择中文....。(更新花了我三个小时左右)
一切完成后再次重启,系统顺利变成中文。可能是我急于求成,系统中文化完成后,更新系统软件的时候我就开始配显卡了,也许这就是后来一系统麻烦的源头...................

然后就开始了漫长的显卡安装过程。
我第一次用ubuntu的时候就是因为显卡没配好放弃使用的。

首先找到论坛中“常用硬件支持”的置顶的文章
http://forum.ubuntu.org.cn/viewtopic.php?t=26188
然后照着它提供的方法,一个个挨着试。
配置完毕后,重启,
在启动的时候进入登陆前,跳出一个警告框,因为是液晶显示器,看不清字,就选了第三项。
进入系统后,分辨率变成800*600
在系统首选项中显示器和显卡的配置菜单中,因为三星的没有我这个型号的,就选了LCD 1680*1050这一项(我的分辨率)。
在“受限驱动”中,勾选上了ATI驱动。重启
结果,登陆后,黑屏。显示器没信号。
一个晚上过去。
第二个晚上,又找了一篇文章,忘了是哪个了,安装,结果花屏,最后凭着感觉,找到选择显卡和显示器的菜单,胡选了一通。重启后,又恢复到VESA显卡,plug n play显示器,800*600
就这样反反复复,一个晚上又过去。到这时,系统源才更新完毕。
白天,我在搜索引擎上翻了许久,终于找到一条命令,改变了以后的事情。
晚上回去后,再次找到“受限硬件”,把ATI驱动勾上。重启,黑屏。
然后断电源,重新启动到recover模式,运行命令,
代码:
sudo dpkg-reconfigure xserver-xorg


重新配置xorg文件。
除了显卡,显示器和分辨率设置外,其它都不要改,一路OK
在显卡选择是,选择fglrx,显示器分辨率选择1680*1050,其它的默认,因为我的独立显卡,选择RAM的时候不要填。集成显卡的应该要填上你想分配的显存。
完成后,重启机器。

结果顺利进入系统,在“受限驱动”中,ATI显卡顺利启动。分辨率已成为1680*1050。这时系统默认的字体有点瘦,我给重新选择了个字体。在“显卡和显示器”中,显卡已经是fglrx,之前在这里没有这个fglrx选项的。

我想,既然驱动装好了,那compiz应该很容易吧。

我找到这篇文章
http://forum.ubuntu.org.cn/viewtopic.php?t=96952
到第11步的时候都还很正常
CCMS顺利的出现在系统菜单中
第第12步就出问题了
运行sudo gedit /etc/X11/xorg.conf
找到
# Section "Extensions"
# Option "Composite" "0"
# EndSection
我的xorg.conf中是这样的
Section "Extensions"
Option "Composite" "0"
EndSection
没有#号,我也不太明白有什么区别,就照着说明给删了

运行到下面说的
然后修改compiz初始文件
代码:
sudo gedit /usr/bin/compiz

打开后,找不到文章中所说的含有# Driver whitelist这一项!
也找不到含有# blacklist based on the pci ids的项目
结果自然也就没法照着文章中所说的方法修改!

无法进行下去,也没法安装其它文章中所说的ico图标,于是我关闭终端。效果中的高级效果也没法启动,不过此时多了一个选择就是“GTK设置”,虽然依然没法选择

我打开CCMS,进行了设置,结果对于里面所说的super键迷茫了许久,根本没这键。后来在QQ群里才知道原来就是平时用的win键。
设置完,重机机器,3D无法激活...,效果-高级中的选项也没法选,依然是出错警告。

第四天白天,我加了几个ubuntu的QQ群,但都像死人一样,没人回答我的问题。
第四天晚上,我把那个出错警告给google了一下,还真找到了解决办法,方法和
http://forum.ubuntu.org.cn/viewtopic.php?t=96952中说的正好相反,要启用XGL。我的驱动是8.4版的!应该是新驱动,不像它说的新驱动不需要xgl。
按照google到的文章,打开新立得,找到xgl-server,安装之。重启计算机。结果,黑屏。
再次进入recover模式,运行sudo dpkg-reconfigure xserver-xorg,更改显卡和分辨率设置,
再次启动,进入效果-高级设置,选择自定义GTK选择(最后一个),这时出错信息不再
再按照http://forum.ubuntu.org.cn/viewtopic.php?t=104839
结果,心动的3D桌面终于出现!

这其间还有许多细节没有说,虽然折腾了很久,但还是小有成就感的。总之,我的经验就是,不能完全按照别人的经验去错,只能是参考,因为每个人的机器硬件都不太一样,对于linux这种系统来说,配置上都会有这样那样不同;安装出错不怕,把出错信息google一下,基本上都有解决办法;系统源更新完,保存系统是最新的再去配ATI的显卡。[/code]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-16 11:00 
头像

注册: 2006-10-25 18:10
帖子: 2677
地址: 长沙
送出感谢: 0 次
接收感谢: 0 次
sudo dpkg-reconfigure xserver-xorg

这也是我配置显示的最后杀手锏了...


_________________
你是自由的。别人也是。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-16 12:01 
头像

注册: 2007-01-28 23:00
帖子: 2682
地址: @江西|南昌@
送出感谢: 0 次
接收感谢: 0 次
ATI显卡 现在安装已经比较方便了。

arch 就是几条命令就OK了。主要是配置好自己的 XORG 驱动好装的!


_________________

Do as you would be done by !


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [分享]求人不如求已,我的ATI x1600+22寸宽屏启动3D桌面的经历
帖子发表于 : 2008-04-16 14:16 

注册: 2008-04-10 1:10
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我也折腾很久了,今天干脆重装了系统来搞ati驱动问题。。。
我的卡是ati 9550
为了节省时间我只装了基本系统,用apt网络安装了X环境的基本包
我是按照这个帖子的方法做的:
http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=
一直完成到这两步都是正常的
#aticonfig --initial
#aticonfig --overlay-type=Xv
重启之后

#fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon 9550 / X1050 Series
OpenGL version string: 1.4 (2.1.7412 Release)

Segmentation fault

fgl_glxgears 根本起不来
# fgl_glxgears
Using GLX_SGIX_pbuffer
Segmentation fault


# glxinfo |grep -e 'direct' -e 'OpenGL'
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon 9550 / X1050 Series
OpenGL version string: 1.4 (2.1.7412 Release)
OpenGL extensions:



没有天理阿,重装了系统,该是最干净了吧,结果还是不行。。。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-16 15:54 

注册: 2008-04-10 1:10
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
终于,显卡驱动装上了,受楼主启发,我没有再按照其他帖子说的,直接安装了ait官方的那个驱动包*.run
哈哈,驱动竟然装上了,现在就差compiz了,不知道直接用官方的驱动能不能开compiz
继续折腾。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译