[分享]8.04ATI显卡的3D桌面问题总结

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
dwz35296
帖子: 8
注册时间: 2008-05-07 11:56
送出感谢: 0
接收感谢: 0

[分享]8.04ATI显卡的3D桌面问题总结

#1

帖子 dwz35296 » 2008-05-08 9:50

我的显卡是ATI的X1950。刚刚装好ubuntu8.04的老是搞不定3D桌面,顶多只能开系统自带的扩展特效。:em21 后来找到了一篇关于ATI开3D桌面的文章http://hi.baidu.com/amnour/blog/item/b2 ... 79867.html
文章里是用ubuntu的“受限驱动”,而我用的是ATI的官方驱动。现在ATI的官方驱动是8.4版,在驱动说明里面有特别指出支持AiGLX,照理来说应该也可以开3D桌面的~我对照了一下作者安装的步骤跟我的差不多,只是再安装compiz前多了一步:

代码: 全选

sudo apt-get install xserver-xgl
于是我产生了疑问:莫非之前是因为没有安装xgl才无法打开3D桌面的?:em23
想到这里,马上动手试试~结果也成功了 :em05
看来,ATI不能打开的原因是因为没有安装xgl~只要安装了xgl,无论是“受限驱动”还是ATI自己的驱动都可以打开3D桌面的~ :em11
至于有很多朋友提出的桌面数问题,其实可以不用理会~只要设定为4-1-1就可以了~ :em08
安装ATI的官方驱动的方法也十分简单:
第一步当然是下载驱动,可以到ATI官方下载,也可以去驱动之家。
第二步是解压,解压出来的文件可以随便放。
第三步就是安装了~打开终端,键入

代码: 全选

sudo
,然后把解压出来的".run"文件拖进终端然后回车,这样就会出现安装向导,跟windows的差不多~一直"next"就ok了~
还有一部分朋友安装好ATI的官方驱动,重启后白屏的问题(本人只出现过白屏,黑屏的还没有见过),只需要进入GNOME安全模式下,打开终端运行

代码: 全选

sudo aticonfig --initial -f
就可以解决。
苍穹猪
帖子: 56
注册时间: 2008-04-08 16:44
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 苍穹猪 » 2008-05-08 13:07

顶,我也是ATI显卡,不过我的特效一直就好,看LZ如此努力,沙发就我坐吧!!!
若无缘,六道之间三千大千世界,百万菩提众生,为何与我笑颜独展,惟独与汝相见?
若有缘,待灯花百结之后,三尺之雪,一夜发白,至此无语,却只有灰烬,没有复燃?
头像
hijay
帖子: 83
注册时间: 2008-04-26 17:15
送出感谢: 0
接收感谢: 0

#3

帖子 hijay » 2008-05-08 21:32

我的也是A卡。原来的7.10和现在的8.04支持都挺好的呀
kingpin
帖子: 263
注册时间: 2007-11-03 16:37
送出感谢: 0
接收感谢: 0

#4

帖子 kingpin » 2008-05-08 22:29

买了A卡就一个字,后悔

:evil: :evil:
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

#5

帖子 hcym » 2008-05-08 22:42

kingpin 写了:买了A卡就一个字,后悔

:evil: :evil:

ls多了一个字

:lol:
xuco
帖子: 794
注册时间: 2008-01-30 19:19
送出感谢: 0
接收感谢: 0

#6

帖子 xuco » 2008-05-08 22:52

第三步就是安装了~打开终端,键入
代码:
sudo


哈哈哈,键入,我要馒头吧
mech
帖子: 466
注册时间: 2007-09-06 16:07
送出感谢: 0
接收感谢: 0

Re: [分享]8.04ATI显卡的3D桌面问题总结

#7

帖子 mech » 2008-05-09 8:48

dwz35296 写了:我的显卡是ATI的X1950。刚刚装好ubuntu8.04的老是搞不定3D桌面,顶多只能开系统自带的扩展特效。:em21 后来找到了一篇关于ATI开3D桌面的文章http://hi.baidu.com/amnour/blog/item/b2 ... 79867.html
文章里是用ubuntu的“受限驱动”,而我用的是ATI的官方驱动。现在ATI的官方驱动是8.4版,在驱动说明里面有特别指出支持AiGLX,照理来说应该也可以开3D桌面的~我对照了一下作者安装的步骤跟我的差不多,只是再安装compiz前多了一步:

代码: 全选

sudo apt-get install xserver-xgl
于是我产生了疑问:莫非之前是因为没有安装xgl才无法打开3D桌面的?:em23
想到这里,马上动手试试~结果也成功了 :em05
看来,ATI不能打开的原因是因为没有安装xgl~只要安装了xgl,无论是“受限驱动”还是ATI自己的驱动都可以打开3D桌面的~ :em11
至于有很多朋友提出的桌面数问题,其实可以不用理会~只要设定为4-1-1就可以了~ :em08
安装ATI的官方驱动的方法也十分简单:
第一步当然是下载驱动,可以到ATI官方下载,也可以去驱动之家。
第二步是解压,解压出来的文件可以随便放。
第三步就是安装了~打开终端,键入

代码: 全选

sudo
,然后把解压出来的".run"文件拖进终端然后回车,这样就会出现安装向导,跟windows的差不多~一直"next"就ok了~
还有一部分朋友安装好ATI的官方驱动,重启后白屏的问题(本人只出现过白屏,黑屏的还没有见过),只需要进入GNOME安全模式下,打开终端运行

代码: 全选

sudo aticonfig --initial -f
就可以解决。
不需要装xgl,你只需要在xorg.conf里面添加 AIGLX 以及 composite相关的参数就行了。
kingpin
帖子: 263
注册时间: 2007-11-03 16:37
送出感谢: 0
接收感谢: 0

#8

帖子 kingpin » 2008-05-09 9:48

关键是开了3D看video会闪。
anqing
帖子: 150
注册时间: 2008-05-04 21:10
送出感谢: 0
接收感谢: 0

#9

帖子 anqing » 2008-05-09 10:15

ati的官方驱动才叫受限驱动
而ub8.04自带的驱动叫开源驱动
我是a9600,用开源驱动,一直没有问题。
而且我没有装xgl
楼主,不知有没有试过,用开源的驱动安装3d且不装xgl
anqing
帖子: 150
注册时间: 2008-05-04 21:10
送出感谢: 0
接收感谢: 0

#10

帖子 anqing » 2008-05-09 10:29

其实,就这一句sudo apt-get install compizconfig-settings-manager就够了
头像
冲浪板
论坛版主
帖子: 7466
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

#11

帖子 冲浪板 » 2008-05-10 7:27

我的没“水”效果,Radeon 9200 PRO
sirxenofex
帖子: 204
注册时间: 2008-01-07 16:39
送出感谢: 0
接收感谢: 0

#12

帖子 sirxenofex » 2008-05-10 19:49

不一定。那是你的机器的问题。我这个机器LiveCD都是自动开启compiz的,开源驱动照样开compiz。不用XGL也是可以的,因为还有AIGLX。

话说Ubuntu自带的驱动好像不完全是开源的,我看有载入fglrx的内核模块。
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#13

帖子 syrano » 2008-06-08 15:04

LZ :oops: 疯了

好好的开源驱动不用,去搞什么受限驱动,
扩展特效都打开了,说明你的开源驱动支持compiz
3D没有,是因为你没有设置。
3D谁都是手动打开的。
建议lz看看关于compiz fusion设置的贴子
kinglead
帖子: 21
注册时间: 2007-11-13 15:54
送出感谢: 0
接收感谢: 0

#14

帖子 kinglead » 2008-06-28 17:35

我装了xserver-xgl,结果再重启的话驱动都显示不对了.
在我的机器上是不能装的,不过好像LZ的貌似正常啊.
现在我的3D还是没搞定,在xorg.conf把Composite和AIGLX设置一下再试试.
头像
maynnd
帖子: 32
注册时间: 2008-05-28 23:12
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 maynnd » 2008-06-28 17:46

支持很好
效果很好
回复

回到 “桌面特效”