当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问使用compiz时,你们的图形界面反应慢吗,ati 9600?
帖子发表于 : 2008-05-10 12:08 

注册: 2007-10-11 10:08
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
我的是ati 9600, ubuntu 8.04。启用compiz后,图形界面总体反应有些慢,特别是浏览网页的时候。如果把compiz关掉就流畅很多,完全没有问题。试了开源和闭源驱动,都一样。闭源驱动的glxgears帧数反了一倍,但是图形界面反应还是慢。Windows下非常流畅。

是我安装有问题吗?你们有没有同样问题。按理说9600对付一般2d加速完全没有问题。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-10 19:46 

注册: 2008-01-07 16:39
帖子: 204
送出感谢: 0 次
接收感谢: 0 次
用Fedora 8的时候ATI的驱动就让我头疼了好一阵子。后来成功驱动了,但是出现了你这种情况:Firefox下卷动网页很慢。但现在Ubuntu好了,也不知道为什么。我的卡是9800SE,跟你的应该性能差不多


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-10 19:58 
头像

注册: 2005-05-14 21:17
帖子: 97
送出感谢: 0 次
接收感谢: 0 次
X和网页浏览器一直是CPU资源耗用大户。如果启用compiz等3D窗口管理器,没有开启硬件加速的话,X就会狂吃CPU资源,所以一旦浏览网页,桌面特效就会不流畅。
你可以用top命令或系统管理器查看一下资源占用的情况就会明白了。
解决办法只有一个,开启显卡的硬件加速,并将性能最优化。
BTW:我用的是Gentoo,ATI9550 128M的显卡,开启Compiz的一般特效后,曾经也出现过楼主所述的情况。不过后来随着开源驱动的完善,我的A卡已经可以在开启Firefox浏览网页的情况下流程地跑Compiz了。
PS:机器性能也是影响3D 窗口管理器的主要因素。因为以我的配置(P4赛扬3.2G,1G ram,Ati9550 128M)无论是跑特效全卡的compiz还是跑特效全开的Vista,都显得很吃力。所以楼主的硬件不是很强悍的话,就不要追求过多、过奢华的3D特效了。


_________________
Gentoo,让菜鸟闪开。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-10 20:11 
头像

注册: 2008-02-17 23:47
帖子: 22110
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
LS有理,不过我的expree200集显,赛羊D331,1G ram,玩Vista还算马马虎虎,可是Compiz就感觉不是太爽了,我看还是Compiz最狠。
当然啦,Compiz的名堂也比Vista强捍多了。
所以LZ不爽的话,没办法,换卡吧 8)


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-11 2:45 

注册: 2007-10-11 10:08
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
多谢大家的恢复。看来还是cpu不够强劲。我的是duron 1.2g, 512M。X和firefox吃掉很多cpu,再加上compiz,cpu负荷不了。显卡倒是其次。开源闭源驱动区别非常小。

P.S. 请问3楼的,如何开启显卡硬件加速?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-11 10:10 
头像

注册: 2005-05-14 21:17
帖子: 97
送出感谢: 0 次
接收感谢: 0 次
ilovedvd 写道:
多谢大家的恢复。看来还是cpu不够强劲。我的是duron 1.2g, 512M。X和firefox吃掉很多cpu,再加上compiz,cpu负荷不了。显卡倒是其次。开源闭源驱动区别非常小。

P.S. 请问3楼的,如何开启显卡硬件加速?

安装好最新的驱动,配置好xorg.conf 用glxinfo |grep direct 查看,如果direct render 为yes就是开启了
我用的是gentoo,emerge 的ati开源驱动,ubuntu可以看http://forum.ubuntu.org.cn/viewtopic.php?t=68939


_________________
Gentoo,让菜鸟闪开。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-11 11:34 

注册: 2007-10-11 10:08
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
一直都是direct rendering yes. 闭源,开源都是。看来就是cpu不行了。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-13 9:57 

注册: 2008-01-07 16:39
帖子: 204
送出感谢: 0 次
接收感谢: 0 次
你的CPU是什么?如果你没安装XGL,那么桌面效果依赖于AIGLX,一个Xserver的插件。它不是完全硬件加速,但是基于Xserver本身,因此兼容性较好,因此CPU确实是有影响。但我认为现在是08年,你的CPU应该不会差到足以影响3D桌面性能。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-13 10:58 

注册: 2007-10-11 10:08
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
呵呵,我的cpu确实不强, duron 1.2g。这是6年前的电脑,还用的好好的。我没有安装xgl,用的就是aiglx。据说xgl更消耗cpu。难的折腾了。用top看了下,就是xorg和firefox把cpu都吃掉了。暂时先把compiz关了。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-15 10:16 

注册: 2008-05-15 9:59
帖子: 103
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
学习中。。。。。。。。。。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-15 15:04 

注册: 2008-04-08 9:27
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
ilovedvd 写道:
呵呵,我的cpu确实不强, duron 1.2g。这是6年前的电脑,还用的好好的。我没有安装xgl,用的就是aiglx。据说xgl更消耗cpu。难的折腾了。用top看了下,就是xorg和firefox把cpu都吃掉了。暂时先把compiz关了。

我用的是X3100集成显卡,一般浏览网页的时候XORG占用cpu大概在40%左右,但是不卷动网页很快就会降到最低10%以下了,可是一旦网页中有大的编辑框,嘿嘿那就惨了,CPU直线上升到80%左右,而且一直都是这么高,我始终没有明白怎么回事,不知道是驱动问题?还是firefox问题?还是xorg问题?或者是compiz的问题?
大家用其他的显卡比如NV, ATI的有没有同样的现象呀?帮忙试试吧。谢谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译