当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ATI Driver 8-6的严重bug!
帖子发表于 : 2008-07-08 10:27 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
刚升级AMD690的集成显卡ATI X1250 ,
安装ati-driver-installer-8-6-x86.x86_64.run后,

原来正常的 screensaver基本上都不能用了,
除了少数的非 3D的图片屏保,

现象是从屏保中退出时失去响应,
只有 CTRL+ALT+BACKSPACE

原来装的ati-driver-installer-8-3-x86.x86_64.run,没问题的,

系统是 gusty 。

估计是 GL lib的问题。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-08 10:37 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
GOOGLE了一下:
看来真是bug:


FuturePast wrote on 2006-04-16: (permalink)
This happens with me too, but it seems only with GL or 3d themes/hacks.

If I'm logged in with ssh, killing the process (gnome-screensaver and hack process) or restarting X makes no difference. Shutdown fails too.
No further ssh logins can be made.

Have done dist-upgrade.

Video card: SiS 305.

D

Darren wrote on 2006-04-24: (permalink)
ATI Radeon 8500.

slightly different - but similar.

I see 2D and 3D screensavers without an issue (other than the fact that the resolution is horribly low because of the slow GPU).

Breezy -> Dapper dist-upgrade using US sources today.

HediG wrote on 2006-05-19: (permalink)
ATI Radeon 9800 Pro

The same here, but only with GL or 3D-Themes. Changing to a console is not possible, neither reboot, total freeze.

Dapper Beta, currently updated.

josechu wrote on 2006-05-20: (permalink)
Radeon Mobility M6 LY

My computer also freezes completely with the screensaver.

I have 2.6.15-19 kernel because posterior kernels don't activate my wireless card


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-08 11:00 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
Jerry Schaefer wrote on 2007-04-20: (permalink)
Feisty!

I just spent 13 hours installing the upgrade to 7.04, hoping it would fix
the Gnome-screensaver bug (106060). It didn't. My PC still froze as soon
as I opened the Screensaver window, since Molecule was still selected.

Is there a way to edit or trash the Gnome-screensaver-preferences file?
If I had known this bug would carry through the upgrade, I would have
re-installed 6.10 to clear the preferences file before doing the upgrade.

Jerry


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-08 11:07 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
Tormod Volden wrote on 2008-04-06: (permalink)
"hack" = screensaver graphic/theme. This is slang used by the screensaver authors. The screensaver back-end (gnome-screensaver) just takes care of checking for keyboard activity etc and starts a program (the hack) that draws something on the screen. In fact, any program that just draws something on the screen can be used as a screensaver hack. The hack can be run standalone by running "/usr/lib/xscreensaver/molecule" but will then just run in a window. To test it fullscreen, add the option "-root". But since this will draw on the "root" window which often is hidden by desktop backgrounds etc, try this is in a "failsafe terminal session" from the login screen.

Most of the hacks used by gnome-screensaver come from the "xscreensaver" source package. Ted referred to him changing this bug's attributes, reassigning it to "xscreensaver" so that the relevant developers and bug triagers are noticed about your bug report.

If one particular hack makes the computer crash it is probably a bug in the graphic card driver, triggered by the hack. So usually these bugs end up in the collection of bug reports for the graphic driver in question. The hack makes drawing requests to the graphic subsystem (X11 and for 3D graphics in particular, using the "mesa" libraries) and, in principle, none of these requests (faulty or not) should hang the machine.

Fixing bugs in the card drivers is generally out of scope for the Ubuntu development (limited manpower and thus hard priority decisions), but we try to analyze and isolate the problems, and if we can collect enough details, we forward the bug "upstream", to the developers of the X11 graphic drivers on bugs.freedesktop.org

Can you all please run "lspci -nn | grep VGA" so that we can identify which cards have this exact problem? Can you reproduce it running molecule stand-alone? In window? Fullscreen?

You can force your AGP cards to run PCI instead with the "ForcePCIMode" device option in /etc/X11/xorg.conf. Please try this, and verify in /var/log/Xorg.0.log that the option was correctly applied.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-08 16:52 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-08 16:55 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
xorg 7.1 原来在ATI 8.3 Driver解决的问题,

8.6 的版本 GL 屏保又回去了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-08 21:29 

注册: 2008-02-21 17:20
帖子: 91
地址: GZ
送出感谢: 0 次
接收感谢: 0 次
the same problem for my ATI HD2400 XT

8.4 is all rightt but the 8.6 will crash my computer down as i installed it . so i still use 8.4 .

hope they can fix this bug


_________________
Let's ubuntu


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-12 15:19 
头像

注册: 2007-07-10 10:52
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
我以前用系统自带的能3D,换了驱动就不能,我很后悔!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-16 1:42 

注册: 2007-12-12 1:56
帖子: 178
送出感谢: 0 次
接收感谢: 0 次
想起来,我也碰到同样的问题,看图片,就明白了。


附件:
Screenshot.png
Screenshot.png [ 1.15 MiB | 被浏览 677 次 ]

页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译