当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu8.10的问题,快疯了
帖子发表于 : 2008-08-23 10:47 

注册: 2005-11-21 21:51
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
IBM T60 (ati X1400) ubuntu 8.10

就知道这玩意儿驱动不好装,我以前的6.10死活没升级,这几天突然想升级到8.10,从6.10到7.04到7.10到8.04最后到8.10,相当相当漫长的过程,之前好好的没什么问题,升级到8.10重启,就废了,说什么低级显示模式,驱动照这里http://forum.ubuntu.com.cn/viewtopic.php?t=91097&highlight=&sid=0cb2fc51d6a729e09f6337500d6c5a01死活装不上,前面所有都照着步骤做下来了,到了命令行安装ati驱动时候,完了给个报错,/usr/share/ati/fglrx-install.log内容如下:
代码:
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
 Assuming default VMAP API
 Assuming default munmap API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.26-5-generic/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.26-5-generic'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:365: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:366: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_SetPageNoCache’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1183: error: implicit declaration of function ‘change_page_attr’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_printk’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1785: warning: format not a string literal and no format arguments
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_PosixSecurityCapGetEffectiveVector’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1922: error: implicit declaration of function ‘cap_t’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_PosixSecurityCapSetEffectiveVector’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1930: error: lvalue required as left operand of assignment
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_get_vm_phys_addr’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2439: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2439: error: (Each undeclared identifier is reported only once
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2439: error: for each function it appears in.)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_get_vm_page_table’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2461: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_vm_test_and_clear_dirty’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2525: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2544: error: implicit declaration of function ‘ptep_test_and_clear_dirty’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_request_irq’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2962: error: ‘SA_SHIRQ’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2962: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_pte_phys_addr_str’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3536: error: implicit declaration of function ‘pte_read’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3574: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3574: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3592: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3592: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3599: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3599: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3606: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3606: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3613: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3613: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3620: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3620: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3627: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3627: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3636: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3636: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5439: error: expected specifier-qualifier-list before ‘kmem_cache_t’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KAS_SlabCache_Initialize’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5478: error: ‘kasSlabCache_t’ has no member named ‘routine_type’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5479: error: ‘kasSlabCache_t’ has no member named ‘lock’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5480: error: ‘kasSlabCache_t’ has no member named ‘name’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5484: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5485: error: ‘kasSlabCache_t’ has no member named ‘name’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5485: error: too many arguments to function ‘kmem_cache_create’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KAS_SlabCache_Destroy’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5508: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5518: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5520: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KAS_SlabCache_AllocEntry’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5555: error: ‘kasSlabCache_t’ has no member named ‘routine_type’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5556: error: ‘kasSlabCache_t’ has no member named ‘lock’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5580: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5583: error: ‘kasSlabCache_t’ has no member named ‘lock’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5591: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KAS_SlabCache_FreeEntry’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5619: error: ‘kasSlabCache_t’ has no member named ‘routine_type’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5620: error: ‘kasSlabCache_t’ has no member named ‘lock’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5632: error: ‘kasSlabCache_t’ has no member named ‘cache’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5635: error: ‘kasSlabCache_t’ has no member named ‘lock’
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] 错误 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-5-generic'
make: *** [kmod_build] 错误 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[/quote]

尝试了网上各种安装驱动的方法,都没有成功,错误信息中的change_page_attr也没查出什么结果来,很郁闷,非常郁闷,只好求救了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-23 15:49 
头像

注册: 2008-07-19 12:44
帖子: 3437
地址: 广西(桂)南宁(邕)
送出感谢: 0 次
接收感谢: 76
试试用envyng-gtk这个软件来帮你装ATI驱动,
用envyng安装驱动有个好处就是,有些需要卸载的冲突软件包它会自动帮你卸载,
有些需要安装的支持软件包它会自动帮你安装。


_________________
一善鱼 yq-ysy@163.com

音频数字工作站 Ardour 4 初学者教程  影视特效3D动画 Blender 2.5~2.6 完全教程  图像处理 Krita 3 数字绘画入门


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-25 18:19 

注册: 2005-11-21 21:51
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
zsh@baicker:/var/log$ sudo /usr/share/envy/pulse.py ati
EnvyNG - Version 1.1.1
Traceback (most recent call last):
File "/usr/share/envy/pulse.py", line 79, in <module>
autoChoice(sys.argv[1])
File "/usr/share/envy/pulse.py", line 18, in autoChoice
objects.atiinstallg(data1)
File "/usr/lib/python2.5/site-packages/Envy/objects.py", line 206, in atiinstallg
task.systemcheck()#system/arch compatibility
File "/usr/lib/python2.5/site-packages/Envy/classes.py", line 813, in systemcheck
raise Exception(error)
Exception: EnvyNG ERROR: Your Operating System does not seem to be supported by Envy


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-25 21:06 
头像

注册: 2008-07-19 12:44
帖子: 3437
地址: 广西(桂)南宁(邕)
送出感谢: 0 次
接收感谢: 76
baicker 写道:
zsh@baicker:/var/log$ sudo /usr/share/envy/pulse.py ati

你这命令是作什么用的?envyng在命令行终端的启动命令应该是:
sudo envyng -t


_________________
一善鱼 yq-ysy@163.com

音频数字工作站 Ardour 4 初学者教程  影视特效3D动画 Blender 2.5~2.6 完全教程  图像处理 Krita 3 数字绘画入门


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [问题]ubuntu8.10的问题,快疯了
帖子发表于 : 2008-10-25 0:36 

注册: 2008-09-23 20:51
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
跟我的完全一样,我的是NV 8600GT 死活也装不上驱动,系统版本为8.10 32位

郁闷之极!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [问题]ubuntu8.10的问题,快疯了
帖子发表于 : 2008-10-26 13:03 

注册: 2006-10-24 10:37
帖子: 207
送出感谢: 0 次
接收感谢: 0 次
我刚升到8.10的时候ATI显卡也驱动不了,后来换到台湾的一个源升级了之后就没问题了,你试试看,不然就再等一段时间吧。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [问题]ubuntu8.10的问题,快疯了
帖子发表于 : 2008-10-26 13:28 
头像

注册: 2008-07-19 12:44
帖子: 3437
地址: 广西(桂)南宁(邕)
送出感谢: 0 次
接收感谢: 76
所有手工安装显卡驱动都会遇到升级到ubuntu 8.10后显卡驱动无效的问题,
这是因为ubuntu 8.10的linux内核已经升级改变,所以需要重装显卡驱动。(非受限驱动则没问题)


_________________
一善鱼 yq-ysy@163.com

音频数字工作站 Ardour 4 初学者教程  影视特效3D动画 Blender 2.5~2.6 完全教程  图像处理 Krita 3 数字绘画入门


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译