当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装AWN遇到的问题,我快疯了,查了N种方法都不行,高手帮忙!谢谢
帖子发表于 : 2008-08-31 16:04 

注册: 2008-01-03 18:29
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我是照着下面的方法安装AWN的:
首先添加下面两个源:
sudo gedit /etc/apt/sources.list
deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main
deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main
然后
sudo apt-get update
然后在新德里安装 avant-window-navigator-trunk 和 awn-extras-applets-trunk 了,
sudo apt-get install avant-window-navigator avant-window-navigator-trunk awn-
extras-applets-trunk

但是我运行这个命令时就出现下面的问题,总是安装不起:
sudo apt-get install avant-window-navigator avant-window-navigator-trunk awn-extras-applets-trunk
sudo: cannot get working directory
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
avant-window-navigator 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
avant-window-navigator-trunk: 依赖: avant-window-navigator-data-trunk (>= 0.3.1~bzr477-hardy1-1) 但是它将不会被安装
依赖: libawn0-trunk (>= 0.3.0) 但是它将不会被安装
依赖: python-awn-trunk (>= 0.3.1~bzr477-hardy1-1) 但是它将不会被安装
冲突: avant-window-navigator 但是 0.2.1-0ubuntu2 正要被安装
awn-extras-applets-trunk: 依赖: libawn0-trunk (>= 0.3.0) 但是它将不会被安装
依赖: libpango1.0-0 (>= 1.20.5) 但是 1.20.1-1 正要被安装
依赖: libwebkit-1.0-1 (>= 0~svn31841) 但是它将不会被安装
E: 无法安装的软件包

大家帮个忙,谢谢!

谢谢各位的回答,我重装系统了!


最后由 hackboss 编辑于 2008-09-02 13:59,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-31 16:42 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
你是8.10吗?


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-31 19:52 

注册: 2008-01-03 18:29
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我是8.04的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-31 20:20 
头像

注册: 2008-06-22 9:47
帖子: 36
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
follow your steps 'n install mine....


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-31 23:08 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
你先安装aptitude
代码:
sudo apt-get install aptitude

然后
代码:
sudo aptitude search awn

看看要安装什么包。。。
安装相应的就行了


_________________
Ubuntu User


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-01 10:36 

注册: 2008-01-03 18:29
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
god@god-desktop:~$ sudo apt-get install aptitude
[sudo] password for god:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
aptitude 已经是最新的版本了。
已经不需要下列自动安装的软件包:
libglitz-glx1 libglitz1
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件未被升级。

用了你说的命令就出现这个,该怎么处理?

我是菜鸟,说详细点,谢谢


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-01 14:52 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
hackboss 写道:
god@god-desktop:~$ sudo apt-get install aptitude
[sudo] password for god:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
aptitude 已经是最新的版本了。
已经不需要下列自动安装的软件包:
libglitz-glx1 libglitz1
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件未被升级。

用了你说的命令就出现这个,该怎么处理?

我是菜鸟,说详细点,谢谢

说明aptitude已经安装过了
代码:
sudo apt-get autoremove

清除没有关联的依赖。。。
然后
代码:
sudo aptitude search awn


_________________
Ubuntu User


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-09-02 10:34 

注册: 2008-05-23 14:28
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
怎么清除阿 !!!!!我也 遇到这样的问题!
meis@meis-desktop:~$ sudo aptitude search awn
p awn-extras-applets-trunk - A collection of applets for Avant Window N
p awn-manager - A manager for the preferences of avant-win
p awn-manager-trunk - A preferences manager for avant-window-nav
p libawn-dev - library for avant-window-navigator - devel
p libawn-dev-trunk - library for avant-window-navigator - devel
p libawn-doc-trunk - library for avant-window-navigator - devel
p libawn0 - library for avant-window-navigator
p libawn0-dbg-trunk - library for avant-window-navigator - debug
p libawn0-trunk - library for avant-window-navigator
p python-awn - library for avant-window-navigator - Pytho
p python-awn-trunk - Python bindings for avant-window-navigator
v python2.5-awn-trunk -
p vala-awn-trunk

而且现在双击窗口自动卷起。而不是最大化~在系统--手选项--窗口 设置不起作用!

谢谢!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-09-02 10:42 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
没办法,源依赖太复杂...有能力的可以尝试自己编译...


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-09-02 12:03 

注册: 2008-05-23 14:28
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
谢谢~我 重新安装~~~~


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-09-07 8:34 

注册: 2006-08-26 4:43
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
http://www.bpio.org/blog/read.php?219


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译